Jump to content

Beelink GT King - stability issues?


Recommended Posts

@balbes150(sorry to @ you and hope youre keeping well!!)


I have a Beelink GT King, which its motherboard lists as being version 2.2-S922X-4G-64G/A It has a terrible stability problem using meson-g12b-gtking.dtb (I have tried the pro file as well as others in case, but it wont boot with those).


The problem I am experiencing is that when any high level of file transfers occur, the system freezes. The mouse etc locks up, the time/clock freezes at the time of the system hanging and the system drops off the network (stops responding to ping).


Ive tried multiple revisions of Ubuntu that can be currently downloaded on Yandex, and been through Bionic, bullseye etc... and through 5.3 up to 5.7. All suffer the same issue. The system will stay stable as long as you dont do very much, however, examples of things that have caused the system to freeze are:


1) sudo apt update

2) ddbr

3) coping the test.mp4 file on the desktop multiple times

4) trying to install to emmc (never been able to get through an install to emmc)

5) running multiple tasks at the same time.

7) Trying to copy a 1GB file

8) etc


In short, the issue is repeatable via various methods.


Ive tried SD cards, USB flash drives and USB SSD'd... all have the same issue.


Because the system freezes/locks up, I cant give any diagnostics.... though it runs 100% fine in Coreelec and Android.


The only working DTB file I can find is the one thats coming with Armbian at the minute, and older revisions seem to be the same file.  (50,214 bytes size on disk).


The only thing I experienced in the past that locked a system up like this was the WIFI being used.... but Im on Ethernet. It does seem to be some buffer issue or similar with the disk access.


Any suggestions? (as I cant find anything in the forums and see no issues with the boot process)


My dmesg output is in a post below (if it helps)


Many thanks


If I use that DTB file with Armbian, it actually looks like my system is trying to boot... it does actually go to a black screen, though there is no scrolling text, though going to a black screen is further than other incorrect DTB files get to). Not sure if that helps in any way.

Link to comment
Share on other sites

Help Armbian team helping you

If its worth anything, this is my dmesg output, when I have booted with the Armbian GTKing DTB file and I am at the desktop/workspace screen (before it freezes)



Link to comment
Share on other sites

The same mate i have GT Pro SB9X tried ubuntu images and Debian compiled images stays stable then reboots randomly. I just need this to run cgminer for gekko any one out there with a stable image on unbunto or debian please..

Link to comment
Share on other sites

@balbes150 Thanks for the reply. I appreciate that you dont have one of these with you to test/look at.


Could I ask however.... would you think that this is an issue with the drivers within Ubuntu ... OR.... settings within the DTB file (frequencies/drivers used)? 


I have added the UART output of both Armbian's and Coreelec's DTB files, when booting Armbian with them... if there is anything you can see in those? (if you have the time to look)


Armbian meson-g12b-gtking.dtb UART output



Perhaps this is the relevant bit?? (as my issue is to do with high disk activity)


[    6.647386] EXT4-fs (sda2): re-mounted. Opts: commit=600,errors=remount-ro

[    6.922303] Unable to handle kernel NULL pointer dereference at virtual address 00000000000000f5

[    6.927276] Mem abort info:

[    6.929986]   ESR = 0x96000004

[    6.932759]   EC = 0x25: DABT (current EL), IL = 32 bits

[    6.939615]   SET = 0, FnV = 0

[    6.946536]   EA = 0, S1PTW = 0

[    6.947931] Data abort info:

[    6.949280]   ISV = 0, ISS = 0x00000004

[    6.949282]   CM = 0, WnR = 0

[    6.949287] user pgtable: 4k pages, 48-bit VAs, pgdp=00000000a220c000

[    6.956371] [00000000000000f5] pgd=0000000000000000

[    6.966305] Internal error: Oops: 96000004 [#1] PREEMPT SMP



Also, I assume I can connect a serial cable to the TX/RX of the device during boot, look at the output, to try find why a DTB file might not start booting?


Im happy to research. learn and give this a go, if you think that may be a good direction to try.....


If you have any thoughts or suggestions on this, please let me know?

Link to comment
Share on other sites

I have the same issue, 


Here is my uart output when the device locks up. 

 fuse: init (API version 7.31)
[  157.006866] SError Interrupt on CPU5, code 0xbf000000 -- SError
[  157.006872] CPU: 5 PID: 1115 Comm: 
[  157.006875] Hardware name: Beelink GT-King Pro (DT)
[  157.006878] pstate: 80000005 (Nzcv daif -PAN -UAO)
[  157.006881] pc : _raw_spin_unlock_irqrestore+0xc/0x68
[  157.006883] lr : add_wait_queue+0x50/0x68
[  157.006885] sp : ffff800015943940
[  157.006888] x29: ffff800015943940 x28: 0000000000000019 
[  157.006894] x27: ffff800015943abc x26: ffff0000877a1800 
[  157.006900] x25: 0000000000000020 x24: ffff0000877a1801 
[  157.006906] x23: 0000000000000000 x22: ffff00000533f000 
[  157.006911] x21: ffff00000533f038 x20: ffff00008b561d40 
[  157.006916] x19: ffff00000533f020 x18: 00000000000000c0 
[  157.006921] x17: 0000000000000000 x16: 0000000000000000 
[  157.006927] x15: 0000000000000000 x14: dead000000000122 
[  157.006932] x13: ffffffffffffffff x12: fffffdfffff4df48 
[  157.006937] x11: 0000000000000191 x10: 0000000000000000 
[  157.006942] x9 : 0000000000000000 x8 : ffff800012931cc0 
[  157.006947] x7 : 0000000000000000 x6 : ffff0000b8ff9b70 
[  157.006953] x5 : ffff8000129321c0 x4 : 0000000000000000 
[  157.006958] x3 : ffff00008b561d48 x2 : 0000000000000000 
[  157.006963] x1 : 0000000000000000 x0 : ffff00008b561d40 
[  157.006970] Kernel panic - not syncing: Asynchronous SError Interrupt
[  157.006974] CPU: 5 PID: 1115 Comm: 
[  157.006977] Hardware name: Beelink GT-King Pro (DT)
[  157.006979] Call trace:
[  157.006981]  dump_backtrace+0x0/0x1c8
[  157.006983]  show_stack+0x18/0x28
[  157.006985]  dump_stack+0xb8/0x100
[  157.006987]  panic+0x15c/0x330
[  157.006989]  nmi_panic+0x8c/0x90
[  157.006992]  arm64_serror_panic+0x78/0x84
[  157.006994]  do_serror+0x84/0x140
[  157.006996]  el1_error+0x8c/0x108
[  157.006999]  _raw_spin_unlock_irqrestore+0xc/0x68
[  157.007001]  __pollwait+0xc8/0x100
[  157.007003]  rfkill_fop_poll+0x6c/0x70 [rfkill]
[  157.007006]  do_sys_poll+0x28c/0x550
[  157.007008]  __arm64_sys_ppoll+0xb4/0xe8
[  157.007011]  el0_svc_common.constprop.0+0x74/0x1f0
[  157.007013]  do_el0_svc+0x24/0x90
[  157.007015]  el0_sync_handler+0x178/0x2b8
[  157.007017]  el0_sync+0x158/0x180
[  157.007049] SMP: stopping secondary CPUs
[  157.007052] Kernel Offset: disabled
[  157.007054] CPU features: 0x080002,20082004
[  157.007057] Memory Limit: none


It is a kernel panic caused by an unidentified  interrupt.


I hope someone can advice on what could be wrong with the dtb. 


Link to comment
Share on other sites

With the exception of Nvidia, The "GT king Pro" is probably the most powerful TV box on the market today.  Slightly surprised there has been no further progression with an Armbian port. If there was an Armbian port with everything working.  I would buy this box tomorrow to use as a desktop computer.



Link to comment
Share on other sites

  • Werner locked this topic
This topic is now closed to further replies.

  • Create New...