0
erew

Beelink GT King - stability issues?

Recommended Posts

@balbes150(sorry to @ you and hope youre keeping well!!)

 

I have a Beelink GT King, which its motherboard lists as being version 2.2-S922X-4G-64G/A It has a terrible stability problem using meson-g12b-gtking.dtb (I have tried the pro file as well as others in case, but it wont boot with those).

 

The problem I am experiencing is that when any high level of file transfers occur, the system freezes. The mouse etc locks up, the time/clock freezes at the time of the system hanging and the system drops off the network (stops responding to ping).

 

Ive tried multiple revisions of Ubuntu that can be currently downloaded on Yandex, and been through Bionic, bullseye etc... and through 5.3 up to 5.7. All suffer the same issue. The system will stay stable as long as you dont do very much, however, examples of things that have caused the system to freeze are:

 

1) sudo apt update

2) ddbr

3) coping the test.mp4 file on the desktop multiple times

4) trying to install to emmc (never been able to get through an install to emmc)

5) running multiple tasks at the same time.

7) Trying to copy a 1GB file

8) etc

 

In short, the issue is repeatable via various methods.

 

Ive tried SD cards, USB flash drives and USB SSD'd... all have the same issue.

 

Because the system freezes/locks up, I cant give any diagnostics.... though it runs 100% fine in Coreelec and Android.

 

The only working DTB file I can find is the one thats coming with Armbian at the minute, and older revisions seem to be the same file.  (50,214 bytes size on disk).

 

The only thing I experienced in the past that locked a system up like this was the WIFI being used.... but Im on Ethernet. It does seem to be some buffer issue or similar with the disk access.

 

Any suggestions? (as I cant find anything in the forums and see no issues with the boot process)

 

My dmesg output is in a post below (if it helps)

 

Many thanks

 

If I use that DTB file with Armbian, it actually looks like my system is trying to boot... it does actually go to a black screen, though there is no scrolling text, though going to a black screen is further than other incorrect DTB files get to). Not sure if that helps in any way.

Share this post


Link to post
Share on other sites

If its worth anything, this is my dmesg output, when I have booted with the Armbian GTKing DTB file and I am at the desktop/workspace screen (before it freezes)

 

 

Share this post


Link to post
Share on other sites

The same mate i have GT Pro SB9X tried ubuntu images and Debian compiled images stays stable then reboots randomly. I just need this to run cgminer for gekko any one out there with a stable image on unbunto or debian please..

Share this post


Link to post
Share on other sites

@balbes150 Thanks for the reply. I appreciate that you dont have one of these with you to test/look at.

 

Could I ask however.... would you think that this is an issue with the drivers within Ubuntu ... OR.... settings within the DTB file (frequencies/drivers used)? 

 

I have added the UART output of both Armbian's and Coreelec's DTB files, when booting Armbian with them... if there is anything you can see in those? (if you have the time to look)

 

Coreelec g12b_s922x_beelink_gt_king_rev_a.dtb UART output

https://pastebin.com/Egb9L5sz

 

Armbian meson-g12b-gtking.dtb UART output

https://pastebin.com/QmFt7WGC

 

Perhaps this is the relevant bit?? (as my issue is to do with high disk activity)

 

[    6.647386] EXT4-fs (sda2): re-mounted. Opts: commit=600,errors=remount-ro

[    6.922303] Unable to handle kernel NULL pointer dereference at virtual address 00000000000000f5

[    6.927276] Mem abort info:

[    6.929986]   ESR = 0x96000004

[    6.932759]   EC = 0x25: DABT (current EL), IL = 32 bits

[    6.939615]   SET = 0, FnV = 0

[    6.946536]   EA = 0, S1PTW = 0

[    6.947931] Data abort info:

[    6.949280]   ISV = 0, ISS = 0x00000004

[    6.949282]   CM = 0, WnR = 0

[    6.949287] user pgtable: 4k pages, 48-bit VAs, pgdp=00000000a220c000

[    6.956371] [00000000000000f5] pgd=0000000000000000

[    6.966305] Internal error: Oops: 96000004 [#1] PREEMPT SMP

 

Not that Ive ever done it before, but Im thinking I might be able to compare settings in the Coreelec DTB file and the current Armbian one, to see if I can find differences in drivers/frequencies etc, build a new DTB and test to see if I can get a working solution.

 

Also, I assume I can connect a serial cable to the TX/RX of the device during boot, look at the output, to try find why a DTB file might not start booting?

 

Im happy to research. learn and give this a go, if you think that may be a good direction to try.....

 

If you have any thoughts or suggestions on this, please let me know?

Share this post


Link to post
Share on other sites
(edited)

https://youtu.be/VHhmbaheUKg

Something is not right while installing anything heavy on Armbian_20.08.0_Arm-64_focal_current_5.7.0-rc7, in this case lubuntu-desktop package. According to the video I uploaded, it seems to be a kernel panic: Asynchronous SError Interrupt.

Edited by bacharm1307

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0