OPi 3 display problem(?) [partially SOLVED]


Recommended Posts

Hi there,

just got OPi3 (4x 1.8GHz, 2GB RAM, eMMC), and I have (probably) issue with display settings (resolution / refresh rate?).

I have an 1280x1024@60Hz VGA monitor, connected to an KVM switch (VGA+USB), then to HDMI->VGA converter. It worked OK for my 2 OPiPC+.

Now what happens when I connect OPi3 instead od one of OPiPC+:

- installed "OOB" Armbian Buster for OPi3, (server),

- during initial startup there was NO question about monitor resolution (differs from initial startup for PC+),

- only login / new user dialog.

- now screen "flickers", text mode for few seconds, then blank screen, "power" LED of monitor is lit, like there is signal. Random periods.

- can user armbian-config to set up basic parameters, network and install "desktop",

- can SSH and do remote X session,

- during boot-up to GUI there is NO display at all.

- if I log in as root (CLI) and then issue "startx", GUI starts, but shifted 1/4 screen high (part of GUI offscreen), 1/4 screen high black bar on bottom.

 

Questions:

- hardware problem, or Armbian config problem?

- how do I change screen resolution / refresh rate (CLI or GUI)? For text mode and X.

Link to post
Share on other sites
Donate and support the project!

Ok, some progress, attached serial to USB converter:

- can enter bootloader,

- as in mentioned "howto" issued:

"setenv video-mode sunxi:1280x1024-24@60,monitor=hdmi,hpd=0,edid=0
    saveenv
    reset"

 

Here is bootloader output:

U-Boot SPL 2019.10-armbian (Feb 17 2020 - 08:24:44 +0100)
DRAM: 2048 MiB
Trying to boot from MMC1
NOTICE:  BL31: v2.2(debug):a04808c-dirty
NOTICE:  BL31: Built : 08:24:33, Feb 17 2020
NOTICE:  BL31: Detected Allwinner H6 SoC (1728)
NOTICE:  BL31: Found U-Boot DTB at 0xc07f048, model: OrangePi 3
INFO:    ARM GICv2 driver initialized
NOTICE:  PMIC: Probing AXP805
NOTICE:  PMIC: AXP805 detected
INFO:    BL31: Platform setup done
INFO:    BL31: Initializing runtime services
INFO:    BL31: cortex_a53: CPU workaround for 855873 was applied
INFO:    BL31: Preparing for EL3 exit to normal world
INFO:    Entry point address = 0x4a000000
INFO:    SPSR = 0x3c9


U-Boot 2019.10-armbian (Feb 17 2020 - 08:24:44 +0100) Allwinner Technology

CPU:   Allwinner H6 (SUN50I)
Model: OrangePi 3
DRAM:  2 GiB
MMC:   mmc@4020000: 0, mmc@4022000: 1
Loading Environment from EXT4... OK
In:    serial@5000000
Out:   serial@5000000
Err:   serial@5000000
Net:   No ethernet found.
Hit any key to stop autoboot:  0 
=>  env print -a

arch=arm
baudrate=115200
board=sunxi
board_name=sunxi
boot_a_script=load ${devtype} ${devnum}:${distro_bootpart} ${scriptaddr} ${prefix}${script}; source ${scripta}
boot_efi_binary=if fdt addr ${fdt_addr_r}; then bootefi bootmgr ${fdt_addr_r};else bootefi bootmgr ${fdtcontri
boot_extlinux=sysboot ${devtype} ${devnum}:${distro_bootpart} any ${scriptaddr} ${prefix}${boot_syslinux_conf}
boot_net_usb_start=usb start
boot_prefixes=/ /boot/
boot_script_dhcp=boot.scr.uimg
boot_scripts=boot.scr.uimg boot.scr
boot_syslinux_conf=extlinux/extlinux.conf
boot_targets=fel mmc_auto usb0 pxe dhcp 
bootcmd=run distro_bootcmd
bootcmd_dhcp=run boot_net_usb_start; if dhcp ${scriptaddr} ${boot_script_dhcp}; then source ${scriptaddr}; fi;
bootcmd_fel=if test -n ${fel_booted} && test -n ${fel_scriptaddr}; then echo '(FEL boot)'; source ${fel_scripi
bootcmd_mmc0=devnum=0; run mmc_boot
bootcmd_mmc1=devnum=1; run mmc_boot
bootcmd_mmc_auto=if test ${mmc_bootdev} -eq 1; then run bootcmd_mmc1; run bootcmd_mmc0; elif test ${mmc_bootdi
bootcmd_pxe=run boot_net_usb_start; dhcp; if pxe get; then pxe boot; fi
bootcmd_usb0=devnum=0; run usb_boot
bootdelay=1
bootm_size=0xa000000
console=ttyS0,115200
cpu=armv8
dfu_alt_info_ram=kernel ram 0x40080000 0x1000000;fdt ram 0x4FA00000 0x100000;ramdisk ram 0x4FE00000 0x4000000
distro_bootcmd=for target in ${boot_targets}; do run bootcmd_${target}; done
efi_dtb_prefixes=/ /dtb/ /dtb/current/
ethaddr=02:07:bd:2e:ac:23
fdt_addr_r=0x4FA00000
fdtcontroladdr=bbf30940
fdtfile=allwinner/sun50i-h6-orangepi-3.dtb
kernel_addr_r=0x40080000
load_efi_dtb=load ${devtype} ${devnum}:${distro_bootpart} ${fdt_addr_r} ${prefix}${efi_fdtfile}
mmc_boot=if mmc dev ${devnum}; then devtype=mmc; run scan_dev_for_boot_part; fi
mmc_bootdev=0
partitions=name=loader1,start=8k,size=32k,uuid=${uuid_gpt_loader1};name=loader2,size=984k,uuid=${uuid_gpt_loa;
preboot=usb start
pxefile_addr_r=0x4FD00000
ramdisk_addr_r=0x4FE00000
scan_dev_for_boot=echo Scanning ${devtype} ${devnum}:${distro_bootpart}...; for prefix in ${boot_prefixes}; d;
scan_dev_for_boot_part=part list ${devtype} ${devnum} -bootable devplist; env exists devplist || setenv devplt
scan_dev_for_efi=setenv efi_fdtfile ${fdtfile}; for prefix in ${efi_dtb_prefixes}; do if test -e ${devtype} $e
scan_dev_for_extlinux=if test -e ${devtype} ${devnum}:${distro_bootpart} ${prefix}${boot_syslinux_conf}; theni
scan_dev_for_scripts=for script in ${boot_scripts}; do if test -e ${devtype} ${devnum}:${distro_bootpart} ${pe
scriptaddr=0x4FC00000
serial#=82c00007bd2eac23
soc=sunxi
stderr=serial@5000000
stdin=serial@5000000
stdout=serial@5000000
usb_boot=usb start; if usb dev ${devnum}; then devtype=usb; run scan_dev_for_boot_part; fi
uuid_gpt_esp=c12a7328-f81f-11d2-ba4b-00a0c93ec93b
uuid_gpt_system=b921b045-1df0-41c3-af44-4c6f280d3fae
video-mod=sunxi:1280x1024-24@60,monitor=hdmi,hpd=0,edid=0

Environment size: 4500/131068 bytes
=> 

 

Now screen (during boot, text mode), same text as on serial, BUT screen is flickering on/off, power control of monitor stays on like there is always "some" signal.

After starting X, screen stays constantly ON, but displaced UP ~1/4 screen (will attach photo later). Some upper part of image is offscreen.

Have NOT this effect on same hardware (KVM switch / monitor) with 2 OPiPC+'s.

 

Can login from console, here is output from it after "startx" command as root.

root@orangepi3:~# startx


X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-8-arm64 aarch64 Debian
Current Operating System: Linux orangepi3 5.4.43-sunxi64 #20.05.1 SMP Sat May 30 21:02:33 CEST 2020 aarch64
Kernel command line: root=UUID=ed5d037a-2a8e-4395-8d32-5a2a244ef271 rootwait rootfstype=ext4 console=ttyS0,111
Build Date: 05 March 2019  08:11:12PM
xorg-server 2:1.20.4-1 (https://www.debian.org/support) 
Current version of pixman: 0.36.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun  3 15:09:26 2020
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
gbm: failed to open any driver (search paths /usr/lib/aarch64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri)
gbm: Last dlopen error: /usr/lib/dri/sun4i-drm_dri.so: cannot open shared object file: No such file or directy
failed to load driver: sun4i-drm
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.

At least one error: "failed to load driver".

 

What's next step?

Any ideas?

OrangePi3.Xorg.0.log

Link to post
Share on other sites
  • laurentppol changed the title to OPi 3 display problem(?) [partially SOLVED]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...