0
darkgeekyang

Hostapd error on Orange Pi Zero

Recommended Posts

(edited)

Hi, all:

Today I just upgraded my packages as normal, by using "apt update && apt upgrade",  on my RockPi 4B (legacy kernel), and I saw there was a hostapd package updated. However, after this upgrade, my hostapd won't start anymore now:

Configuration file: /etc/hostapd.conf
wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Using interface wlan0 with hwaddr 6c:21:a2:37:ff:1a and ssid "RockPi-Armbian"
Failed to set beacon parameters
Interface initialization failed
wlan0: interface state COUNTRY_UPDATE->DISABLED
wlan0: AP-DISABLED 
wlan0: Unable to setup interface.
wlan0: interface state DISABLED->DISABLED
wlan0: AP-DISABLED 
wlan0: CTRL-EVENT-TERMINATING 
hostapd_free_hapd_data: Interface wlan0 wasn't started
nl80211: deinit ifname=wlan0 disabled_11b_rates=0

The culprit might be "Failed to set beacon parameters", but not for sure, even if I search on Google and still couldn't figure it out. The following is the output of "sudo armbianmonitor -U":

See here

 

Not sure if it's a RockPi specific or common issue. If you need more information, just tell me. Thanks.

Edited by darkgeekyang

Share this post


Link to post
Share on other sites
2 hours ago, darkgeekyang said:

Today I just upgraded my packages as normal, by using "apt update && apt upgrade",  on my RockPi 4B (legacy kernel), and I saw there was a hostapd package updated. However, after this upgrade, my hostapd won't start anymore now:


We have no capacity to test this function on upgrade yet, but at least testing - that we will know it fails - will be probably established by the end of this year.

 

2 hours ago, darkgeekyang said:

If you need more information

 

Who needs more information?

 

Check support terms https://github.com/armbian/build#support

Share this post


Link to post
Share on other sites

So I was trying to set up a portable wifi hotspot on my Orange Pi Zero (running Armbian buster with Linux 5.4.34-sunxi).

 

But whenever I try to enable wifi hotspot on it through armbian-config, it refuses to create a hotspot.

When I looked closely, it tried to probe the nl80211 driver without any error but then it also tried to probe realtek's driver, which is rtl871xdrv according to hostapd.conf in /etc . During its probing, in the corner of the terminal, it said: ioctl[SIOCSIWMODE]: Invalid argument
And as a result, it returned the No compatible driver found error.

 

I even tried to make NetworkManager ignore it (wlan0) and stop NetworkManager before enabling the hotspot, and start hostapd manually but no positive results.

I'm using the pi's built-in wifi chip - XR819, I'm aware that this wifi chipset isn't greatly supported but before all of this mess, it ran without any hassle. I only encountered this problem after doing an apt upgrade.

 

And I also tried to downgrade hostapd to an earlier version - 2.7 - but still, nothing.

 

What can I do to make hostapd working again? Any help would be appreciated!

I also included a screenshot of hostapd when I manually start it.

ioctl_error.png

Share this post


Link to post
Share on other sites
33 minutes ago, Quang-vip said:

But whenever I try to enable wifi hotspot on it through armbian-config, it refuses to create a hotspot.


https://armbian.atlassian.net/browse/AR-245
Planned to look into this in the upcoming months.

 

33 minutes ago, Quang-vip said:

What can I do to make hostapd working again?


Manual way ... All those project are open source, there is a documentation for hostapd and network manager way. Both project are independent from Armbian.

 

Try using attached hostapd.

hostapd_2.9-99~armbian5.98+1_armhf.deb

Share this post


Link to post
Share on other sites
Quote

Try using attached hostapd.

 

Surprisingly, it successfully ran with the config file in /etc, the network showed up in my phone :D


But what I see weird is that despite the correct password I put into my phone, it didn't want to authenticate.

I double checked the password in the config file and the one in my phone, they're the same but it kept telling me it wasn't correct

Maybe I missed something or I didn't set it up correctly.

 

But thanks for your temporary solution :D

Share this post


Link to post
Share on other sites
1 hour ago, Quang-vip said:

it didn't want to authenticate


Try armbian-config now. It should work, but AC mode doesn't work. I already waste afternoon ...

Share this post


Link to post
Share on other sites

Well, suddenly NetworkManager keeps telling rfkill to block the wlan interface (happens on boot and everytime I restart NetworkManager).

 

But what's weirder is that even after I unblock the interface, it still can't scan for any wifi network. And as a result, the option to create a hotspot in armbian-config isn't available.

 

However, if I start hostapd manually (an updated version thru apt I just updated yesterday), it will open a hotspot with that config file. But sadly it still doesn't want to authenticate. Welp

 

I'll make more investigation on this.

Share this post


Link to post
Share on other sites

Good news :D
 

Several days ago, I tried armbian-config again to try to create a hotspot. And surprisingly, it worked :DD

The hotspot has been running for days now.

 

Thanks for your hard work @Igor, I really appreciate it ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0