Audio on NanoPi K1 Plus


Recommended Posts

Hello!

 

I found that on NanoPi K1 Plus there is issues with both of integrated audio adapter (H3 Audio Codec) and HDMI Audio (allwinner-hdmi 1c22800.i2s-i2s-hifi)

1. With H3 Audio Codec I getting only silence, altrought there is short click on starting and end of playback. "Stereo" mode was chosen in pavucontrol for this audio adapter.

2. With allwinner-hdmi audio playback is working, but left and right channels is swapped. Like above "Stereo" mode was chosen in pavucontrol for this audio adapter.

Tests was performed from Mate desktop installed on top of Armbian 20.05.4 with Linux 5.4.45-sunxi64. "speaker-test -t wav -c 2" command was used for testing. To make sure that PulseAudio will route audio from speaker-test to right audio adapter I used pavucontrol to disable all other audio adapters besides the one I currently test.

 

I wonder if anyone else experiencing same issues with this board? Should I report allwinner-hdmi channels issue or H3 Audio Codec issue to kernel bugzilla or some Armbian-specific patches is involved in enabling audio adapters on this board?

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Armbianmonitor: https://pastebin.ubuntu.com/p/qymdnDjRpH/

 

Re-tested Armbian 21.02.1 focal server and focal desktop images:

1. I found that not-working audio playback via integrated H3 Audio Codec probably was caused by some issues in asound.state file or UCM file for audio adapter (if there is any). Shortly, if I just boot Focal desktop image and try to playback audio via 3.5mm jack - it works. However, if I enable and then disable H3 Audio Codec in pavucontrol - then audio playback via 3.5mm jack just stop working.

2. Microphone doesn't work even on fresh Focal server (via arecord) or Focal desktop or Focal Gnome desktop (via gnome-sound-recorder) where PulseAudio settings was never touched or PulseAudio was never installed in first place. With FriendlyCore image microphone is working.

 

I didn't tested HDMI Audio this time.

 

EDIT

Found workaround for getting microphone working:

amixer cset name='Mic1 Capture Switch' on,on
amixer cset name='Mic2 Capture Switch' on,on

Not sure why it's not enabled by default?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...