No gpu support on Udoo?


Recommended Posts

Armbianmonitor:

I downloaded Armbian for a Udoo Quad from https://dl.armbian.com/udoo/Focal_current_desktop.

uname -a reports: 

Linux udoo 5.6.18-imx6 #20.05.4 SMP Mon Jun 15 00:30:23 CEST 2020 armv7l armv7l armv7l GNU/Linux

However in https://docs.armbian.com/Hardware_Freescale-imx6/ I read: "Udoo Quad Kernel 3.14.x and 4.4.x with some hardware support, headers and some firmware included", which suggests that the image should have a 3.14 or 4.4 kernel.

In /var/log/Xorg.0.log I read:

[    21.345] (II) AIGLX: Screen 0 is not DRI2 capable
[    23.279] (II) IGLX: Loaded and initialized swrast
[    23.279] (II) GLX: Initialized DRISWRAST GL provider for screen 0

LIBGL_DEBUG=verbose glxgears  -info says:

libGL: screen 0 does not appear to be DRI2 capable
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /home/pi/.drirc: No such file or directory.
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /home/pi/.drirc: No such file or directory.
GL_RENDERER   = llvmpipe (LLVM 9.0.1, 128 bits)
GL_VERSION    = 3.1 Mesa 20.0.4
GL_VENDOR     = VMware, Inc.

suggesting that there is no hardware acceleration.

Is there any way to get hardware acceleration on a Udoo Quad with Armbian

Link to post
Share on other sites
Donate and support the project!

1 hour ago, hji said:

suggesting that there is no hardware acceleration.

 

AFAIK all possible acceleration for imx6 has been mainlined and they are most likely enabled by default. Old 3.14 and 4.4 kernels were dropped long time ago.

 

1 hour ago, hji said:

Is there any way to get hardware acceleration on a Udoo Quad with Armbian


You will need to research the topic. Without researching ... I don't know. We never maintained this functionality. We care about basis functionality and if that works and if we have spare time (which never came), we proceed to such fancy and expensive to maintain functions.

 

Armbian provides builds tools which gives you a solid base. General support terms: https://github.com/armbian/build#support

Link to post
Share on other sites
2 hours ago, hji said:

Is there any way to get hardware acceleration

You have proper hardware acceleration from the kernel already.

Quote

[   10.439569] etnaviv etnaviv: bound 130000.gpu (ops gpu_ops [etnaviv])
[   10.443294] etnaviv etnaviv: bound 134000.gpu (ops gpu_ops [etnaviv])
[   10.451085] etnaviv etnaviv: bound 2204000.gpu (ops gpu_ops [etnaviv])
[   10.451107] etnaviv-gpu 130000.gpu: model: GC2000, revision: 5108
[   10.451469] etnaviv-gpu 134000.gpu: model: GC320, revision: 5007
[   10.451559] etnaviv-gpu 2204000.gpu: model: GC355, revision: 1215
[   10.451571] etnaviv-gpu 2204000.gpu: Ignoring GPU with VG and FE2.0
[   10.452674] [drm] Initialized etnaviv 1.3.0 20151214 for etnaviv on minor 0

What you are probably missing is the xorg driver to make use of it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...