Maybe stupid question: trying to build u-boot only


barish
 Share

1 1

Recommended Posts

I tried to build the espressobin u-boot only with the command given in the docs: 

./compile.sh 'compile_uboot'

But I get

...
  COPY    u-boot.bin
  CFGCHK  u-boot.cfg
rm: missing operand
Try 'rm --help' for more information.
[ o.k. ] Building flash-image-DDR3-512m_1cs_0-600_600.bin 
cp: cannot stat 'build/a3700/debug/flash-image.bin': No such file or directory
[ o.k. ] Building flash-image-DDR3-512m_2cs_0-600_600.bin 
cp: cannot stat 'build/a3700/debug/flash-image.bin': No such file or directory
...

Do I need more/different parameters or a different config-default.conf ?

Sorry for these maybe stupid questions, I am aware that I don't really see through the build system yet... 

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

I finally managed to get a stable U-Boot for my EspressoBin v7 with 1GB DDR4. I changed lib/main.sh to replace github.com/MarvellEmbeddedProcessors/A3700-utils-marvell with github.com/globalscaletechnologies/A3700-utils-marvell as well as some other lines – would there be a more elegant way to patch this, I would love to know?

 

I changed config/sources/families/mvebu64.conf too to use the repository by GlobalscaleTechnologies and I even tried out the current U-Boot 2020.10 instead of Marvell's old U-Boot – I have not encountered any errors. Should I make a pull request for these changes?

 

Edit: Or better make a pull request upstream...?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

1 1