Olimex LCD Panel Support for A64


Recommended Posts

LCD support does not appear to be working in the latest builds (stable kernel 5.8.6, development kernel 5.9.7)

 

My understanding is that this has been an issue for a while with A64 boards, specifically the Pine64, but that it was working at one time.

 

Here's what I've tried so far:

 

-Followed instructions at https://docs.armbian.com/Hardware_Allwinner/  and added "setenv video-mode sunxi:480x272-24@60,monitor=lcd,hpd=1,edid=1" to boot.cmd and put "saveenv" at the end, re-compiled boot.scr

 

-Did a modprobe of panel-olimex-lcd-olinuxino

 

-Rebooted several times

 

-Ensured that LCD jumper was closed and verified LCD was working with Olimex builds.

 

Screen flickers at startup then stays white.

 

Any thoughts?

Link to post
Share on other sites
Donate and support the project!

On 11/20/2020 at 7:05 PM, Digitalman1983 said:

One additional comment,

 

I noticed according to the hardware notes in armbian docs that CONFIG_VIDEO_LCD_MODE must be enabled in kernel configuration.

 

I just checked my kernel configuration and that option does not exist.

I do not know about the other issues but if i recall correctly CONFIG_VIDEO_LCD_MODE is actually an option in U-Boot, not kernel.

Link to post
Share on other sites

Thanks for that, Gediz,

 

In looking at the Olimex forum post https://www.olimex.com/forum/index.php?topic=4463.0 regarding the A13, as well as http://linux-sunxi.org/LCD it would appear that the CONFIG_VIDEO_LCD_MODE is indeed part of the configuration for U-Boot, which requires U-boot to be custom built:

 

git clone git://git.denx.de/u-boot.git
cd u-boot/
git checkout v2015.04 -b tmp

https://developer.arm.com/-/media/Files/downloads/gnu-a/9.2-2019.12/binrel/gcc-arm-9.2-2019.12-x86_64-aarch64-none-linux-gnu.tar.xz

tar -xvf gcc-arm-9.2-2019.12-x86_64-aarch64-none-linux-gnu.tar.xz

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- a64-olinuxino_defconfig

make menuconfig

 

This allows the configuration of U-boot where the LCD can be properly enabled.

 

I'm working on the next step, which is properly linking the compiler to build the U-boot image, as well as adding a user patch to armbian build tools to allow use of the custom U-boot binary.  Stay tuned.

 

 

 



 

Link to post
Share on other sites
18 hours ago, Digitalman1983 said:

Thanks for that, Gediz,

 

In looking at the Olimex forum post https://www.olimex.com/forum/index.php?topic=4463.0 regarding the A13, as well as http://linux-sunxi.org/LCD it would appear that the CONFIG_VIDEO_LCD_MODE is indeed part of the configuration for U-Boot, which requires U-boot to be custom built:

 

git clone git://git.denx.de/u-boot.git
cd u-boot/
git checkout v2015.04 -b tmp

https://developer.arm.com/-/media/Files/downloads/gnu-a/9.2-2019.12/binrel/gcc-arm-9.2-2019.12-x86_64-aarch64-none-linux-gnu.tar.xz

tar -xvf gcc-arm-9.2-2019.12-x86_64-aarch64-none-linux-gnu.tar.xz

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- a64-olinuxino_defconfig

make menuconfig

 

This allows the configuration of U-boot where the LCD can be properly enabled.

 

I'm working on the next step, which is properly linking the compiler to build the U-boot image, as well as adding a user patch to armbian build tools to allow use of the custom U-boot binary.  Stay tuned.

 

You're welcome. If you don't mind, I'd recommend you to use a more recent U-Boot version if there isn't any special purpose to use v2015.04.

 

By the way, I had to spend a little bit amount of time to integrate a custom U-Boot and Linux to Armbian for my own use case. I thought that it'd help to see what/where should i add/modify back in then. Maybe this may help you a bit. By the way, do not mind FEX. It was for a really old kernel.

 

.
├── config
│   ├── boards
│   │   └── myboard-a13.csc
│   ├── fex
│   │   └── olinux-som-a13.fex
│   ├── kernel
│   │   └── linux-sun5i-default.config
│   └── sources
│       └── sun5i.conf
├── defconfig
│   └── u-boot
│       └── myboard-a13_defconfig
└── userpatches
    ├── config-myboard.conf
    └── u-boot
        └── u-boot-sunxi-legacy
            └── myboard-a13_defconfig.patch

 

Just after copying an overlay like this to your Armbian build directory, then ./compile.sh myboard

 

This configuration may be outdated to an extent. It's been some months.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...