First Start – No Console Output


tmb

Recommended Posts

Hi folks,

 

I got my helios64, assembled it during the weekend and can’t seem to actually install it.

 

Here are some of the things I tried (I'm on windows 10 btw, I don’t have hdd drives yet, I assume this would not be an issue):

·         2 sd cards (one of which is a Samsung as recommended in the wiki), two computers (with correct com ports as visible in the device manager, driver is installed), tried both on usb2 and usb3

·         USB cable has been trimmed to fit the case properly - also tried with the back panel off and directly connected to the board

·         the devices starts up as soon as I plug in the power cord - I then use the power button to shut if off, then open the console and start it up (I did use the 4 seconds to shut it off and make sure the leds are not on)

·         (when I plug it in, the system light turns on red for just a millisecond, and then off, and all other light blue)

 

After start-up:

-          No light on the system led, not even blinking.

-          Power and hdd leds are all blue (constant on).

 

Anything I should be trying next? Thanks for reading.

 

PS. Not really much an expert on linux, last time I used it was years ago when I was tweaking my prior nas.

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Hey, thanks!


I’ve seen the Maskrom and will keep it as a last option for two reasons:
- I’d still like to boot from the sd card – just to experiment with the device and decide on the final setup.
- It looks a bit more complicated (or risky).

 

I will still try to test & understand why I cannot boot from the sd card yet.
 

Link to post
Share on other sites

If the lights are all just solid, that suggests to me that you aren't getting a clean boot, so the console settings aren't relevant yet. In my case, with a clean boot, my HDD lights flash intermittently while booting, then go solid. The top system LED flashes intermittently after a good boot.

 

How did you burn the image onto the SD card? I used Balena Etcher on a Sandisk card and got a good boot on the first try. I'd recommend re-burning the image, then reinsert the card, making sure to get a solid "click" when it seats.

 

If it boots and you see the system LED flashing, then the console is actually optional - if you check your router settings you should be able to see which DHCP address was assigned to the device (it will have hostname "helios64", and then you can SSH directly to the device using "root" and "1234" as the default login info.

Edited by phidauex
add url
Link to post
Share on other sites

Have you tried checking your router's dhcp for a lease on the helios64?
If you have the ethernet plugged in when starting it up, and it makes it through sdcard boot, regardless of your serial console it should get a lease. (Then you can SSH in with the same credentials.)

 

I also had no console output when I first tried to set it up, and ended up using the router to discover what the IP was.

Make sure you are using the correct COM address.

I had to install the driver, and I was on COM4.

Link to post
Share on other sites

Hi again,

 

Yes, the lights were solid blue after boot (power and hdds, nothing else), so the comment about not getting a clean boot make sense.

 

I was monitoring the router but no ip was coming up for it, so this again makes sense as it wasn’t really booting with the sd card.

 

Here’s what actually worked last evening (don’t remember the exact order):

-          Changed the sd card image from Armbian_20.08.13_Helios4_buster_current_5.8.16.img to Armbian_20.11_Helios64_buster_current_5.9.10.img (yes, using Etcher), initially I was using the older image for what seemed to be stability reasons…

-          Before burning the image again - reformatted the card from exFAT to FAT in Windows 10 (as mentioned, not really much experience with Linux so this might have been the cause)

-          Moved the device from the left side of my desk to the right :)

 

It powered up and connected via usb - COM6 with my desktop as I was checking anyway every time before trying (for example desktop was always COM6, laptop always COM3).

 

Looks fine now, power light on, system light blinking, no hdd lights (as I don’t have any yet).

 

Even installed OMV which took about 20 mins, but I am able to access it.

 

Now off to buying disks, fun times ahead :)

Thanks for your time, people!

Link to post
Share on other sites