Need help with MXQ Pro 4K


Recommended Posts

Hello guys, and thanks for all your work !

 

I recently wanted my old MXQ pro 4K to become a little server :-)

 

I found your work and tried everything, starting from following your tutorial, then tried to change the dtb with another because I saw that my mxqpro4k have a S905 (not a S905X), but it seems like it's impossible for me to boot onto the SD CARD (nor USB), with or without the toothpick method.

 

Here's the thing :

https://www.amazon.co.uk/gp/product/B01FH8DL46/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

 

I tried to boot on Multitool and on Armbian img aswell. It's seems that i'm missing something.

 

I found an old bables post where he was talking about "Multi-boot". Is that the problem ?

 

EDIT : I think I figured out your image are certainly for MXQ Pro 4K... but not for S905 CPU, that's it ? What should I download then ? :-)

Edited by lary
Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

2 hours ago, lary said:

Hello guys, and thanks for all your work !

 

I recently wanted my old MXQ pro 4K to become a little server :-)

 

I found your work and tried everything, starting from following your tutorial, then tried to change the dtb with another because I saw that my mxqpro4k have a S905 (not a S905X), but it seems like it's impossible for me to boot onto the SD CARD (nor USB), with or without the toothpick method.

 

Here's the thing :

https://www.amazon.co.uk/gp/product/B01FH8DL46/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

 

I tried to boot on Multitool and on Armbian img aswell. It's seems that i'm missing something.

 

I found an old bables post where he was talking about "Multi-boot". Is that the problem ?

 

EDIT : I think I figured out your image are certainly for MXQ Pro 4K... but not for S905 CPU, that's it ? What should I download then ? :-)

Try to follow this steps and ask there for S905 support 

 

Link to discussion about S905 devices

Link to post
Share on other sites

@lary I move your post to the appropriate forum.  There are two items in the TV box club FAQ and you should read both of them.  The first is about status of support of TV boxes and the second talks about how to install on Amlogic boxes like you apparently have.

Link to post
Share on other sites
On 3/3/2021 at 7:11 PM, lary said:

I tried to boot on Multitool and on Armbian img aswell. It's seems that i'm missing something.

I just do an intervention here to state that the Multitool works just for a couple of rockchip socs (rk3228/9 and rk3288). No Amlogic (neither allwinner) support currently.

 

Link to post
Share on other sites