1 1
aliend

Selinux OR Apparmor

Recommended Posts

Hi

I tried to install selinux on my OPI Jessie but i find out selinux-policy-default has problem with debian jessie and even it's not integrated with kernel .after all i tried to use apparmor but it's not integrated too.I find this doc to cross compile and add apparmor or selinux but seems it's not work because 

git clone https://github.com/orangepi-xunlong/u-boot-orangepi.git
 

doesn't exist !

After all :)  :huh: ,how can i use selinux or apparmor on my OPI?

Share this post


Link to post
Share on other sites

HI again 

I tried to add selinux and(or) Apparmor to my kernel modules , after kernel compile with  Xenial, Jessie and wheezy dist on my OPI pc plue and OPI lite i installed this two modules packages and i tried to set them in enforce mode but i couldn't .

some errors are like : 
check-selinux-installation
../proc/1 kernel..
SELinux is not enabled.
The init process (PID 1) is running in an incorrect domain.

or :

$sestatus

SELinux is disabled

even when i set it in enforce mod or permissive and reboot my system still it was disabled 

Anyway has anyone tried it before? and anyone has any idea for my problem ?

thanks.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1