CAN controller in BananaPi does not work in 21.05.1 image, solution available


mue473
Go to solution Solved by mue473,

Recommended Posts

  • Solution

Hello,

for my BananaPi I recently downloaded "Armbian_21.05.1_Bananapi_buster_current_5.10.34.img" and did not get the on-board CAN controller working with this image.

 

I found out that in sun7i-a20-bananapi.dtb (uses sun7i-a20.dtsi) the group name for the CAN pins PH20 and PH21 has changed from "can0_pins_a" to "can_ph_pins" but in the sun7i-a20-can overlay this change had not been done accordingly, and the DT merging failed.

 

So changing "sun7i-a20-can.dts" to:

/dts-v1/;
/plugin/;

/ {
	compatible = "allwinner,sun7i-a20";

	fragment@0 {
		target = <&can0>;
		__overlay__ {
			pinctrl-names = "default";
			pinctrl-0 = <&can_ph_pins>;
			status = "okay";
		};
	};
};

solved the problem.

 

Please consider this for further releases,

regards
Rainer

Link to post
Share on other sites
Donate and support the project!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...