OPi3 not routing (Armbian Buster)


 Share

3 3
Go to solution Solved by laurentppol,

Recommended Posts

Armbianmonitor:

Hi there,

I have an OPi3 box that acts as home surveillance server.

It has WiFi configured as AP, client is Android phone with static IP/routing and IP Camera software.

Problem is, that there is NO IP routing. I CAN access video / pictures from phone on OPi box, but NOT from my LAN.

Below is routing table and iptables. Looks ok but not working.

I am able to access (from LAN) WiFi IP of OPi. Also can access video served by "motion" software on OPi. But no direct connection to Android phone.

 

root@orangepi3:/tmp# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.60    0.0.0.0         UG    100    0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     100    0        0 eth0
192.168.2.0     0.0.0.0         255.255.255.0   U     100    0        0 eth0
192.168.10.0    192.168.1.30    255.255.255.0   UG    100    0        0 eth0
192.168.15.0    0.0.0.0         255.255.255.0   U     600    0        0 wlan0
root@orangepi3:/tmp# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

 

Laurent

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

@laurentppol  :  asking just out of curiosity , can you elaborate more on your this "Surveillance server" ? Which type of external storage attached to OPi3 for IP camera videos/images ? which open source surveillance software used and its configuration ? Number  of IP camera(s) used and their types ?  and about over all performance and satisfaction level for this whole setup ? 

Link to post
Share on other sites

On 6/20/2021 at 11:49 AM, ATK said:

@laurentppol  :  asking just out of curiosity...

Storage - external USB->SATA HDD, 320GB, about 2GB/24h @ 1fps, software: motion, set to permanently record at 1fps from IP Webcam on old Android phone (Xperia L), image set 1280x1024. Plus cron replica to remote storage every 10min (WiFi link). Separate WiFi network (different channel from other apps for performance reasons, this is why I have set up OPi3 as AP and want routing). Satisfaction level: very high :).

 

lanefu: THX very much.

Link to post
Share on other sites

Ooops, not so fast:

httping works (to telephone, Android does not respond to ping), but using browser I get to.... OPi3 HTTP server, NOT phone.

iptables are just clear.

 

How to solve this?

 

root@orangepi3:~# iptables-save | more
root@orangepi3:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.60    0.0.0.0         UG    100    0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     100    0        0 eth0
192.168.2.0     0.0.0.0         255.255.255.0   U     100    0        0 eth0
192.168.10.0    192.168.1.30    255.255.255.0   UG    100    0        0 eth0
192.168.15.0    0.0.0.0         255.255.255.0   U     600    0        0 wlan0

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

3 3