Jump to content

Tanix TX6S - H616


Recommended Posts


Firstly sorry for the bad english(By Google Translator). I've been searching for a long time on how to use linux on my tv box, without success.


I searched here on the forum in several topics, I didn't find anything related to the tx6s, the closest I came was the Orange-Pi Zero 2, which uses the same processor.


In one of the topics, from 2020 if I'm not mistaken, a user warned that because it was the same processor or similar hardware, it wouldn't necessarily work.

Even so I ventured out and tried in hopes of working, some versions of Armbian for OrangePi Z2 and other linux for ARM.


With other ARM versions the tv box, booted normally on Android, with Armbian, it didn't even start and no led lit up.


What made me believe that somehow with Armbian, the tv box recognized the SD card as bootable, but for some problem it can't boot. Maybe it's the u-boot used. if some of the versions I tried to install:


https://drive.google.com/drive/folders/1HsD11VGl-CSv98GgmWoVSlnFYEE1jMNM - Orange-Pi Zero2 IMG [Armbian_22.05.0-trunk_Orangepizero2_jammy_edge_5.17.5_minimal.img] - (No_Boot) - {Problema_com_o_U-boot?}


https://drive.google.com/file/d/1wZulOr6_Sur_btcqqzBFTpjPmhPX0fZ1/view?usp=sharing - Orange-Pi Zero2 IMG [Armbian_22.05.0-trunk_Orangepizero2_focal_current_5.15.35.img] - (No_Boot) - {Problema_com_o_U-boot?}


https://drive.google.com/drive/folders/13pY93TozoF2omgKYnCiSZrONbBvBPxAh - Orange Pi Zero2 Linux5.13 IMG [] e []


https://armbian.hosthatch.com/archive/orangepizero2/archive/Armbian_21.08.1_Orangepizero2_hirsute_edge_5.13.12.img.xz - Orange Pi Zero2 IMG [Armbian_21.08.1_Orangepizero2_hirsute_edge_5.13.12.img]

https://mirrors.dotsrc.org/armbian-dl/orangepizero2/archive/ Orange Pi Z2 IMG [FOCAL Armbian_22.02.1_Orangepizero2_focal_edge_5.16.11][Armbian_22.02.1_Orangepizero2_bullseye_legacy_4.9.255.img]


TV BOX MODEL: https://linux-sunxi.org/Tanix_TX6s


I also found this about u-boot, I don't know if it can be useful or how to use this information, I have no technical knowledge:


https://gist.github.com/heitbaum - u-boot


https://github.com/jernejsk/u-boot -u-boot


https://github.com/jernejsk/u-boot/tree/h616-v2 - u-boot


If anyone knows how to install this tv box, please show me the way to the stones. it could be the server version.


Link to comment
Share on other sites

The h616 is a relatively new cpu from allwinner.  Support for that cpu by mainline linux (and therefore armbian is still in the early stages).  Currently development efforts are making progress but still have a ways to go.  The best working code bases right now don't use mainline linux but custom vendor supplied kernels with a bunch of out of tree linux modifications.

What I mention above is for SBCs like the Opi Zero2.

Armbian does not support TV boxes.  The handfull of people who hang out in these TV box forums have an interest in running armbian on TV boxes, but no one is working on the h616.  I would say you are a year or two away from potentially running armbian on your box (if that ever happens).

Link to comment
Share on other sites

OK. I think I understand. The problem is not the difference or similarity of the hardware, but the different kernel modified by each manufacturer, which makes development difficult. You have to customize for each type of tv box in specific.


I will continue to follow the forum and wait. Thank you so much for replying my friend.

Link to comment
Share on other sites

@Munez I posted my findings earlier here:

basically what I found on my end was that most of the kernels of these Orange Pi Zero 2 ROMs didn't seem to do anything on H616 boxes I got access to but somehow the ones specifically with 4.9.279 and 4.9.280 kernels booted and gave one USB and HDMI out on one of these boxes and other clearly did some additional loading too but with no HDMI out. None of the other ROMs showed any activity on boot but granted I haven't hooked up serial connection for further analysis. For example 4.9.255 was just dead on my end.

I've used ROMs from this archive for testing: https://armbian.hosthatch.com/archive/orangepizero2/archive/

This works on the H96max (H616) box here: https://armbian.hosthatch.com/archive/orangepizero2/archive/Armbian_21.08.1_Orangepizero2_bullseye_legacy_4.9.280.img.xz

Would be nice to hear others experiences on this, if 279 and 280 work for others too there must be some reason why only these are more compatible with H616 TV boxes.

Link to comment
Share on other sites

1 hour ago, rzu said:

Would be nice to hear others experiences on this, if 279 and 280 work for others too there must be some reason why only these are more compatible with H616 TV boxes.

The 4.9.x kernels are 'legacy' kernels in armbian speak.  That means they are the kernels supplied by the board vendor.  Vendor kernels are generally heavily modified and the changes don't get put into the mainline kernels.  Because of the heavy modifications these vendor kernels are always very old kernels and therefore not receiving any support/bugfixes/patches.  Armbian focuses on support of mainline kernels and the mainline kernel tree and tries to minimize any out of tree kernel patches (when there are patches necessary, it is the goal that these changes will ultimately be accepted into the mainline tree).  Because the vendor kernel and mainline are so far apart, it often isn't realistic to merge the vendor changes into mainline, but instead the work needs to be redone.  Since the vendors generally don't put any effort into mainlining all that falls upon the community which can take a long time.

Link to comment
Share on other sites

Em 17/05/2022 às 08:21, rzu disse:

@Munez , postei minhas descobertas anteriormente aqui:

basicamente o que eu encontrei no meu final foi que a maioria dos kernels dessas ROMs Orange Pi Zero 2 não pareciam fazer nada nas caixas H616 às quais eu tive acesso, mas de alguma forma os especificamente com kernels 4.9.279 e 4.9.280 inicializados e deu uma saída USB e HDMI em uma dessas caixas e outras claramente fizeram algum carregamento adicional também, mas sem saída HDMI. Nenhuma das outras ROMs mostrou qualquer atividade na inicialização, mas admito que não conectei a conexão serial para análise posterior. Por exemplo, 4.9.255 estava morto do meu lado.

Eu usei ROMs deste arquivo para teste: https://armbian.hosthatch.com/archive/orangepizero2/archive/

Isso funciona na caixa H96max (H616) aqui: https://armbian.hosthatch.com/archive/orangepizero2/archive/Armbian_21.08.1_Orangepizero2_bullseye_legacy_4.9.280.img.xz

Seria bom ouvir outras experiências sobre isso, se 279 e 280 funcionam para outros também, deve haver alguma razão pela qual apenas esses são mais compatíveis com caixas de TV H616.

Hello friend, I found this topic, I saw your comment, I don't remember if I found the ISO you mentioned and I tested it. Thank you so much for replying to my thread and posting the links. I will test these images you mentioned here. Let's see if it works on mine.

Link to comment
Share on other sites

Worth noting that I couldn't get anything but one USB and HDMI running but that let me put in usb hub with gbit lan to it and hook it to network that way, also tested usb ac wifi dongle and that also worked but it's more pain to manage. With physical wire you can just remote SSH always as long as you've done the initial armbian setup.

Link to comment
Share on other sites

@rzu@SteeManHi, so I tested several images with 4.9.x kernel, in some I was able to boot, but in no case I was able to install.


initial remarks:


this model tx6s has 2 usb 2.0, 1 usb 3.0, 1 hdmi and 1 ethernet.

the white streaks in the images, from the screen is a problem with my tv


General notes, on all tested images that booted:


It doesn't boot the boot loader the first time, I've made more than five attempts in every one I've tested.

In all cases the hdmi, 1 usb 2.0 and 3.0 worked, recognizing the keyboard.


images that were tested and boot loader initialized:


images taken from the link https://armbian.hosthatch.com/archive/orangepizero2/archive/ shared by @rzu







images taken from the link https://armbian.chi.auroradev.org/dl/orangepizero2/archive/?sort=size&order=desc





All behaved the same way. Got stuck on black screen without loading anything, for more than 10 minutes with no change. as you can see in the image below.


Image: https://ibb.co/7bfBj2t


I decided to test the images available on the orangepi website for the zero 2 model. And surprisingly I was also able to boot the boot loader, and it loaded some files but it gave an error in both Ubuntu and Debian versions.



images taken from the link https://drive.google.com/drive/folders/1ohxfoxWJ0sv8yEHbrXL1Bu2RkBhuCMup






Image:  https://ibb.co/3vZzrQt



images taken from the link https://drive.google.com/drive/folders/1Xk7b1jOMg-rftowFLExynLg0CyuQ7kCM





I made a video to be readable, due to the problem with the TV image.


Video: https://odysee.com/@uaitidoguis:d/Tanix_TX6S_Orangepizero2_2.2.0_debian_buster_desktop_linux4.9.170:f?r=H7r2LcNEzboXLJ9aLRuWBf15XxyGjZjp


Well that's it, I hope this helps someone who is in the same situation. Unfortunately on mine it didn't work 100%, I'm already better than yesterday. I'll continue in the battle looking for an image that works, maybe I'll get lucky. If anyone knows any more links to images with kernel 4.9x, share it here. If I have any more progress, I'll come back to share.







Edited by Munez
not embeded image
Link to comment
Share on other sites

Note that since you are using a build for a completely different device (orangepizero2 vs tx6s) you aren't going to get everything working without a proper dtb file.  So at a minimum you would need to find/modify a dtb file that describes to the kernel the actual hardware in your box.  Unless the opzero2 has the exact same hardware on the board as the tx6s the dtb file you are using will be wrong and the hardware that is different will not be working.  I'm honestly amazed that you have as much working as you do.

Link to comment
Share on other sites

I tested some more Armbian versions with 4.9x, it was the same way. I found a guy on the LibreElec forum, he commented that he had managed to run linux on his tx6s. Heitbaum, I'm trying to get in touch with him, he still hasn't replied. Including one of the links from my first post here which is from his Git. He shared some files for tx6s. Could you take a look, please, when you have time. Maybe one of them is dtb.or maybe it's some file I can use.







I will research about dtb files, how to create and edit, compare the Orange hardware with my tx6s, see what I need to change or add. I will try to learn how to do it. Now that I have a path to follow it becomes better. I'll just stop trying to figure out how to run linux on it. After the tvbox stops working or exhausts my possibilities.

Link to comment
Share on other sites

I did notice that on H96Max H616 box I have here MiniMyth's orangepi_zero image actually boots with both USB ports functional (vs one USB port on those select Armbian images) so their H616 patches definitely do improve things. Ethernet is still dead on it but that's no surprise since it's not a matching board.

I was also able to extract DTS from this H96Max box and it looked very similar to orangepizero2's DTS file on armbian, items in different order but values were close to identical.

Link to comment
Share on other sites

@rzu- i did not try the images from waprme's minimyth2, but i'm using the patches for both the h6 and h616 to build my own images (not armbian) and they are working very well so far - i would say its the most complete patch collection for h616 right now


best wishes and good luck - hexdump

Link to comment
Share on other sites

33 minutes ago, hexdump said:

@rzu- i did not try the images from waprme's minimyth2, but i'm using the patches for both the h6 and h616 to build my own images (not armbian) and they are working very well so far - i would say its the most complete patch collection for h616 right now

Cool stuff, I'm assuming you mean now patches that you have here? https://github.com/hexdump0815/linux-mainline-and-mali-allwinner-h6-kernel

Is there any plan to push these to Armbian eventually? I'm still piecing together how these all work together.

I've so far fiddled with custom AW H6 armbian builds for my T95 Mini (everything working great on it) and tried to get something to build for this H96 Max box but best I've gotten on my own builds is the armbian logo on HDMI using legacy kernel :D

Link to comment
Share on other sites

On 6/7/2022 at 7:26 AM, rzu said:

@rzuYes it worked, as it is not the type of linux distribution I am looking for, I stopped here https://ibb.co/2hRxYgk

I replaced the original dtb from tested images with that of mythtv. Unsuccessfully. I think I must have to change something inside some file for the system to recognize it. I still don't know how to open and edit the files


@hexdump@rzuPlease, if you have any custom linux h616 image that is working, even if it is not 100% please send me a link so I can try it on my tv box.


Link to comment
Share on other sites

I buy a h96max tv box with h616 processor with 2gb ram and 16gb of emmc, however, i downloaded and loaded the armbian version Armbian_21.08.1_Orangepizero2_bullseye_legacy_4.9.280.img.xz, as said above it would work on tv box, but it until the armbian logo appears, loading, but it hangs there. Does anyone have any ideas on how to modify the boot?

Link to comment
Share on other sites

After reading the comments here from the group, I decided to open my h96max tvbox, and I realized that it had a serial connector, when plugging into a usb serial interface, I got these results when loading armbian.


515][AUTO DEBUG]16 bit,1 ranks training success!
[522]DRAM CLK =720 MHZ
[525]DRAM Type =3 (3:DDR3,4:DDR4,7:LPDDR3,8:LPDDR4)
[531]Actual DRAM SIZE =1024 M
[534]DRAM SIZE =1024 MBytes, para1 = 30fb, para2 = 4000001, dram_tpr13 = 6041
[547]DRAM simple test OK.
[549]rtc standby flag is 0x0, super standby flag is 0x0
[555]dram size =1024
[557]*****dram handle ok****
[560]card no is 0
[562]sdcard 0 line count 4
[565][mmc]: mmc driver ver 2019-12-19 10:41
[569][mmc]: sdc0 spd mode error, 2
[573][mmc]: set f_max to 50M, set f_max_ddr to 25M
[577][mmc]: mmc 0 bias 0
[585][mmc]: Wrong media type 0x0
[589][mmc]: ***Try SD card 0***
[599][mmc]: HSSDR52/SDR25 4 bit
[602][mmc]: 50000000 Hz
[604][mmc]: 15084 MB
[606][mmc]: ***SD/MMC 0 init OK!!!***
[707]Loading boot-pkg Succeed(index=0).
[711]Entry_name        = u-boot
[720]Entry_name        = monitor
[724]Entry_name        = dtbo
[727]Entry_name        = dtb
[730]Jump to second Boot.
NOTICE:  BL3-1: v1.0(debug):9fecd83
NOTICE:  BL3-1: Built : 17:08:29, 2020-05-28
NOTICE:  BL3-1 commit: 8
ERROR:   Error initializing runtime service tspd_fast
NOTICE:  BL3-1: Preparing for EL3 exit to normal world
NOTICE:  BL3-1: Next image address = 0x4a000000
NOTICE:  BL3-1: Next image spsr = 0x1d3

U-Boot 2018.05-armbian (Aug 28 2021 - 20:00:15 +0200) Xunlong Software

[00.807]CPU:   Allwinner H616
[00.810]Model: Orange Pi Zero 2
I2C:   ready
[00.815]DRAM:  1 GiB
Relocation Offset is: 35ec9000
[00.855]secure enable bit: 0
[00.858]PMU: AXP806
[00.862]CPU=1008 MHz,PLL6=600 Mhz,AHB=200 Mhz, APB1=100Mhz  MBus=400Mhz
[01.044]sunxi overlay merged okqv
[01.076]__clk_enable: clk is null.
tv_init()950 fetch tv0 err.
[01.082]drv_disp_init finish
[01.085]gic: sec monitor mode
[01.090]flash init start
[01.092]workmode = 0,storage type = 1
[01.095]MMC:     0
[01.097]get mem for descripter OK !

[01.125]sunxi flash init ok
[01.128]Loading Environment from FAT... [01.131]get mem for descripter OK !

** Bad device mmc 1 **
Failed (-5)
[01.147]usb burn from boot
delay time 0
[01.160]usb prepare ok
[01.967]do_burn_from_boot usb : no usb exist
177 bytes read in 21 ms (7.8 KiB/s)
Set HDMI disp_mode to 1080p60
177 bytes read in 21 ms (7.8 KiB/s)
Set fb0_width to 1280
Set fb0_height to 720
230454 bytes read in 43 ms (5.1 MiB/s)
[02.377]update dts
Net:   [02.380]No ethernet found.
Hit any key to stop autoboot:  1 0
no mmc device at slot 1
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
2612 bytes read in 25 ms (101.6 KiB/s)
## Executing script at 43100000
U-boot loaded from SD
Boot script loaded from mmc
177 bytes read in 21 ms (7.8 KiB/s)
6695987 bytes read in 594 ms (10.7 MiB/s)
24127560 bytes read in 2044 ms (11.3 MiB/s)
## Booting kernel from Legacy Image at 41000000 ...
   Image Name:   
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    24127496 Bytes = 23 MiB
   Load Address: 41000000
   Entry Point:  41000000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 43300000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    6695923 Bytes = 6.4 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
   Loading Ramdisk to 4999d000, end 49fffbf3 ... OK
   reserving fdt memory region: addr=48000000 size=1000000
## Linux machid: 00000000, FDT addr: 7be89580

Starting kernel ...

Loading, please wait...
Starting version 247.3-6

Loading, please wait...
Starting version 247.3-6
Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... Scanning for Btrfs filesystems
Begin: Will now check root file system ... fsck from util-linux 2.36.1
[/sbin/fsck.ext4 (1) -- /dev/mmcblk0p1] fsck.ext4 -a -C0 /dev/mmcblk0p1  
/dev/mmcblk0p1: recovering journal
/dev/mmcblk0p1: clean, 40682/131264 files, 373396/436224 blocks
Begin: Running /scripts/local-bottom ... done.
Begin: Running /scripts/init-bottom ... done.

Edited by javaxsousa
Link to comment
Share on other sites

Lurking into the forums I tried a lot of images. I have a cheap TV Box with H313 which I found out is technically a H616 with lower clock speeds. None of the Armbian versions for Orange Pi Zero 2 worked on this thing(and shouldn't either).

However one version of Ubuntu worked which I found on a Russian forum. This is the image. It is an older(2.1.2) version with 4.1.970 kernel. I tried booting the newer version (2.2.0) however my luck was same as @Munez

I do not have sufficient knowledge to know the changes between those two versions. However @hexdump might have some idea regarding this.

Talking about the image, both USB ports are functional. Ethernet is also working. The WiFi though doesn't work.


Link to comment
Share on other sites

@TeroDadaI stopped trying to run linux on the tv box, I was freaking out. 😄 I tried everything in my power, MacGyver style, to no avail. this tv box is the devil's thing 😂. I almost went crazy trying to run linux on it every day. mine is kept here, maybe some blessed soul can still make it work and share.

Link to comment
Share on other sites

If one really wants to go with the tv box route, better at least pick device that's proven to already be fully functional with armbian IMHO :) My own interest on H616 is because have one here already + it runs cooler than my current armbian box (H6).

I tried that old
4.1.970 kernel on this H616 box I have here and both USBs seemed to work but didn't get LAN to work. Basically the new patches that MythTV project gave also had similar functionality with newer kernel (got both USBs and HDMI working with it but no LAN). I guess if one really wanted to dig deeper into this, would need to figure out how to do own uboot with recent patches available for these devices.  But this isn't really the greatest hardware either since it only has 2x USB 2 ports and LAN is 100/10, meaning the throughput to network is going to be limited even with external LAN adapter (could still be enough for some applications like home automation).


Like mentioned before, I have full dump of the T96Max's DTS file here too and it's not really that different from stock orangepi one so using that could also help here, I just have zero clue how to do the custom uboot atm with armbian. A lot of the knowledge around this seems to be scattered around and a lot of things are left unexplained, probably because these are considered to be too advanced for people new to custom builds.

Link to comment
Share on other sites

@rzu I believe it is possible to use MythTV files to boot Armbian or another distro. I tried various possibilities and combinations of merging with armbian and orange without success. I wanted to use a Brazilian expression for an amateur job, I'm afraid it will end up being offensive to you😄, let's say, a beginner's job, amateur, with little technical knowledge.


maybe just changing the Mythtv uboot to work with armbian or orange. Or else you will have to change the uboot and system files the distro used to make the boot work on tx6s. I didn't delve further due to lack of knowledge. For someone to get their hands dirty and do it, just that they are very interested in using the tx6s or love a challenge.


With what I know today, I would never have bought this model of tvbox for sure.

Link to comment
Share on other sites

Hey @TeroDada, I also have a H313 box. It seems to be a x96 something... I tried a bunch of images, it does not boot. You said that ubuntu image booted, did you do something with it? I tried to burn it into a SD card but it gives out a warning that it is not a bootable image. I tried anyway, and the box does not boot. 

Any help would be appreciated at this point!

Link to comment
Share on other sites

On 4/7/2023 at 10:28 PM, Sigma7 said:

@ArkhanLK have you tried again to install Armbian on TV Box with H313 chip? Hey @TeroDada, could you share your solution?


Hey man. I have not tried again... Nothing I tried worked for the box I have (it is 100% the H313 chip, yes). I tried stuff for H616 too, but I may be too noob to figure out how or what to do in this case. Still really looking forward to a solution! So, thanks for quoting me and if you know anything, let me know. I can share my knowledge/attempts with you, but again, it is very basic stuff.

Link to comment
Share on other sites



see that this one have support but iam not able to boot.

Is it possible to make armbiam of this?

Allwinner H616TanixTX6s-axp313works (ap6330@SDIO)worksworksnot works (firmware issue)some things are still missing

Allwinner H616TanixTX6sworks (xr819@SDIO)worksworksnot works (firmware issue)some things are still missing


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines