Jump to content
  • 0

Helios64 USB to serial device not detected


n3o
 Share

Question

Hello, I have recently bought a Helios64 item. I have mounted it, I have done all steps written on wiki here https://wiki.kobol.io/helios64/kit/ and here https://wiki.kobol.io/helios64/install/sdcard/ but when I try to follow this steps https://wiki.kobol.io/helios64/install/first-start/ USB to serial bridge is not detected by my notebooks (I have tried with notebook 1 (windows10 x64 with drivers downloaded and installed with exe setup) and notebook 2 (x86 cpu with last kernel ubuntu and windows xp)). I have unmounted the backplane cover, jumper P10, P11 and P13 (see here jumper description https://wiki.kobol.io/helios64/jumper/ ) are all opened so my question is: what is the problem?

 

p.s. 1: When I have followed this step https://wiki.kobol.io/helios64/install/sdcard/ when i plug the power connector automatically system has booted without that I press power bottom (in the link at step 4 is written "Don't power-up the Power Adapter yet") ... something has been happened that cause the not detection on my notebooks?

 

p.s. 2: the USB to serial bridge can be detected from notebooks with system that is turn off with only plug power connector plugged (with only LED1 lighted https://wiki.kobol.io/helios64/led/)? I make this question because here https://www.youtube.com/watch?v=58coL23Bzzw the dude first turn on helios 2:05, after when is linked with usb and execute picocom command helios is turn off 2:08 and finally he turn on Helios device 2:10

 

p.s. 3: when I realize that the USB to serial bridge isn't detected by my notebook, I turn off the device from power button. Sometimes is necessary only press button for 1 second and device is turn off, other times I press button for 5 seconds... but in the last case I hear a whistle... something can be damaged in the second scenario?

 

p.s. 4: if I must buy jumper shorting, the spec of 2.54 mm is right?

 

Hoping that somebody help me 

 

Best regards

 

Edited by n3o
Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 0

After reading this thread 

maybe the cause is related to missing jumpers shorting P10 and P11 ... but why isn't been written in the wiki that for boot from microsd should be shorted P10 & P11 jumper? and why console don't start even if isn't found the bootloader code ? console is contained inside armbian image?

 

Another question: here https://wiki.kobol.io/helios64/troubleshoot/  there is the section bootloader

 

Old bootloader¶
On October 5th, 2020 there was device tree (dtb) filename change. It applied to Armbian 20.08.8. Originally the filename is rk3399-helios64.dtb and changed into rk3399-kobol-helios64.dtb

Boot from microSD card and execute following commands


sudo mkdir -p /mnt/system
sudo mount /dev/mmcblk1p1 /mnt/system
sudo ln -sf rk3399-kobol-helios64.dtb /mnt/system/boot/dtb/rockchip/rk3399-helios64.dtb
sudo umount /mnt/system
sudo poweroff
Remove the microSD card and power on the system.

After boot successfully to eMMC, we strongly suggest to update the bootloader using armbian-config.

 

 

this step update emmc memory? the updated bootloader is present in the last armbian buster image?

Edited by n3o
Link to comment
Share on other sites

Search Before Posting!

  • 0

Hello, let's not waste time, you seem to be in a hurry, that's good for me too.

 

Take a Windows computer because they are all the same,
create a "Helios64" folder on the Desktop, open it then create a "Helios64_BKU" folder and a "Helios64_IMG" folder

 

open your internet browser

go on Armbian
click on download from archives
Select an Image, if you don't know which one let me suggest
move the downloaded compressed image to the "Helios64 IMG" folder

unzip in the directory with his name.

 

Then go to the win32diskimager page
in the tab "files" click on the directory "Archive" and choose win32diskimager-1.0.0-install.exe
after download, install it.

 

then go to the PuTTY Site
Download the latest version from
choose MSI (‘Windows Installer’) 64-bit x86
after downloading, install it.

 

open win32diskimager
choose the image file in "Helios64_IMG" selected the location of your SD card on the computer, then click on write.
at the end of the process, remove the SD card from the computer.

 

Then restarted your Windows computer.

Link to comment
Share on other sites

  • 0

Now let's check your Helios64 Unit,
we will start on Helios64 by booting from an SD card,
for this the bridges must be closed in P10 and P11 the jumpers must be in position (pay attention to the direction).
as explained on the Kobol WIKI https://wiki.kobol.io/helios64/jumper/#boot-mode-p10-p11

jumpers J09/13/14/15 must be open (without jumper)

all the cables are in their place and correctly fixed on the motherboard,
a network cable was plugged into helios64 on the same network as the computer,
and hard drives have been removed from slots.

 

now connect your Helios64 unit to your Windows computer with a USB-C to USB-A data cable <1m (USB-C power cables do not work)

your Helios64 unit must be switched off but plugged into an electrical outlet.

 

in Windows search typed "Computer management" open the program then in "device manager" open "Ports"
noted the COM(X) corresponding to Helios64

 

Open PuTTY, in order to make a serial connection
select Connection type: Serial
in Serial Line put: COM(X)
in Speed Put: 1500000
Saved Session type: Helios64 USB
Click Save,
choose Helios64 USB in Saved Session then click on Open.

a PuTTY window opens titled "COM(X) - PuTTY"

 

Put your SD card in the SD slot of your Helios64 and turn it on.

 

normally your PuTTY window displays the boot returns of your system.
at the end you are greeted with a fixed Helios64 display and status information,
followed by the prompt
open a note and copy the local IP of your Helios64 unit (XXX.XXX.XXX.XXX) save in Desktop/Helios64/myhelios64.txt

 

then we will use PuTTY for a remote connection.
to do this from the PuTTY icon right-click select PuTTY (64-bit)
in order to make a remote connection
select Connection type: SSH
in Host Name put: local IP (XXX.XXX.XXX.XXX)
in Port type: 22
Saved Session type: Helios64 ETH
Click Save,
choose Helios64 ETH in Saved Session then click on Open.

a PuTTY window opens titled "XXX.XXX.XXX.XXX - PuTTY"

 

in the prompt
login as: root
@XXX.XXX.XXX.XXX's password: 1234

greeted by a fixed Helios64 display and status information
followed by the prompt

 

did you succeed ?

Link to comment
Share on other sites

  • 0

Tonight I'll buy jumper shorting and tomorrow I'll tell You, do You confirm that should be of 2.54 mm?

 

Hope that with jumper shorting usb to serial device is founded by Windows, because at current status when I link usb nothing is detected

Link to comment
Share on other sites

  • 0

well, let's drop the jacket you want!

 

it is not necessary to have the jumpers at P10 and P11 to make a serial connection through the USB-C port of your unit, when P13 is open.

 

Normally Kobol has provided in the Bundle two jumpers and a screw for the M.2 module in a small plastic bag. 

 

There are several reasons that can cause problems.

 

1.The backside of the case that supports the fans prevents your USB-C head cable male plug from properly seating in your unit's USB-C female Slot. remove it so that you can connect directly.

 

2. Your USB-C cable is not the original one provided by Kobol and this may be the cause, try another (the thicker the better).

 

3. Your Windows computer does not correctly recognize the Helios64 Serial port, in 'Device Manager' check 'Other Device' and 'Universal serial bus controller', 

or try from another Computer any System (Linux lsusb) 

 

4. Maybe your unit is faulty, in order to verify that your helios64 can start normally, when the jumper 2.54mm are in place.

try the remote connection after boot (after starting the system, the system LED should flash quickly, if it then flashes slowly, your system has started correctly),

capture your unit's local ip on the router/computer/Smartphone but make sure you are on the same local network. 

for example you can use (https://techet.net/netanalyzer/). 

 

 

after all

X. Removed the motherboard from the case and take pictures of your Motherboard from above and below, and verify that all components are in place. users have complained about breaking things, maybe you pay the price for their mistakes. 

 

Y. Close P13 and see what Windows/Linux says.

 

Z. Retry the operations on the card outside the case but leave it on the metal support and check check the status LEDs on the motherboard and play with Buttons. 

Link to comment
Share on other sites

  • 0

ok, so You think that my issue is not the same of this thread https://forum.armbian.com/topic/20591-helios64-no-boot-no-serial-line-no-fan-some-leds/ ?

 

In the 3rd post user wrote

 

"Hello,

Thank you for your answer.

For a reason I don't get, but I had to strap Jumper P10 and P11, and I got something on the serial line"

 

fot the other consideration:

- I have bought Helios64 from a user that has told of never used it so I don't have found the jumpers and the screw for the M.2 module.

 

1. Already tried to connect usb without backplane but nothing is detected

 

2. The usb-c cable is the original one because it was enclousure in the plastic bag with the id number of item.

 

3. I'll will retry with windows 10 notebook, but with x86 notebook the lsusb command has only retrieved mouse device, webcam device and roothub

 

4. The system boot because if I turn on it without microsd card all the 5 hdd led are fixed lighted, if I turn on it with microsd card the swystem activity led is blinking and the system error led is turn off. So question is: what does it load if the first start steps ( https://wiki.kobol.io/helios64/install/first-start/ ) aren't even executed? Without the use of console I can't set ip, and without the setting of ip I can't execute "sudo armbian-config" command to install open media vault . Do you know if it's possible use ssh without execute the commands of the wifi on console?

 

Y. if I close J13 jump I disable the USB to Serial converter ....  so I think it's worst ... or not?

 

p.s.: Can be the cause of the issue the hard disk plugged? In other worlds, can be a problem plug hard disk at first install? I have only 2 hdd plugged at slot 1 and 3

 

 

Link to comment
Share on other sites

  • 0

If your unit is new, this allows you to remove a lot of unknowns. the SPI and EMMC being empty the jumper was not mandatory. 

 

Hard drives extend startup time and can cause the system to fail to boot, that's why I advise you to remove them, and then put them 1 by 1 when you have a functional system.

 

The P13 allows switching from a serial connection on the helios 64 motherboard to a mass storage connection on the unit's Emmc.

 

If your unit boots without an error led and the system LED flashes slowly after 20 to 70 seconds of booting.

Your unit has certainly negotiated its ip assignment with your router. check on your router if Helios64 appears.

Grab the ip and do a remote SSH connection on it.

Link to comment
Share on other sites

  • 0

For some unknown reason you can't use the USB-C port,

consider that for the moment your card is a 3-legged stool instead of a 4-legged chair.

You will try to sit on it with a remote connection. 

 

https://wiki.kobol.io/helios64/install/first-start/#step-5-connect-to-helios64-via-ssh

 

Adress Mac helios64s 64.62.66.XX.XX.XX

Router > list devices

Computer > arp

Android/Ios > https://techet.net/netanalyzer/

 

You must also try the hdmi output by usb-c, 

you may be able to use your unit as a Computer, 

and have access to the prompt. 

https://wiki.kobol.io/helios64/usb/#display-port

 

If you do not obtain a local IP address after starting your Unit, Unfortunately, I couldn't help you any further. 

 

You'll still have the P14 serial connection to see what's been going on since startup,

but I've never had to do that, and I don't have the expertise or experience to help you further.

https://wiki.kobol.io/helios64/usb/#serial-console

 

Link to comment
Share on other sites

  • 0

ok, the helios is founded on my router and I have configured it from ssh (even if I don't understand why console doesn't working).

 

Now I have also other problem to fix:

1. if I access on storage -> disk in openmediavault are showed the following device:

 

helios1.jpg

 

Why if I have only 2 sata devices (the 2 WDC drives) and 1 microsd of 32 GB that contain image system are listed 4 device? Is used internal eMMC named "/dev/mmcblk2" ? Why? I don't want use eMMC memory, only the 2 sata drives and microSD and I want that all the settings are being saved into microSD memory.

 

Moreover, going to storage ->File system , the following file system are showed:

 

helios2.jpg

 

In file system tab there's only /dev/mmcblk1p1 ... what does it mean?

 

2. If I follow this tut https://www.youtube.com/watch?v=gT-EGNl9bZA when try to connect from my windows 10 notebook, user and password setted aren't accepted... how I see the problem in file log from ssh?

 

3. In Access Right management -> Shared folder I can't share sdb device .... why it's not mounted automatically such as sda?

 

If I want copy some files from a folder into sdb device into a folder into sda device how should I do from terminal?

 

Link to comment
Share on other sites

  • 0

that's great, I'm glad you can use your Helios64 unit.

 

I was a little worried about you, because from memory I never read this type of problem with a broken USB C port,

moreover you arrived after the battle, and Kobol no longer supports after-sales service .

Regarding your questions about OpenMediaVault, this goes beyond ARMBIAN.

 

when you install the OMV overlay on your unit it profoundly modifies your Armbian distribution, so it is painful for anyone to help you on the ARMBIAN forum,
moreover we do not use OMV in the same way, in file management it is preferable to take the time to understand how it works and how to make it work.

it's best to ask your questions on the OpenMediaVault Forum directly after reading Documentation.

 

/dev/mmcblk2 is your EMMC
/dev/mmcblk1 is your SD card

 

nevertheless if this is your first grip, for OMV I give you the following advice do not put your sensitive data before being sure of what you are doing, and being sure that it works without problem.

(you are not safe from a corruption of file rights, or an unusable exotic partition)

once again I now invite you to browse the forums and specific documentation.

 

Avoid compulsive updates, and do not hesitate to make image backups on /Desktop/Helios64/Helios64_BKU/ of your SD card, before any installation / update / modification.

Link to comment
Share on other sites

  • 0

thank You for the answer; so considering that "/dev/mmcblk2" isn't showed in storage -> file system it's mean that isn't used, is true?

 

how I can verify that there aren't corruption of file? Sholud I check md5 or sha checksum of each file in the hdd? What utility in shell ssh I can use to calculate checksums?

 

I have already done many updates except kernel, how are made images backup on Desktop ? and how I can made restore if something do not more work?

 

another thing: I want disable the autopower on, I have read here https://wiki.kobol.io/helios64/gpio/#gpio-control and here  https://wiki.kobol.io/helios64/auto_poweron/, the Systemd-shutdown Script is already present , if I try to execute "echo 0 > /sys/class/gpio/gpio153/value" in "To disable the Auto Power-On" section of 2nd link I'll get an error ... what I wrong?

Link to comment
Share on other sites

  • 0

Of course partition there, mount the filesystem and you have 16gb on SOC.

 

Regarding the files, I expressed myself badly, I was talking about the access rights on the files, it was corrupt because I was handling the OMV files by rooting on my Armbian desktop,

and in the error I tried to redefine the rights and the owners since an SCP connection under windows and boom it became nonsense.
I had to take the discs out one by one to read them in a low level system to recover my files with no owner rights.

 

You can use Win32Diskimager and press read instead of write, this will create an .img backup of your SD (beware the program if all your SD card has a capacity of 128Gb you will have a 128gb image,

nor will you be able to write your image to an SD card smaller than 128gb afterwards, unless you resize it with another program.

I have been using Win32DiskImager for a very long time, there are many other ways to do the same in the command line or program, it is not absolute.

 

I rediscover the functions of helios64 with your questions, my unit being in operation 24/24, I had not paid attention to that.

You can use this program to walk around in user space

WinSCP

read Documentation and Download here.

you can change things very quickly

 

If you are unfamiliar with "tree file" and the user commands you can also install fish on your unit from ssh.

read Documentation here

apt-get install fish

and play with the tab and esc key

 

have many fun !!

Link to comment
Share on other sites

  • 0

thank You for the answer .... about gpio control and disable power on permanently, how should I fix the issue? Actually I don't have the board plugged in the UPS external (so the NAS is always power off)  neither the small ups battery is linked . So I don't want that if the UPS is turned off, and power go off and go on, ups turned on automatically

Link to comment
Share on other sites

  • 0

As I often say there are 1001 ways to use a same device.

what is obvious for one is a special case for others.

You must try for yourself until you get the result that satisfies you in your use.

 

did you follow the procedure, as explained by Kobol?

WinSCP makes it very quick and easy to edit files.

 

 

while wandering around i found this

maybe this will fix your mute usb-c.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...