Jump to content
  • 0

Kernel 5.19.x not working for me with media branch (rockchip64 works)



I planned to upgrade and skip current 5.18 (EOL) with edge 5.19 or just use LTS 5.15.


Offcial images 5.19/edge (e.g. Armbian_22.08.1_Nanopct4_sid_edge_5.19.5.img.xz) won't boot at all, maybe a short uboot screen.

Using uboot v22.04 like other rk3399 boards did not fix it.

SInce the nanopct4.conf is boardfamily=media but also works with rockchip64 (which was changed some time ago),

building with boardfamily=rockchip64 current 5.15 or edge 5.19 works fine, the cli builds boot as expected. 


Maybe a general question, which bordfamily fits now best to nanopct4. I remember exactly problems which were fixed bei 150balbes maintainer when pulling it to media.

Thankfully all patches found their way to rockchip64, which seems to be more active for rk3399 in general.


Do you have any plans to combine them again? 


Link to comment
Share on other sites

17 answers to this question

Recommended Posts

Help Armbian team helping you

  • 0

Hmm, i deleted mmcblk2 to be sure to have no remaining stuff on it, booting with any 5.18 image like Armbian_22.08.1_Nanopct4_jammy_current_5.18.19.img and dd it.


sudo dd if=/dev/zero of=/dev/mmcblk2 bs=1M


Then tried Armbian_22.08.1_Nanopct4_sid_edge_5.19.5.img again, here is a screenshot of uboot, after that the screen loses signal and device does not boot (checked through dhcp on router).


Link to comment
Share on other sites

  • 0

I built Armbian_22.08.2_Nanopct4_jammy_edge_5.19.10.img with following command, no changes made:



Same error, see screenshot.

As mentioned earlier when changing boardfamily to rockchip64, so their patch directories (kernel+uboot) are used to build the image instead of media, it works fine.

Maybe some patch is missing?

I also made a build from master branch, Armbian_22.11.0-trunk_Nanopct4_jammy_edge_5.19.10.img which also does not get beyond uboot.


Link to comment
Share on other sites

  • 0

Version 20220926 works!

Tested Armbian_22.11.0-trunk_Nanopct4_jammy_edge_6.0.0.img and Armbian_22.11.0-trunk_Nanopct4_jammy_current_5.19.11:

Both boot, show no dmesg errors and emmc install (boot+system) is fine.


I will receive my UART device tomorrow for future debugging.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...