Jump to content

u-boot for direct sata boot


Recommended Posts

Helios4 can boot directly from the sata disk nr 1, without the need to switch from the SD or the eMMC.
I personally tried setting SW1 to 11100 and using u-boot-sata for Clearfog, which shares the same uSOM and the system booted regularly, obviously the system didn't recognize many devices being u-boot for another board.


I tried to compile a version of u-boot for sata trying to integrate the changes present in https://solidrun.atlassian.net/wiki/spaces/developer/pages/287212134/A38X+U-Boot in the U-boot build instruction and sources for Helios4 present in the Kobol Wiki but my skills are not sufficient for such a job.


In the binaries available for Helios4 at  https://imola.armbian.com/beta/pool/main/l/linux-u-boot-helios4-current/ there are only u-boots for uart, flash and mmc. 

Would it be possible to have the sata version in future releases?

Thanks in advance and for all the work done.

Link to comment
Share on other sites

Yeah that should be no problem. Just compare these two files:


(Clearfog configuration)


(Helios4 configuration)



Just provide a PR with added targets here https://github.com/armbian/build/blob/master/config/sources/families/include/mvebu-helios4.inc#L11
Test it by building locally and we'll have sata uboot on the next release.

Link to comment
Share on other sites

I tried to modify configuration but unlucky it's not sufficient and I got error that I'm unable to fix.


  LD      spl/u-boot-spl
  OBJCOPY spl/u-boot-spl-nodtb.bin
  CAT     spl/u-boot-spl-dtb.bin
  COPY    spl/u-boot-spl.bin
  MKIMAGE u-boot-spl.kwb
  CFGCHK  u-boot.cfg
[ error ] ERROR in function compile_uboot [ functions/cli/cli-entrypoint.sh:108 -> functions/main/default-build.sh:55 -> functions/compilation/uboot.sh:145 -> functions/logging/traps.sh:0 ]
[ error ] U-boot file not found [ u-boot-sata.kwb ]
[ o.k. ] Process terminated


Link to comment
Share on other sites

4 hours ago, Mangix said:

I am curious why


Because nobody volunteered to try, check for possible regressions and submit changes? From project perspective, if @Heisathdon't have much time and interest, there is nothing we can do as project is way way too small to follow endless users & HW needs. We don't have a backup


Link to comment
Share on other sites

@Mangix because u-boot was maintained by the kobol team, which have given up supporting both their boards. I do not currently have the time to switch to another u-boot and test / fix upgrade and new image scenarios. But there are only a few patches https://github.com/armbian/build/tree/master/patch/u-boot/legacy/u-boot-helios4 and so it might be possible to go upstream. You are welcome to try and send a patch. 


I might also try, once I find time + motivation for it.

Link to comment
Share on other sites

Upstream u-boot (in its next branch) has now lot of 32-bit armada / mvebu patches related to SD/eMMC, SATA and UART booting. Also on mailing list are waiting some Clearfog eMMC patches.

Likely you should take Helios patches and put then on top of the u-boot next.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines