Jump to content

Ping command local lookup does not work


Guy
 Share

Go to solution Solved by Myron,

Recommended Posts

I am trying to ping device on my network by device name, it works on my Linux computer and does not work on my NPi R1.
Expecting pinging the device name will retrieve ping data including my device local IP.

 

$ ping HPC0180319938E.local
ping: HPC0180319938E.local: Name or service not known


I preformed

sudo apt update && sudo apt upgrade

 

 

Not sure how to check ping command version.

 

_   _ ____  _   ____  _  
| \ | |  _ \(_) |  _ \/ |
|  \| | |_) | | | |_) | |
| |\  |  __/| | |  _ <| |
|_| \_|_|   |_| |_| \_\_|
                         
Welcome to Armbian 22.08.8 Focal with Linux 5.15.74-sunxi


 

Link to comment
Share on other sites

Search Before Posting!

  • Solution

Looks like I've found a solution.  See: https://askubuntu.com/questions/772774/unknown-host-even-though-avahi-is-installed-and-running

 

I installed libnss-mdns and altered the hosts: line in /etc/nsswitch.conf to read:

hosts:          files mymachines mdns4 [NOTFOUND=return] dns myhostname

 

resolving mdns names is now working for me.

Link to comment
Share on other sites

It looks like even though avahi daemon was running I was missing

libnss-mdns

 

so just installing it using

 

sudo apt install libnss-mdns

 

solved it.

 

In my case /etc/nsswitch.conf already had similar content, maybe from my previous attempts to solve this

 

hosts: files mymachines mdns4_minimal [NOTFOUND=return] dns myhostname

 

Thanks for all the help

Edited by Guy
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...