Jump to content
  • 0

Problems ILI9341and hummingboard


nowy1
 Share

Question

 

Hello,

 

I have a problem with connecting to ILI9341 hummingboard

 

postaebuje as described

 


 

 

I do entry

 

Add this to your / etc / modules: fbtft_device name = adafruit22a rotate speed = 90 = 48000000 fps = 50 GPIOs reset = 67, led 72, dc 195 busnum = 1

reboot

 

but the display is lit only shows nothing

 

What may be the problem

 

wyśietlacz exactly

 

Link to comment
Share on other sites

21 answers to this question

Recommended Posts

  • 0

Double check wiring ... it should work out of the box. Which kernel do you use?

It should be only slightly lit, just background ... than try to test with:

fbi -d /dev/fb2 -T 1 -noverbose -a yourimage.jpg
Link to comment
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

  • 0

Double check wiring ... it should work out of the box. Which kernel do you use?

 

 

Welcome to ARMBIAN Debian GNU/Linux 8 (jessie) 4.7.3-cubox

 

 

after entering

 
fbi -d / dev / fb2 -T 1 -noverbose -a mini.jpg
using "DejaVu Sans Mono-16", pixelsize = 16.67 file = / usr / share / fonts / truetype / dejavu / DejaVuSansMono.ttf
 
and nothing shows on the LCD backlight only
Link to comment
Share on other sites

  • 0

Remove driver from auto loading and start manually. 

modprobe fbtft_device name=adafruit22a rotate=90 speed=48000000 fps=50 gpios=reset:67,led:72,dc:195 busnum=1

and proceed with image loading.

 

Edit: 

 

For auto loading, try this: add only fbtft_device to /etc/modules and create conf file for parameters.

echo 'options fbtft_device name=adafruit22a rotate=90 speed=48000000 fps=50 gpios=reset:67,led:72,dc:195 busnum=1' >/etc/modprobe.d/fbtft_device.conf
Link to comment
Share on other sites

  • 0

 

Remove driver from auto loading and start manually. 

modprobe fbtft_device name=adafruit22a rotate=90 speed=48000000 fps=50 gpios=reset:67,led:72,dc:195 busnum=1

and proceed with image loading.

 

Edit: 

 

For auto loading, try this: add only fbtft_device to /etc/modules and create conf file for parameters.

echo 'options fbtft_device name=adafruit22a rotate=90 speed=48000000 fps=50 gpios=reset:67,led:72,dc:195 busnum=1' >/etc/modprobe.d/fbtft_device.conf

 

 

 

It works but once you start the system must enter

 
manually
 
modprobe fbtft_device name = adafruit22a rotate speed = 90 = 48000000 fps = 50 GPIOs reset = 67, led 72, dc 195 busnum = 1
 
add an entry to the rc.local?
 
if I can somehow view the desktop instead of the display on hdmi?
Link to comment
Share on other sites

  • 0

No, you don't need to start it via rc.local - try method to create module parameters. This is usual way in recent system ... I realized later that the manual was done when in Debian Wheezy era.

 

You need to tell desktop to use /dev/fb2 some. I was using it only this way:

https://github.com/igorpecovnik/homedisplay

 

Check here.

Link to comment
Share on other sites

  • 0

No, you don't need to start it via rc.local - try method to create module parameters. This is usual way in recent system ... I realized later that the manual was done when in Debian Wheezy era.

 

You need to tell desktop to use /dev/fb2 some. I was using it only this way:

https://github.com/igorpecovnik/homedisplay

 

Check here.

 

 

How do you think did so to do the same with two displays?

 
Link to comment
Share on other sites

  • 0

SPI bus allows you to have multiple devices attached to a bus but here is edge of my experimenting / knowledge ... so I hope someone else could provide more details how to do it.

Link to comment
Share on other sites

  • 0

Kernel config file, TFT enabled.

https://drive.google.com/file/d/0B5PY...

cmdline.txt including TFT configuration.

https://drive.google.com/file/d/0B5PY...

I planned to create a patch, but I did not find the original RPi kernel source (3.6.y). I have the working copy of the modified kernel source, however:

https://drive.google.com/file/d/0B5PY...

Unfortunately, there is no schematic, however wiring is pretty simple:

LCD0 - RPi
SDO(MISO) - MISO/GPIO9, pin21 (common)
LED - 5V through 1k resistor, pin 2 (common)
SCK - CLK/GPIO11, pin23 (common)
SDI(MOSI) - MOSI/GPIO10, pin19 (common)
D/C - GPIO24, pin18
RESET - GPIO25, pin22
CS - CE0/GPIO8, pin24
GND - GND, pin 6 (common)
VCC - 3.3V, pin 1 (common)

LCD1 - RPi
SDO(MISO) - MISO/GPIO9, pin21 (common)
LED - 5V through 1k resistor, pin 2 (common)
SCK - CLK/GPIO11, pin23 (common)
SDI(MOSI) - MOSI/GPIO10, pin19 (common)
D/C - GPIO18, pin12
RESET - GPIO23, pin16
CS - CE1/GPIO7, pin26
GND - GND, pin 6 (common)
VCC - 3.3V, pin 1 (common)

Link to comment
Share on other sites

  • 0

I am sure about one thing. Forget about RPi kernel parameters and kernel config ... they are irrelevant. You already have all support for display within kernel and you got one working ... if you need two working, seek how to switch between them. It's probably only loading another module with different parameters and changing with GPIOs which is active. Probably.

Link to comment
Share on other sites

  • 0

so far I've been able to run one of the link :(

 
 
 
root@cubox-i:~/RPi.GPIO_BP/homedisplay# FRAMEBUFFER=/dev/fb1 startx


X.Org X Server 1.16.4
Release Date: 2014-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-0.bpo.4-armmp-lpae armv7l Debian
Current Operating System: Linux cubox-i 3.14.79-cubox #7 SMP Wed Sep 14 22:56:30 CEST 2016 armv7l
Kernel command line: root=/dev/mmcblk0p1 rootfstype=ext4 rootwait console=ttymxc0,115200 console=tty1 video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24,bpp=32 rd.dm=0 rd.luks=0 rd.lvm=0 raid=noautodetect pci=nomsi ahci_imx.hotplug=1 consoleblank=0 vt.global_cursor_default=0 quiet loglevel=3
Build Date: 11 February 2015  01:18:06AM
xorg-server 2:1.16.4-1 (http://www.debian.org/support) 
Current version of pixman: 0.32.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.5.log", Time: Sat Oct 22 20:29:00 2016
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Link to comment
Share on other sites

  • 0
/dev/fb2

2 is correct device number for this small display.

 

 

 

Now it works and how to add to auto start?

 
because now the system is booting up I have to enter:
 
modprobe fbtft_device name = adafruit22a rotate speed = 90 = 48000000 fps = 50 GPIOs reset = 67, led 72, dc 195 busnum = 1
 
lights up the display and now fits:
 
Framebuffer = / dev / fb2 startx
Link to comment
Share on other sites

  • 0

Read above
http://forum.armbian.com/index.php/topic/2615-problems-ili9341and-hummingboard/?p=18199

 

1. Create a file /etc/modprobe.d/fbtft_device.conf with content: 

options fbtft_device name=adafruit22a rotate=90 speed=48000000 fps=50 gpios=reset:67,led:72,dc:195 busnum=1

2. Add:

fbtft_device

 to /etc/modules (without anything)

 

3. Reboot

Link to comment
Share on other sites

  • 0

Read above

http://forum.armbian.com/index.php/topic/2615-problems-ili9341and-hummingboard/?p=18199

 

1. Create a file /etc/modprobe.d/fbtft_device.conf with content: 

options fbtft_device name=adafruit22a rotate=90 speed=48000000 fps=50 gpios=reset:67,led:72,dc:195 busnum=1

2. Add:

fbtft_device

 to /etc/modules (without anything)

 

3. Reboot

 

 

hello, or touch-screen also supports the armbian as plug in?

 

and if you can control the brightness of the display?

Link to comment
Share on other sites

  • 0

Touch screen should be doable but I haven't done it.

 

Brightness of this display. No idea if this is supported on this display / driver ... most likely not. Try to get this info from driver maker ... if it's implemented, it will work on Armbian too.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...