Support for Mele A1000/A2000 armbian

Recommended Posts

Hi, thanks for the efforts making armbian very well and very stable for all the distributions, I'm running with a Cubieboard 1 and other arm devices..


I don't want to disturb,

but I'll be a headache to support or add in repository this old A10 device  Mele A1000/A2000? 

I know that is old chip, but I'm feel nostalgia, because was one of  firsts devices supported in linux-sunxi, and Tom Cubie worked at mele, and sell this litlle joys overseas in 2012, and there are a lot of people now that have  this devices too. a lot now sure in the dust ;) and is in mainline kernel also.


Tom left Mele, and maked Cubieboard 1, this Mele A1000 I think that have the same configurations, and cubieboard was based on it, this board has no external 40/44 pins headers like cubieboads or other dev devices


I forked the library and maked a test,


1) added the fex file (for 3.4.x compilations I think, kernel mainline don't needed right? )


from https://github.com/linux-sunxi/sunxi-boards/blob/master/sys_config/a10/mele_a1000.fex

2) added a conf file in boards section (i don't know if is correct, I  based from cubieboard.conf file)



Is the correct form to add a device to run compile.sh?


I run and maked the image and works like a charm, I think that can be polished but is out of my experience :(, but now works,

I know that I can compile a new kernel in every update of armbian lib, but I don't know if it can be added to baords list of armbian, and have a fresh compile every update of the libs.


and if is a problem I will do it as now of if can be a better configure option, I'm a all ears.


thanks in advance. Pere.

Share this post

Link to post
Share on other sites
Is the correct form to add a device to run compile.sh?


Yes, that's enough. We can accept / add it to the script while I am skeptic for adding to download section since it's an older device.


There is a dedicated device tree within mainline kernel, so it would be good to create new u-boot config for this board:



# CONFIG_CMD_IMLS is not set
# CONFIG_CMD_FLASH is not set
# CONFIG_CMD_FPGA is not set

This is copy past from Cubieboard1 with changed DT path. Need to be tested and checked.


After you are satisfied make a pull request.

Share this post

Link to post
Share on other sites

oou ;) , many thanks Igor,


Yeah, this device is old !! make sense not putting in download section,

taking 1 A10 board for reference as cubiebard1 that is in download section, users can make a idea how to make images for older devices if follow script pattern.


I will try to add the configuration files for this board, and if can be added to the main lib script as accepted will be great, or configuration added but in a disabled state that only has to be uncommented for lib detect and build the image if user select the device.



Share this post

Link to post
Share on other sites

Igor I recently installed ARMBIAN 5.65 stable Debian GNU / Linux 9 (stretch) 4.19.17-sunxi from (https://dl.armbian.com/melea1000/archive/). Everything works very well. Because I have Mele A2000g I have 1G Ram. Can you tell me how to change your image so that Armbian can see the full 1G Ram. I am trying to compile, but it's hard for me to be my first contact with Linux. Maybe you could also compile such a version?



Edited by Pctrend
add source

Share this post

Link to post
Share on other sites

Welcome to ARMBIAN 5.65 stable Debian GNU/Linux 9 (stretch) 4.19.17-sunxi   

System load:   0.78 0.55 0.52  Up time:       23:11 hours

Memory usage:  33 % of 485MB  Zram usage:    6 % of 242Mb  IP:  

CPU temp:      32°C           

 total        used        free      shared  buff/cache   available

Mem:         497216      166340      118280        3652      212596      317116

Swap:        248604       14592      234012

Share this post

Link to post
Share on other sites

Gentlemen, I'm sorry I did not thank you immediately for your suggestions. But I could not get more memory in Armbian.

On the box from the bottom:

Mele model A2000G .

After a few hours of fighting, I opened the box. I found memory chips on the PCB.


2PCS X H5TQ2G63DFR-H9C   DDR3-1333H (supports down binning to DDR3-1066F), x16, density: 2G

That means I have 4 GB of flash and 512 MB of RAM even though I have an A2000G sticker on the box. Thanks for support . Igor, you're doing a great job.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.