0
kometchtech

Solved stop at boot time (cubietruck)

Recommended Posts

The following message is logged when you start using the following versions of the vanilla kernel debian jessie and get stuck.
[ TIME ] Timed out waiting for device dev-ttyS0.device.

[ DEPEND ] Denpendency failed for Serial Getty ono ttyS0.
4.3 and 4.5 install to the SD card by entering the same State.

legacy kernel even experiencing the same symptoms and can't get to the login prompt.

What should I do?
 
 

 

Share this post


Link to post
Share on other sites

What  :o No kernel is working for you? 3.4.109 and 4.2.3. Are you doing power cycle? Have you try to set clock as described here? Once this is solved you should be able to boot normally.

Share this post


Link to post
Share on other sites

The problem persist only on Jessie images. On others  there is an fix build into startup script.

 

There are many ways how to do it but none is ideal. Disabling sytemd is the best out of this since it covers new install and upgrade. Disabling it at least for first boot and problem would go away.

 

Since I haven't put no info about new releases, I would rather rebuild all Jessie images with kernel 4.x and disable systemd. That was origina idea but I lost focus on other things.

 

I'll write on first page within release info @www.armbian.com when it's done.

Share this post


Link to post
Share on other sites

I updated all Jessie images with kernel 4.x ... they are working as expected.

At first boot you get an error / eth0 failed to bring up ... ignore it ... than my scripts fix RTC and reloads the Ethernet. This is possible if there is no systemd so it's disabled by default.

 

You can turn systemd back if you like. Howto is inside /boot/boot.cmd

Share this post


Link to post
Share on other sites

No, the problem is first boot and only when we came from older kernel. The reason is difference in RTC handling. When your clock is once set, errors are gone ... forever or until you boot again into old / legacy kernel  ;)

Share this post


Link to post
Share on other sites

Latest kernel 4.3.2 has one annoying bug fixed / I2C debugging was enabled and that rapidly fills the log. The rest I guess no major changes.

Share this post


Link to post
Share on other sites
In order to confirm whether the file has been successfully downloaded, I want you to tell me the md5sum.
 
By the way, following such error message when you start from being output.
root@cubietruck:~# systemctl poweroff
Failed to get D-Bus connection: Unknown error -1
Best regards.

Share this post


Link to post
Share on other sites

I was not aware of the PGP sign. I'm sorry.

Making the Systemd over there, there is no merit in using the jessie.
Since the time being vanilla kernel does not start well with some reason out of the environment, and then to go in the legacy kernel.

Best regards.

Share this post


Link to post
Share on other sites

You can easy enable systemd back. It's pre-configured and it works. It's only disabled because it sometimes hangs at first boot (RTC).

 

Read first few lines in boot script /boot/boot.cmd:

# if you want to boot jessie with systemd: setenv bootargs init=/bin/systemd console=tty1 ...
# remember to disable ramlog prior switching to systemd
setenv bootargs "console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=1"

Share this post


Link to post
Share on other sites

You must forgot / mistype something. I just did this on latest Jessie image for Cubietruck with kernel 4.2.3. with desktop.

 

It's working as expected.

Share this post


Link to post
Share on other sites


sunxi# setenv bootargs "console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=1"

 

sunxi# boot

Still, it stops when Starting Kernel.

Share this post


Link to post
Share on other sites


Somehow I feel like solved.

First put the init=/bin/systemd, good only to regenerate boot.scr?



setenv bootargs "init=/bin/systemd console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=1"


My best regards.

 


Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
0