Jump to content

New install, ethernet doesn't work (no lights even) and USB3 ports are dead.

Go to solution Solved by Werner,

Recommended Posts

New OPI5+, unable to finish install because ethernet doesn't work.


I haven't been able to figure it out and my searches turned up nothing.


journalctl has the following messages:


 - hpptx phy lane locked!

 - rk_gmac-dwmac fe1c0000.ethernet error: no phy at addr -1

 - stmmac_open: cannot attach to phy (error -19)


I've checked power supply, cables,  edited the interfaces file, and more , with no success. I have an Orange Pi 5 that I can swap as is in its place and everything works. Coupled with the fact that I couldn't find mention of the errors, I'm hoping that someone can help me before I give up and return the OPI5+.









Edited by octal8
Spelling error.
Link to comment
Share on other sites

Posted (edited)

I switched to the official Orange Pi installation and it works fine. So it's not a hardware issue.  Since an Orange Pi 5 worked fine in the same setup, I was suspecting that and am glad because I didn't want to return it.


Based on the symptoms, it seems like a driver/configuration issue.


The problem is I don't want to use the official Orange Pi installation since it is run by Huawei with servers in China. For one, I'd much rather use an organization run by volunteers (Armbian) than one run by a corporation. Also, with the way things are going between the USA and China, who knows what may happen in the future with respect to sanctions, etc...


Marco, I tried your suggestion and it didn't work. Still no USB3 and Ethernet. 


Werner, I'm going to try your suggestion next to see if it narrows down what I need to do to make Armbian work.




Edited by octal8
Spelling error.
Link to comment
Share on other sites

Posted (edited)



 -Still no USB3

- Still no Ethernet

- Parted doesn't recognize the nvme M.2 card installed.

- Installing the OS to the emmc chip remains a mystery.

- No sound


Edited by octal8
Added "No sound"
Link to comment
Share on other sites

8 minutes ago, Werner said:

As Efe stated. You are using the wrong images. Oranhe Pi 5 != Orange Pi 5 Plus


On the Armbian website, all three OP5 hardware versions are lumped together on the same page. There are two images available on the page, the cli version that I'm using, and a Gnome version.




There is also a link for older versions, but since the OPI5+ is new, something tells me they would not be better.


What am I missing?

Link to comment
Share on other sites

20 minutes ago, ricardo_brz said:

The one posted by Efe here is official, do you mean you want something more official than that?


My apologies to all, especially Efe. I missed the obvious. 


I need some sleep.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines