Jump to content

Wifi module AX210

Go to solution Solved by Werner,

Recommended Posts

Hello everyone, and Happy New Year.

One question about Orange Pi 5 Plus: i have installed a wifi module (supported than what the official Orange documentation reports) AX210NGW in my Orange Pi 5 Plus main board with Operating System: Armbian 23.11.1 bookworm and Kernel: Linux 5.10.160-legacy-rk35xx.

I copied in /lib/firmware the firmware of the module (https://intel.ly/3S0QZrA).
if from the terminal I run: lspci
I see the device but in "Armbian-config" in hardware section don't see the wifi module, and I can't activate the module to surf the Internet or the local network in wifi.

The question is: am I forgetting any steps to setup the wifi module correctly?

Link to comment
Share on other sites

Hello @Werner thanks for your suggestion.

I have enabled (via armbian-config) the orangepi-5-ap6275p module (listed), see attached image (orangepi-5-ap6275p.jpg)

I restarted the pi5plus board, but the wifi still isn't working.
The wifi module is visible with lspci (see attached imagem - lspci.jpg)

The Manage wireless networking section (on armbian-config) only displays the two Ethernet network cards, as the network cables have been disconnected. (see attached image wired_connection.jpg).

Important some question: you suggested

"Try rk3588-wifi-ap6275p.dts or rk3588-wifi-pcie.dts from here:


1) OK, but Where should I copy the two files (rk3588-wifi-ap6275p.dts or rk3588-wifi-pcie.dts) you suggested?

2)  Will I see the copied items in the list under the 'Toggle hardware configuration' section in armbian-config?

3) Do I need to enable both items  (rk3588-wifi-ap6275p.dts or rk3588-wifi-pcie.dts)?







Link to comment
Share on other sites

Thank you @Werner,  but I have read the documentation on overlays and do not have enough experience to make the changes myself.

I also don't know how to create the dtbo file to put in the /boot/overlay/ folder.
Anyway, thanks for the help.

Link to comment
Share on other sites

Please help me with the exact same problem with the exact same board, distro, and wifi card. I am very inexperienced with Linux and am having the same problem. Tried installing the firmware manually, tried running apt install armbian-full-firmware, and it ran through the whole rigamarole, but I'm still having trouble. Wifi module isn't in armbian-config, but it is in device list, wifi options are in the GUI, but doesn't find any networks.


usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm DOES exist but I don't know how to delete it. 


Dmesg results in image




Edited by Antimtr
Link to comment
Share on other sites

Thank you Royk! I've been learning a lot of commands--googled for an hour and couldn't find that remove command. I'll try it and update after. 


*Update* tried it and still getting wifi unavailable.

Bizarrely, the Bluetooth is working fine. Smh.


*Update 2* I threw the kitchen sink at it so I don't know which solution posted here finally worked, but after trying everything--i put the wifi into airplane mode then turned airplane mode off and the module activated!


Signal strength is only 3 bars right next to my router though. I've turned power management off. Any easy way in armbian to give the card maximum voltage?

Edited by Antimtr
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines