new? boot problem

Recommended Posts



after trying to upgrade to new image 4.5 (don't know whether this was successful...) and reboot, my cubietruck get's stucked:



What could have happened? Is this the same problem, some others describe here or totally different?

Seems like it doesn't find 'a boot file'!? What does this mean? Bootloader is on sd, root etc. on hdd. 


Thanks and best regards,


Link to post
Share on other sites
Donate and support the project!

Yes, boot is on sd, everything else on hdd. Survived some reboots before.


I upgraded from ubuntu trusty 4.1 image / vanilla kernel. Was it the 4.2 kernel?


I used 

wget -q -O - | bash

to upgrade to the 4.5 image (did this already some weeks before in order to update to the 4.1 image.)

Is this the right procedure, to run this again? Or should I have just use apt-get upgrade?


Seems that it didn't do anything, but i'm not sure. So after that I ran

apt-get update && apt-get upgrade

Also didn't seem to do much (maybe beause I have automatic upgrades activated?).


So I decided to try to reboot in order to see whether it'll come up with a new kernel but oops,... doesn't boot any more.

Link to post
Share on other sites

When you do this procedure once, you don't need to do it again. Than you proceed with apt-get update / upgrade.


Script should work, I made many tries up and downgrade. Try to find upgrade.log and paste it here (it's in the directory in which you run the script). It would help to resolve the issue.


To get system running - I can only point you to Documentation - How to unbrick the system?


Before proceeding, check boot scripts and try to boot from SD system first, only change root=/dev/sda1  to /dev/mmcblk0p1


I fixed something today on the way but that does not affect / was not a problem.

Link to post
Share on other sites

Hi Igor,


instead of installing a whole new system in parallel, I'd first like to try your 'unbrick-mechanism' as described under Documentation.

I'm just wondering whether I'll need only the 4 files you mention in 'How to unbrick the sytem' or in addition the headers and especially the u-boot, as you mention here: ?

If I'd need also the u-boot, could you please tell me the URL to it, since I couldn't locate it.


Thanks and best regards,


Link to post
Share on other sites

Igor, could you please tell me where to download the 4.3 image for trusty-next-cubietruck (Ionly found the single files but that doesn't seem to work)?

[Edit]: Ok, guessed the right download-link ;-)



- installed latest 4.5 image on sd

- did sata-install on fresh hdd

- tried to boot with newsd+old hdd (with all my data on it)


-> didn't work because during boot process e.g iptables complains about wrong kernel


Thanks and best regards,


Link to post
Share on other sites



Ok, don't know, what have caused the problem but after 

- installing 4.2-image on sd

- doing sata-install on fresh hdd

- booting from sd with old hdd

system comes up! :)


Seems to be f***ed-up somehow (iptables and some other complain, I have to look into it...) but it's up & running again.


Although: Seems that system still was on kernel 4.1.6, although I did the update-stuff with new update-script. Have to try this again.


Link to post
Share on other sites
This topic is now closed to further replies.