Jump to content

Armbian 2.15 fresh install and apache don't start after reboot - Debian 8


paul75
 Share

Recommended Posts

Hello,

 

I test to prepare a sd with the fresh install with the last image in the website 5.25. I installed Apache2 php5 mariadb and it works but when I reboot the system apache don't start it tell that /var/log/apache2 not found. The I created the directory apache2 and restart apache manually => ok it start.

I reboot the system and again it failed withe the same message !*I go to /var/log/ and not see the apache2 created ....

 

 

Thanks for help

Link to comment
Share on other sites

When discussing a problem make sure to provide full logs!

 

Perhaps logram size is too small for your scenario ... disable or debug the ram logging service.

systemctl disable log2ram.service 

Hello,

 

Thanks not works without do :  apt-get -o DPkg::Options::="--force-confmiss" --reinstall install apache2

 

after it works.

 

Strange because in my other than have 5.23 and upgrade to 5.25 (apt-get upgrade) it not do this .....

 

 

Thanks

Link to comment
Share on other sites

Perhaps logram size is too small for your scenario ... disable or debug the ram logging service.

systemctl disable log2ram.service 

Hello,

 

I test to prepare a sd with the fresh install with the last image in the website 5.25. I installed Apache2 php5 mariadb and it works but when I reboot the system apache don't start it tell that /var/log/apache2 not found. The I created the directory apache2 and restart apache manually => ok it start.

I reboot the system and again it failed withe the same message !*I go to /var/log/ and not see the apache2 created ....

 

 

Thanks for help

 

I have the same problem.

 

In this web: https://github.com/azlux/log2ram

 

I see this, but doesn't work:

 

Customize services :

If you open the file /etc/systemd/system/log2ram.service , you will see a line starting by Before=, you can list here the services who need to start after log2ram. You will need to change this line when a service start too fast and stop running because log2ram mount a ram folder where it has start to write log.

For example, If you use apache instead of nginx, add apache2.service into this line.

Link to comment
Share on other sites

I had this exact same issue, but on an ubuntu image (Armbian 5.25, Ubuntu 16.04, pine64) and checked the service status of apache2, and saw the following two errors - sorry, ends were trimmed by SSH scrollback history

(2)No such file or directory: AH02291: Cannot access directory '/var/log/apache2/' for main
(2)No such file or directory: AH02291: Cannot access directory '/var/log/apache2/' for error


I decided to take it on face value, and created the directory, and what do you know... it worked!  This was fresh after installing a new (l)amp stack via sudo apt-get install lamp-server^ on a fresh pressed and updated Armbian image.  Stupid apache2! ;)

sudo mkdir /var/log/apache2

 

Link to comment
Share on other sites

Same Problem :)

Armbian uses log2ram for /var/log. And log2ram writes logs to storage every 1 hour.  Basically if you install services and reboot computer before write all changes including new folders be missing :)

most easy option is for example:

 

sudo apt-get install apache2

sudo log2ram write

sudo reboot

 

and all works fine :)

 

for confirmation after restart run:

ls /var/log

 

and look for "apache2" folder

 

for chaking if system use log2ram type:

df -h

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...