Jump to content

CSC Armbian for RK322x TV box boards


Recommended Posts

On 2/20/2023 at 5:03 AM, Luciano Almeida said:

I would still like to boot from internal memory, but multitool no longer displays the option to write to NAND. ("Burn Armbian image via steP-nand")

ow do I switch back? Do I have alternatives to work without SD or external USB?

NAND are not exactly easy beasts, if the multitool does not detect it anymore it is because the kernel rockchip driver does not detect it.

It is difficult to say what happened exactly, we have spent hours and hours to figure out what was the behaviour of the nand driver and all the other proprietary software pieces of the puzzle.

Also they are quite "fragile" pieces of hardware, and abusing of them can quickly destroy the cells capacity to work.


In the past, people has restored the NAND functionality restoring original android images with AndroidTool for windows, or uploading particular bootloaders; you should look for such resources in this thread (or with google) because some procedures were described to do so I forgot to bookmark.


For what me and @fabiobassa have seen, what seems to be an apparently random behaviour of the NANDs, in reality it is deterministic and can be understood. What we've found to be totally confusing was the fact that keeping anything attached to the board (HDMI, ethernet, keyboard, serial adapter, ... whatever!) can prevent the NAND from being detected after a reboot.


Also remember to use the armbian image with the legacy kernel, those with mainline kernel miss the proprietary driver. Also you could post a dmesg log after booting such legacy kernel image to see what the driver has to say about NAND.


Link to comment
Share on other sites

On 2/21/2023 at 2:37 PM, fabiobassa said:



Have you read the whole topic ?




Because at the beginning Is clear that multitool will warn you if inside the box there is a nand


That said , go read First post


Hi, I have write multitool image to microsd with rufus, but when I have turnon the device multitool menu isn't been showed and only an android menu has been showed... What should I do?

Link to comment
Share on other sites

4 hours ago, speed21 said:

does anyone tried adding a usb gigabit lan to make your smb server transfer speed fast? I am not quite sure that it will get its full speed since the box only have a usb 2.0

Best hope is that it will go around 400mbit/s, more reasonably around 300/350mbit/s; surely you won't get anything near the full gigabit.

Link to comment
Share on other sites

52 minutes ago, n3o said:

Hi, I have write multitool image to microsd with rufus, but when I have turnon the device multitool menu isn't been showed and only an android menu has been showed... What should I do?

Paste the serial output logs here; without them, we're blind

Link to comment
Share on other sites

Here are my impressions after some weekend tests:


Overall, it's all working better than I expected ! 


Despite some things I have read here, the desktop experience is fine to me, maybe my
standards are too low? chromium is loading first time in about 10 
seconds, after that it's faster. It's not super responsive to the commands, but
it's not too laggy either.


Youtube in Chromium is almost OK to watch, which surprised me, I expected much
worse. But there is some stuttering. I think it can work much better with some
external app. I installed smtube, but it depends on youtube-dl which was failing,
but now I found a 2023 version of it that seems to work, to be tested later.


I installed many window managers, jwm, icewm, wmaker and lxde, all working well,
but I now mostly like icewm which combines a very light ram usage and some nice
windows-looking menus. Ideal to show your friends who think linux is an OS that only
can be used by wizards.


My parents like printing so I put there cups with hplip, and libreoffice showed
a nice preview, remote printing worked, which made them impressed, they asked me how I did
that, funny, right.


Ethernet worked for most of the time but suddenly stopped one or two times, I
am not sure if this is a driver issue or network-manager related, to be verified.

Wifi was failing to load, I now found out that ssv6051 was looking for a .conf
file and it was named .cfg in the filesystem, to verify later if it works after correcting it.


The internal storage was detected as mmcblk2 and some partitions mmcblk2boot0 and boot1,
however I couldn't mount them, I am not sure what goes on here, maybe it's
a different rockchip filesystem because of the boot files and with the correct
offset it can be mounted, to be checked later.


IN my opinion it truly makes a little pc in your tv, thumbs up ...

Link to comment
Share on other sites

On 2/25/2023 at 9:47 PM, jock said:

No, I mean the serial output logs. If you don't know what I'm talking about, read the rest of the thread or search with google.


from first post I have read the followng post 


What do You mean for serial output logs?

Link to comment
Share on other sites


....... Serial UART (configured at 115200 bps, not 1.5Mbps!) ....   that means serial output logs

if really you have read CAREFULLY the first post you should have read this too !

Anyway here is described all, exactly in the first post

if somethings is still not clear, here is not a ready food store but you should proceed by trials and errors, andmostly study by yourself

And you didn't even read the post of another user:



eMCP is RAM and Flash on one Chip most time  , --> when you have only one big chip beside the CPU

since you DON'T HAVE a big chip beside the cpu, then you have nand or emmc. Easy , isn't it

Multitool will say what it is, if a emmc or a nand

But you come back again asking and asking, and asking again

This usually is not a right approach to a forum


Link to comment
Share on other sites

49 minutes ago, fabiobassa said:

This usually is not a right approach to a forum


my apologies, I'm newbie with hardware... I have this device



it's useful to reach the goal? if not can you post the device to buy?


If yes, can you post photo of how link cable dupont from board to that device? I ask just of little patience

Link to comment
Share on other sites


Hello, I have a smart speaker, RK3229CPU, and the sound card is AMK’s AK7755EN. The firmware of the box can be flashed normally, but there is no sound driver. How can I recognize the AK7755EN normally? If it needs to be developed separately, I am willing to pay for the relevant fees . Thank you very much.


The following is the introduction of this speaker:



ak7755_f01e.pdf (akm.com)


I extracted the dts file of smart speaker android for your reference.


my email is:2823609@qq.com



smart speak R1 android.dts



Edited by Prioner
moved inlined file to spoiler
Link to comment
Share on other sites

1 hour ago, fabiobassa said:

is a 329q1


how do You have discovered that is a 329q1? how do You have discovered that is nand and not emmc?


what do You tell about item linked? it's useful or I shoult buy another uart? and the dupont link?

Link to comment
Share on other sites

hello @Prioner

If the driver has no source available, I don't think it can work with a compiled kernel.
The only way I see a closed source driver could work, would be if you used your original kernel and used it to boot a linux file system.

Have a good week,
Link to comment
Share on other sites

Hi everyone, Im triying to boot multitool but it doesnt work. When I put the SD card with multiboot for RK322X box doesnt show anything on display (display stays standby) and blue led doesnt blink. I also tried booting it with the toothpick method (like I do with LibreElec 9.2 just fine) and same behavior. Box specs:

OTT MXQ 4K (not Pro) device with these specs (real and verified by me with my camera):

RK3229 CBBKM43012 1552 CPU

SanDisk P553072141 SDTNRGAMA-008G CP0813618 NAND


Pulse H1102NL 1549-M ETH

Espressif ESP8089 05215 P27X03 WiFi

Board name T066-V1

Firmware MXQ-4K_ota_20160308


For the sake of adding more info, LibreElec 10 doesnt boot (but shows some stuff on display) like I posted here: https://forum.libreelec.tv/thread/25236-unofficial-rk3228-rk3229-libreelec-10-x-builds/?postID=177493#post177493

Maybe LibreElec 10 and Multiboot issues are related.

Would LOVE to try Armbian on this little device.

Link to comment
Share on other sites



What do you mean " inspected by my camera"


Have read, again, the whole post ( no, i Guess)


Because already discussed that even if marked 3229 sometimes are fake and they really are amlogic or allwinner.

Heve you skills to get a USB TTL converter and give us a serial log ?





Link to comment
Share on other sites


I think he meant that he took some pics with his camera.
And, please correct if i'm wrong, but, @ochentay4 if you can boot libreelec I think you can boot armbian , at least by doing a mixed image, as proposed by user "hexdump" in the first posts, that's how I prepared my sdcard image too.
good luck
Link to comment
Share on other sites

@jock@fabiobassa and others 

Thanks for great support for RK322x.


I had x96mate with h616, after booting arch, its HDMI gave up on me, so after reading your post got the RK3229 box.


I don't intend too use as a desktop but as a kiosk.

Mainly I use chromium, nodejs, and mpv/ffplay/cvlc (anyone)


Box I got is rk3229 with nand, so teste 3 legacy images, one without DE and two with xfce from OP. Everything works as expected on horizontal mode. 


As I need mpv to run smoothly, installed media package by @jock


after installing media support, i no longer able to rotate my display, before installing the media support display rotate worked.


cannot use xrandr to rotate also option in settings ---- display, rotate option is not there.


DISPLAY=:0 xrandr --output HDMI-1 --rotate right


any clue how to sort this out ? 

Edited by BigZero
Link to comment
Share on other sites

On 3/1/2023 at 4:49 PM, fangis said:

can you still boot to android ?


I do not more tried because I don't know if device that I already have is useful to connect to UART. Moreover, even if somebody confirm that is useful, I don't know  how connect UART on the 329q -1 board to that interface (it's better post a photo because with electronic I'm noob).


However I'm not interested to use Android TV 7 current firmware ... because when I want use acestream I cannnot use my smartphone as bluetooth keyboard to insert link.


Hope that somebody answer me

Link to comment
Share on other sites


I will try to get a USB TTL converter and give you a serial log but it will take time, as I dont have the neccesarry stuff to do it myself and I cant get one so easily online where I live.

What I meant to say was that I took photos with my camera and took note of all chip descriptions.

I can confirm its a real RK3229 and I already managed to boot LibreELEC 10 thanks to "ilmich" here: https://forum.libreelec.tv/thread/25236-unofficial-rk3228-rk3229-libreelec-10-x-builds/?postID=177599#post177599 that fixed it.

I also tried to boot several armbian images, even legacy ones, and same beahavior as multitool, black screen (stand by) and no blinking leds. 

I also tried to scan my network to see if multitool booted but had no display and no, it doesnt how (of course my DHCP is working and cable plugged on ethernet port).

Tried with tootchpick, no toothpick, tried both holes, it doesnt show anything on screen, only blue led on.



I read the post by "hexdump" and its really complicated for me at the moment, I need to learn more. Thats why I wanted to test armbian on this device so I can "play" with linux.


Something else: I dont know why my profle is still "Validating"... and cant post more than 1 post a day and cant change my avatar... Some help would be welcome.

Edited by ochentay4
Link to comment
Share on other sites

@fabiobassa I have searched for photo and I have found that model is R329Q_V3.1. Do you confirn that UART consist in only 3 cable link:

1. TXD (on CH341A board) - RX (on R329Q board)

2. RXD (on CH341A board) - TX (on R329Q board)

3. GND (the pin on CH341A board below RXD) - GND (on R329Q board)






in red circle there are link to UART, right? ... for the install of image the usb port to link to linux pc is the green circle port?


In putty window, when I choose "Serial" on connection type, in "Serial line" label it's showed "COM1" as default ...Leave it and set only Speed to "115200" ?


To use multiboot only (to search what error there's) it's necessary also link usb cable male - male?

Link to comment
Share on other sites



Il Mich , jock, and me we are actual studiers/developers in those rk322x and thanks to a Little " intuition" Mich discovered a missing piece in dtb and this Is  the reason libreelec booting and armbian or multitool NO.

We must build a " Frankenstein" boot with multitool kernel and libreelec dtb.

And yours Is a tipical case study





Link to comment
Share on other sites

On 2/28/2023 at 2:06 PM, fabiobassa said:


....... Serial UART (configured at 115200 bps, not 1.5Mbps!) ....   that means serial output logs

if really you have read CAREFULLY the first post you should have read this too !

Anyway here is described all, exactly in the first post


@fabiobassa this is your post .... you have written 115200 bps, not 1.5Mbps


I have read the first post, moreover You have told that I have only Nand (without eMMC), so I must follow procedure NAND and installation from SD. Before this, I should also update bootloader as described here 


Edited by n3o
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines