Jump to content

CSC Armbian for RK322x TV box boards


Recommended Posts

On 4/17/2023 at 1:20 AM, jock said:

If you don't provide any logs, photos, description of the issue (you were talking about the loader before, now you talk about armbian dtb...) you will be banging the head for yet long time...

well the issue is every armbian image i tried, from legacy to current to nightly is not working. after flashing the image, it always just having a red led light. as for the loader, that was a different issue i first encountered. I dont have an sdcard adapter so i tried following installation without SD card. but the loader you provided is working, so that issue was fixed. i cant provide any logs since its not letting me boot. as for the photos, i only have a phone with crappy camera but here you go.

Edited by http418
Link to comment
Share on other sites

@http418 Still, the necessity of the boot logs are sine-qua-non condition to understand why the board does not boot, otherwise anyone can't be of any help here. To get the boot logs you need the serial adapter and to find the serial pads/pins on your board. Possibly they are below the heatsink, but I have no such board so I don't know.


About your board, an R29, the HDMI port is reported to not work and I can't fix that, because - again - I have no such board. Did you try to access via SSH to the board after 5 minutes it booted to see if is working or not?

Link to comment
Share on other sites

3 hours ago, jock said:

About your board, an R29, the HDMI port is reported to not work and I can't fix that, because - again - I have no such board. Did you try to access via SSH to the board after 5 minutes it booted to see if is working or not?

not at all, since it doesn't even boot. also, i dont have a serial adapter. however, i managed to boot an initramfs base of an armbian image (with filename: Armbian_23.05.0-trunk-e33842ef2_Rk322x-box_lunar_edge_6.2.9_xfce_desktop.img)  by using dd with uInitrd and skipping the first 64 bytes(based from openwrt).
for the other partitions, i basically just followed this, the only difference is that i use the stock uboot and trust from stock android rom, then i packed a resource image using the 'rk322x-box.dtb' from mentioned armbian image. sadly after a reboot it wont boot at all. but i managed to get the dmesg log:



Edited by http418
Link to comment
Share on other sites

On 4/21/2023 at 11:34 AM, Tiago Tavares Rodrigues said:

Hello, i'm geting this error when try flash multitool image.  




Can help?


Hi @Tiago Tavares Rodrigues


Try this:

- exclude all partitions on your sdcard;

- create one partitiion included all disk space;

- format this partition to FAT32;

- go to balena and burn multiboot image.


Link to comment
Share on other sites

Am 27.4.2023 um 21:20 schrieb mr. madness:

6051p network card.

sorry for late answer


you have to try some LED-Config ( better name GPIO Config) settings inside rk322x-config tool and always reboot after every change, 

it should be support by kernel 5.x , else you can try legacy image ( with kernel 3.xx)



Link to comment
Share on other sites

2 hours ago, Wilcon Barro said:

Is there an image file of this armbian where erasing the mmc is not needed? I tried flashing the images to sd card, but it doesn't boot/black screen. Multitool and libreelect works though.

There is no prebuilt image of that kind on purpose: whenever you do an update of the kernel/uboot, it will break the system and it won't boot anymore.

Link to comment
Share on other sites

Hello @jock,


I have R29 board and want to help out with the no video problem.


Here's stuff i gathered so far:

* CPU is RK3229 (Based on what Android says it is. Couldn't remove heatsink to physically check, it's "glued" on really tight, didn't want to use excessive force to not damage anything).

* On WiFi chip is written S9012P but Android says it's AP6210 (Neither has Linux driver so whatever).

* Standard 1GB/8GB RAM/storage setup.

* Photos of board front, back

* Device tree dumped from running Android

* dmesg of Android

* dmesg of multitool

I've noticed multitool has troubles reading storage too.


Let me know if you need anything else.


Link to comment
Share on other sites

@spinning banner Hello!

Unfortunately R29 boards seem to have a widely well-known issue with HDMI output, which is not working for some unknown reason.

Some research has already been done in the past on device trees, inspecting photos and logs, but still the problem is unknown, as long as I don't have such a board in my lab to really study where the problems are.


The S9012P wifi chip also is a no-name chip, as long as I remember it is a chinese chip with no known drivers that "emulates" a realtek chip (not a broadcom one, like those which AP6xxx are based upon), but I can be wrong.

 @RaptorSDS did some research on that chip, but as far as I know, there is no solution because there is no driver for that (see https://forum.armbian.com/topic/12656-csc-armbian-for-rk322x-tv-boxes/page/57/#comment-156548)


R29 is a quite weird board actually; despite being very similar to others, has some compatibility issues all-around and it does not surprise me the multitool has troubles with emmc, although it should have none.

From the android dmesg I see on android the eMMC runs at 31.25 MHz; Multitool runs it at standard 50 MHz, and that may be the cause of the flash storage issues on multitool.

The reason could be a  very poor quality board or eMMC,  because ALL the boards with eMMC I have ever seen runs the eMMC at 50Mhz perfectly fine and I never had to downclock the eMMC frequency to solve an issue like that.



Link to comment
Share on other sites

Hi, I want to install armbian with my tv box that has rk3229 chip. But it seems that I cannot install it due to compatibility issues, can you help me please? I also noticed that your multi tool has bash script, we have a project and it needs to be done by this week, I was hoping that i can use your multi tool since it has the same function as the armbian (bash script) and I want to have an access where i can install mariadb, ssh, apache2 for our requirement. Can you please help me? Thank you so much! 

Link to comment
Share on other sites

vor 4 Stunden schrieb Wonder Xyril:

compatibility issues,

Let's look into the crystal ball, I see something, it could be that something is not right here and someone has problems with a rk322x box. hope you understand this little fun, it would be of course especially with such a time pressure of only a week surprising if we could really solve your problem with such a crystal ball, so let's start here. Describe your box in more detail, which multitool which problem from which point, why this solution not something else and much much more ....

Link to comment
Share on other sites

@RaptorSDS I bought a fake tv box (https://shp.ee/w5h2xzg), it says that its amlogic, but in reality it is RK322x. 

I've tried flashing most of the builds that is related to RK322x, but none of them worked. I have flashed it directly to the sd card and used the multi tool to burn and nothing worked. (direct sd card - nothing happens, not booting) (multi tool - eMMc not showing, and the image cant be found.) 

Link to comment
Share on other sites

vor 1 Stunde schrieb Wonder Xyril:

amlogic, but in reality it is RK322x

how do you know , do you open the box and remove the heatsink ? , maybe after all really a AmLogic maybe?

we seen like sell as amlogic , print on die as rockchip and after all allwinner chip  or stupid things like sell as rockchip print as amlogic and really is rockchip older model


please show and tell us more

Link to comment
Share on other sites

Hey everyone, I have tv box same as user Md Ashik Khan, I have tried to burn multi tool, or burn armbian image to SD card but it does not boot. It shows black screen and nothing happening so I have no idea how to debug this 😞 any suggestions? Thanks

Edited by Himera
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines