Jump to content

Share Screen in Raspberry Pi 5B

Recommended Posts

Hello all,

I am using Armbian (Debian Bookworm), Gnome with Wayland. everything is working just fine. The problem is with sharing or presenting screen with OBS-Studio, Jitsi, Google meeting or other. 

If I share a tab in Chromium/Firefox with Jtisi or Google meeting, that's work, but I can't share a window or full screen. I am wondering what is the main cost of that.

This when I share full screen, it doesn't work properly, it shows like this:

Sharing screen, doesn't work as well.

This when I share tab, it's working just fine.



Link to comment
Share on other sites

I have tried sharing screen with Chromium on Wayland session and I got this:

[2:2:0707/210734.551088:ERROR:object_proxy.cc(576)] Failed to call method: org.freedesktop.ScreenSaver.GetActive: object_path= /org/freedesktop/ScreenSaver: org.freedesktop.DBus.Error.NotSupported: This method is not implemented
[2:15:0707/210735.038303:ERROR:ev_root_ca_metadata.cc(162)] Failed to decode OID: 0
[34:34:0707/210751.850181:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 1 times!
[34:34:0707/210751.851681:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 2 times!
[34:34:0707/210757.085650:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 3 times!
[2:170:0707/210803.727287:ERROR:egl_dmabuf.cc(632)] Failed to bind DMA buf framebuffer
[2:170:0707/210803.727339:ERROR:shared_screencast_stream.cc(938)] Dropping DMA-BUF modifier: 72057594037927935 and trying to renegotiate stream parameters
'loop->recurse > 0' failed at ../src/pipewire/thread-loop.c:426 pw_thread_loop_wait()
'loop->recurse > 0' failed at ../src/pipewire/thread-loop.c:426 pw_thread_loop_wait()


Then I tried that with firefox and got this:

[GFX1-]: vaapitest: ERROR
[GFX1-]: vaapitest: VA-API test failed: failed to initialise VAAPI connection.

'loop->recurse > 0' failed at ../src/pipewire/thread-loop.c:425 pw_thread_loop_wait()
'loop->recurse > 0' failed at ../src/pipewire/thread-loop.c:425 pw_thread_loop_wait()


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines