Nightly Builds


Recommended Posts

Donate and support the project!

Yes i tried doing the build and it worked the first time sadly the second time i tried it it wont boot :(

although it MAY be because im running 16.04.3 so i have to VM ware it and try again.

 

It would just be nice for everything to be in "one spot" but yeh.

 

 

As for donation, the project has no money, (its completely volunteer) and in its infancy, but maybe ill throw something you guyzes way, its a solid project :) Thanks for the work!

 

 

Link to post
Share on other sites

option one: edit /etc/apt/sources.list.d/armbian.list and change apt to beta, save, apt update, apt upgrade, reboot

option two: armbian-config, switch to beta (nighlty or daily build), reboot

 

Nothing else.

 

If kernel flag is changed in this file: https://github.com/armbian/build/blob/master/config/kernel/linux-sun50i-dev.config then you should notice changes. (this config is responsible for the kernel you are using).

Link to post
Share on other sites

It was looking for /boot/dtb/allwinner/allwinner..... where all the files where in boot/dtb/allwinner/..

 

so i moved them and now it get the same thing i got when i compiled it myself

Spoiler

 0 
38518 bytes read in 130 ms (289.1 KiB/s)
Unknown command 'bmp' - try 'help'
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
3362 bytes read in 191 ms (16.6 KiB/s)
## Executing script at 4fc00000
U-boot loaded from SD
Boot script loaded from mmc
116 bytes read in 159 ms (0 Bytes/s)
23204 bytes read in 522 ms (43 KiB/s)
** File not found /boot/dtb/allwinner/overlay/sun50i-h5-fixup.scr **
4992073 bytes read in 455 ms (10.5 MiB/s)
12288008 bytes read in 890 ms (13.2 MiB/s)
## Loading init Ramdisk from Legacy Image at 4fe00000 ...
   Image Name:   uInitrd
   Image Type:   AArch64 Linux RAMDisk Image (gzip compressed)
   Data Size:    4992009 Bytes = 4.8 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 4fa00000
   Booting using the fdt blob at 0x4fa00000
   Loading Ramdisk to 49b3d000, end 49fffc09 ... OK
   reserving fdt memory region: addr=4fa00000 size=6c000
   Loading Device Tree to 0000000049ace000, end 0000000049b3cfff ... OK

Starting kernel ...

Loading, please wait...
starting version 229
Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... Scanning for Btrfs filesystems
done.
Begin: Waiting for root file system ... Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.

 

 

Link to post
Share on other sites
On 2017/09/02 at 1:20 AM, Igor said:

Well, my recipe should work on stable builds, but in beta areas, there is no warranty - it might or not ... things are WIP.

 

Try altering boot device in /boot/armbianEnv.txt or simply pay attention to build log changes https://github.com/armbian/build/commits/master

Latest git pull fixed the boot problem but now i list usb :P im guesrsint DTB issue so digging i go thanks for all the help :) (i know its DIY and even if it wasnt you would be under no obligation to give it so i appreciate it!)

Link to post
Share on other sites
On 9/1/2017 at 8:20 AM, Igor said:

If you want to test latest builds, it's also fairly ok to download just any available image for this board, switch to beta repository and update. It will work in most cases. 

Sorry if this is too noobish but how do I switch to the beta repository?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.