1 1

[Solved] [Udoo Quad] Jessie to Stretch: not booting after upgrade

Recommended Posts

I upgrade Jessie to Stretch and installed (from armbian stretch)





Unfortunately the kernel is not booting any more from sata:


U-Boot SPL 2015.10-armbian (Nov 22 2017 - 17:21:35)

U-Boot 2015.10-armbian (Nov 22 2017 - 17:21:35 +0100)

CPU:   Freescale i.MX6Q rev1.2 at 792 MHz
Reset cause: POR
Board: UDOO Quad
DRAM:  1 GiB
No panel detected: default to HDMI
Display: HDMI (1280x720)
In:    serial
Out:   serial
Err:   serial
Net:   using phy at 6
Hit any key to stop autoboot:  0
** Bad device size - sata 0 **
AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl SATA mode
flags: ncq stag pm led clo only pmp pio slum part
SATA Device Info:
S/N: B645560128
Product model number: TS256GSSD370
Firmware version: 20140516
Capacity: 500118192 sectors
Booting from sata ...
37690 bytes read in 391 ms (93.8 KiB/s)
7120160 bytes read in 164 ms (41.4 MiB/s)
Kernel image @ 0x12000000 [ 0x000000 - 0x6ca520 ]
## Flattened Device Tree blob at 18000000
   Booting using the fdt blob at 0x18000000
   Using Device Tree in place at 18000000, end 1800c339

Starting kernel ...

Booting Linux on physical CPU 0x0
Linux version 4.14.0-udoo (root@armbian) (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.4)) #18 SMP Wed Nov 23:35 CET 2017
CPU: ARMv7 Processor [412fc09a] revision 10 (ARMv7), cr=10c5387d
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
OF: fdt: Machine model: Udoo i.MX6 Quad Board
Memory policy: Data cache writealloc
cma: Reserved 256 MiB at 0x40000000
random: fast init done
percpu: Embedded 17 pages/cpu @af61a000 s40396 r8192 d21044 u69632
Built 1 zonelists, mobility grouping on.  Total pages: 259840
Kernel command line: console=ttymxc1,115200 root=/dev/sda1 rootwait rw fbmem=24M video=mxcfb0:dev=hdmi,1920x1080M@60,bpp=32
PID hash table entries: 4096 (order: 2, 16384 bytes)
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 759876K/1048576K available (10240K kernel code, 744K rwdata, 2340K rodata, 1024K init, 456K bss, 26556K reserved, 262ma-reserved, 0K highmem)
Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
    vmalloc : 0xc0800000 - 0xff800000   (1008 MB)
    lowmem  : 0x80000000 - 0xc0000000   (1024 MB)
    pkmap   : 0x7fe00000 - 0x80000000   (   2 MB)
    modules : 0x7f000000 - 0x7fe00000   (  14 MB)
      .text : 0x80008000 - 0x80b00000   (11232 kB)
      .init : 0x80e00000 - 0x80f00000   (1024 kB)
      .data : 0x80f00000 - 0x80fba2fc   ( 745 kB)
       .bss : 0x80fc4e74 - 0x8103723c   ( 457 kB)
SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
Hierarchical RCU implementation.
NR_IRQS: 16, nr_irqs: 16, preallocated irqs: 16
L2C-310 errata 752271 769419 enabled
L2C-310 enabling early BRESP for Cortex-A9
L2C-310 full line of zeros enabled for Cortex-A9
L2C-310 ID prefetch enabled, offset 16 lines
L2C-310 dynamic clock gating enabled, standby mode enabled
L2C-310 cache controller enabled, 16 ways, 1024 kB
L2C-310: CACHE_ID 0x410000c7, AUX_CTRL 0x76470001
Switching to timer-based delay loop, resolution 333ns
sched_clock: 32 bits at 3000kHz, resolution 333ns, wraps every 715827882841ns
clocksource: mxc_timer1: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 637086815595 ns
Console: colour dummy device 80x30
Calibrating delay loop (skipped), value calculated using timer frequency.. 6.00 BogoMIPS (lpj=30000)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 2048 (order: 1, 8192 bytes)
Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
CPU: Testing write buffer coherency: ok
CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
Setting up static identity map for 0x10100000 - 0x10100060
Hierarchical SRCU implementation.
smp: Bringing up secondary CPUs ...
CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
CPU2: thread -1, cpu 2, socket 0, mpidr 80000002
CPU3: thread -1, cpu 3, socket 0, mpidr 80000003
smp: Brought up 1 node, 4 CPUs
SMP: Total of 4 processors activated (24.00 BogoMIPS).
CPU: All CPU(s) started in SVC mode.
devtmpfs: initialized
VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
futex hash table entries: 1024 (order: 4, 65536 bytes)
xor: measuring software checksum speed
   arm4regs  :  1221.200 MB/sec
   8regs     :   951.200 MB/sec
   32regs    :   987.200 MB/sec
   neon      :   894.400 MB/sec
xor: using function: arm4regs (1221.200 MB/sec)
pinctrl core: initialized pinctrl subsystem
NET: Registered protocol family 16
DMA: preallocated 2048 KiB pool for atomic coherent allocations
cpuidle: using governor ladder
cpuidle: using governor menu
CPU identified as i.MX6Q, silicon rev 1.2
vdd1p1: supplied by regulator-dummy
vdd3p0: supplied by regulator-dummy
vdd2p5: supplied by regulator-dummy
vddarm: supplied by regulator-dummy
vddpu: supplied by regulator-dummy
vddsoc: supplied by regulator-dummy
hw-breakpoint: found 5 (+1 reserved) breakpoint and 1 watchpoint registers.
hw-breakpoint: maximum watchpoint size is 4 bytes.
imx6q-pinctrl 20e0000.iomuxc: no fsl,pins and pins property in node /soc/aips-bus@02000000/iomuxc@020e0000/imx6q-udoo/pwm4grp
imx6q-pinctrl 20e0000.iomuxc: no fsl,pins and pins property in node /soc/aips-bus@02000000/iomuxc@020e0000/imx6q-udoo/pwm3grp
imx6q-pinctrl 20e0000.iomuxc: initialized IMX pinctrl driver
raid6: int32x1  gen()   106 MB/s
raid6: int32x1  xor()   151 MB/s
raid6: int32x2  gen()   165 MB/s
raid6: int32x2  xor()   171 MB/s
raid6: int32x4  gen()   181 MB/s
raid6: int32x4  xor()   166 MB/s
raid6: int32x8  gen()   205 MB/s
raid6: int32x8  xor()   152 MB/s
raid6: neonx1   gen()   616 MB/s
raid6: neonx1   xor()   572 MB/s
raid6: neonx2   gen()   658 MB/s
raid6: neonx2   xor()   666 MB/s
raid6: neonx4   gen()   678 MB/s
raid6: neonx4   xor()   700 MB/s
raid6: neonx8   gen()   560 MB/s
raid6: neonx8   xor()   532 MB/s
raid6: using algorithm neonx4 gen() 678 MB/s
raid6: .... xor() 700 MB/s, rmw enabled
raid6: using neon recovery algorithm
mxs-dma 110000.dma-apbh: initialized
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
usb_phy_generic 2000000.aips-bus:usbphy_nop1: 2000000.aips-bus:usbphy_nop1 supply vcc not found, using dummy regulator
usb_phy_generic 2000000.aips-bus:usbphy_nop2: 2000000.aips-bus:usbphy_nop2 supply vcc not found, using dummy regulator
i2c i2c-0: IMX I2C adapter registered
i2c i2c-0: can't use DMA, using PIO instead.
i2c i2c-1: IMX I2C adapter registered
i2c i2c-1: can't use DMA, using PIO instead.
i2c i2c-2: IMX I2C adapter registered
i2c i2c-2: can't use DMA, using PIO instead.
media: Linux media interface: v0.10
Linux video capture interface: v2.00
pps_core: LinuxPPS API ver. 1 registered
pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
PTP clock support registered
Advanced Linux Sound Architecture Driver Initialized.
clocksource: Switched to clocksource mxc_timer1
VFS: Disk quotas dquot_6.6.0
VFS: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
FS-Cache: Loaded
CacheFiles: Loaded
NET: Registered protocol family 2
TCP established hash table entries: 8192 (order: 3, 32768 bytes)
TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 8192 bind 8192)
UDP hash table entries: 512 (order: 2, 16384 bytes)
UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
hw perfevents: no interrupt-affinity property for /soc/pmu, guessing.
hw perfevents: enabled with armv7_cortex_a9 PMU driver, 7 counters available
Initialise system trusted keyrings
workingset: timestamp_bits=14 max_order=18 bucket_order=4
zbud: loaded
FS-Cache: Netfs 'nfs' registered for caching
NFS: Registering the id_resolver key type
Key type id_resolver registered
Key type id_legacy registered
nfs4filelayout_init: NFSv4 File Layout Driver Registering...
fuse init (API version 7.26)
Key type asymmetric registered
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 247)
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
io scheduler mq-deadline registered
io scheduler kyber registered
imx-weim 21b8000.weim: Driver registered.
imx-sdma 20ec000.sdma: Direct firmware load for imx/sdma/sdma-imx6q.bin failed with error -2
imx-sdma 20ec000.sdma: external firmware not found, using ROM firmware
21e8000.serial: ttymxc1 at MMIO 0x21e8000 (irq = 70, base_baud = 5000000) is a IMX
console [ttymxc1] enabled
21f0000.serial: ttymxc3 at MMIO 0x21f0000 (irq = 71, base_baud = 5000000) is a IMX
brd: module loaded
loop: module loaded
ahci-imx 2200000.sata: fsl,transmit-level-mV not specified, using 00000024
ahci-imx 2200000.sata: fsl,transmit-boost-mdB not specified, using 00000480
ahci-imx 2200000.sata: fsl,transmit-atten-16ths not specified, using 00002000
ahci-imx 2200000.sata: fsl,receive-eq-mdB not specified, using 05000000
ahci-imx 2200000.sata: SSS flag set, parallel bus scan disabled
ahci-imx 2200000.sata: AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl platform mode
ahci-imx 2200000.sata: flags: ncq sntf stag pm led clo only pmp pio slum part ccc apst
scsi host0: ahci-imx
ata1: SATA max UDMA/133 mmio [mem 0x02200000-0x02203fff] port 0x100 irq 81
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
libphy: Fixed MDIO Bus: probed
tun: Universal TUN/TAP device driver, 1.6
fec 2188000.ethernet: 2188000.ethernet supply phy not found, using dummy regulator
pps pps0: new PPS source ptp0
libphy: fec_enet_mii_bus: probed
fec 2188000.ethernet eth0: registered PHC device 0
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci-mxc: Freescale On-Chip EHCI Host driver
usbcore: registered new interface driver usb-storage

Has anybody an idea?

I tried also booting 4.4 kernel. Same result....

Is this an u-boot issue?




kind regards



Share this post

Link to post
Share on other sites

Ok. Solved


I needed to go back to 4.4 kernel (next).

And i forgot to install linux-stretch-root-next-udoo.


4.14 kernel is not working for me.


Share this post

Link to post
Share on other sites
This topic is now closed to further replies.
1 1