1 1
Elektrický

Orange Pi Zero Plus how to downgrade kernel?

Recommended Posts

I originally installed Armbian_5.38_Orangepizeroplus_Ubuntu_xenial_next_4.14.14
I got NTP with PPS up and running on UART2 with PPS on PA3
I have a working backup image of this.
I then used armbian-config to boot from USB disk and I installed a LAMP stack and battled to get a DB up and running.

My mistake was upgrading the kernel before making a backup.

My version is now ARMBIAN 5.38 stable Ubuntu 16.04.4 LTS 4.14.48-sunxi64
NTP and PPS no longer work.

Is there a way to downgrade the kernel without having to go back to the backup and battle with the DB config again?

I'm a Linux newb so please make allowances for my ignorance.  I have searched for several hours without success before posting.

Share this post


Link to post
Share on other sites

Having not received a reply to this question, I tried a few things and borked my setup.   I had to go back to my backup on next_4.14.14.  My GPS PPS and NTP Server worked again.

I then plugged in my powered 1TB disk drive and all looked good, until I mounted a partition and began to use it.

The GPS died.  The PPS lock blink went off and obviously NTP stopped receiving PPS and NMEA.  When I stopped using the drive (it was still mounted) the PPS lock blink on the GPS came back and NTP received again.

Very strange.  Is it some kind of USB / UART interference?  Maybe RF interference with the GPS module?  Something related to processor load?

 

Any insight is welcome.

UBLOX 7020 neo-7m-c gnss chip UART TTL level GPS module on UART2 with PPS on PA3

 

Share this post


Link to post
Share on other sites

You can install specific version this way:

apt install linux-image-next-sunxi64=5.38

But first, check which are available:

apt-cache policy linux-image-next-sunxi64

Why we have a regression here ... hard to say. I assume you have enabled UARTS in armbianEnv.txt ... in case you made changes to DTB, it is overwritten on upgrade.

Share this post


Link to post
Share on other sites

Thanks Igor,  I have made a note for future reference.

I now suspect that it might not be the higher version causing the problem, but only that the problem is worse and happens all the time on the higher kernel version. 

 

I can make the problem occur on the lower kernel version by copying a very large file on the drive.  If I do the same thing with a usb stick instead of the powered drive, I don't have the problem.  Do you know if there has been a change that could increase power consumption between the two versions?

My thoughts are that there might be a power issue with the drive, even though the drive has it's own power supply and the board is powered by a 3A unit directly connected to the pins.   Next step is to attach a volt-meter to see if I can see a voltage drop or fluctuation.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1