2 2
javalatte

OrangePi zero not working with 1-wire

Recommended Posts

4 minutes ago, mantouboji said:

I use the same hardware configuration for a long time , running very well under kernel 3.x 

still have the same problem?

Share this post


Link to post
Share on other sites
3 minutes ago, FRANK333 said:

still have the same problem?

 Yeah, It can't works at all.

 

[    0.000000]   Normal zone: 1152 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 131072 pages, LIFO batch:31
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 129920
[    2.876113] [TTM] Zone  kernel: Available graphics memory: 252532 kiB
[    6.055402] random: fast init done
[    6.761472] systemd[1]: Set hostname to <opione2>.
[    8.603638] gpio-20 (onewire@0): enforced open drain please flag it properly in DT/ACPI DSDT/board file
[    8.825062] thermal thermal_zone0: failed to read out thermal zone (-110)
[   10.501758] random: crng init done
[   57.867241] w1_master_driver w1_bus_master1: Attaching one wire slave 00.800000000000 crc 8c
[  116.503399] w1_master_driver w1_bus_master1: Attaching one wire slave 00.400000000000 crc 46
[  163.347210] w1_master_driver w1_bus_master1: Attaching one wire slave 00.c00000000000 crc ca

 

Share this post


Link to post
Share on other sites
22 minutes ago, mantouboji said:

I use the same hardware configuration for a long time , running very well under kernel 3.x 

I also had problems working, I reloaded armbian with the new kernel, connected sensor and resistance (checking that the circuit is correct) and works continuously for months.
Read my previous posts and connect everything as I did I must work! (from what you posted seems just the sensor that is mounted badly)

I'm sorry if I insist.:)

 

Share this post


Link to post
Share on other sites
11 minutes ago, mantouboji said:

Yeah, It can't works at all.

In /boot/armbianEnv.txt, along with adding w1-gpio to overlays, did you provided W1 parameters, param_w1_pin and param_w1_pin_int_pullup ?

Are you sure you have the proper pin ?

Share this post


Link to post
Share on other sites

I'm about to start tinkering with a DS18B20 clone on an Orange Pi Zero running Armbian buster with Linux 5.4.31-sunxi.

I will re-read the whole thread to avoid any obvious mistake.

Share this post


Link to post
Share on other sites

gounthar,

activate 1wire, edit armbianEnv.txt, connect the sensor (with pull-up resistor) to the pi pins correctly, and it will work everything

Share this post


Link to post
Share on other sites

@gounthar

 

how i did it with my OPZero:

 

Enable w1-gpio

 

add

param_w1_pin=PA10

to armbianEnv.txt

and connect your DS18B20 like these..

+------------------------------------------------+
| OPi Zero GPIO Pin      |  18B20  | Widerstand  |
|------------------------|---------|-------------|
|Pin 17 3.3V   | braun   |   VCC   |-|4,7kOhm|-¬ |
|Pin 26 1-wire | blau 	 |   Data  |------------ |
|Pin 9  GND    | schwarz |   GND   |			 |
+------------------------------------------------+
 

Its working fine :-)

 

 

63.52.png

Share this post


Link to post
Share on other sites
[   11.862342] Driver for 1-wire Dallas network protocol.
[   11.881792] gpio-10 (onewire@0): enforced open drain please flag it properly in DT/ACPI DSDT/board file
[   11.914947] w1_master_driver w1_bus_master1: Attaching one wire slave 28.3c01a8160ce7 crc a8

It looks like it has been detected. I now have to find where the information is stored.
I may have found it:

cat /sys/devices/w1_bus_master1/28-3c01a8160ce7/hwmon/hwmon0/temp1_input
23437

Thanks a lot!

Share this post


Link to post
Share on other sites

@gounthar

 

i do this:

 

root@zero-bk:~# cd /sys/bus/w1/devices
root@zero-bk:/sys/bus/w1/devices# ls -l
insgesamt 0
lrwxrwxrwx 1 root root 0 Apr 21 14:09 28-02161f5ca2ee -> ../../../devices/w1_bus_master1/28-02161f5ca2ee
lrwxrwxrwx 1 root root 0 Apr 21 18:45 w1_bus_master1 -> ../../../devices/w1_bus_master1
root@zero-bk:/sys/bus/w1/devices# cat /sys/devices/w1_bus_master1/28-02161f5ca2ee/w1_slave
51 01 4b 46 7f ff 0c 10 ab : crc=ab YES
51 01 4b 46 7f ff 0c 10 ab t=21062

 

Share this post


Link to post
Share on other sites

Thanks. I don't know yet what this output means, but I'll find out.
Anyway, I tried to install RPi-Monitor, but it looks like something failed along the path:

sudo armbianmonitor -r
Installing RPi-Monitor. This can take up to 5 minutes. Be patient pleaseE: Unable to locate package rpimonitor
/usr/bin/armbianmonitor: line 697: /usr/share/rpimonitor/scripts/updatePackagesStatus.pl: No such file or directory

Now patching RPi-Monitor to deal correctly with H3

Now you're able to enjoy RPi-Monitor at http://192.168.0.21:8888
poddingue@orangepizero-ups:/sys/bus/w1/devices$ wget http://192.168.0.21:8888
--2020-04-21 21:55:21--  http://192.168.0.21:8888/
Connecting to 192.168.0.21:8888... failed: Connection refused.

 

Share this post


Link to post
Share on other sites

gounthar ,

If you intend to use rpi-monitor to control the temperatures of the sensors I recommend you to leave it alone, I use domoticz works well and it's simple, if you need more info open a new post.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
2 2