Larmbian (LXDE Armbian)


Recommended Posts

[Thanks Igor et al. for all the hard work]

 

For those who prefer LXDE, here are the steps to transform the Jessie server to LXDE desktop:

## Update distro
sudo apt-get update
sudo apt-get dist-upgrade -y

## Install LXDE Desktop
sudo apt-get install -y xorg lxde lightdm policykit-1
sudo sed -i.bak -e 's/^NotShowIn=GNOME;KDE;$/NotShowIn=LXDE;GNOME;KDE;/' /etc/xdg/autostart/lxpolkit.desktop

## Add Armbian wallpaper
umask 022
sudo mkdir -p /usr/local/wallpapers
(cd /usr/local/wallpapers; sudo wget https://raw.githubusercontent.com/igorpecovnik/lib/master/bin/armbian01.jpg)
sudo sed -i.bak -e 's/^wallpaper=.*$/wallpaper=\/usr\/local\/wallpapers\/armbian01.jpg/' /etc/xdg/pcmanfm/LXDE/pcmanfm.conf
sudo sed -i.bak -e 's/^background=.*$/background=\/usr\/local\/wallpapers\/armbian01.jpg/' /etc/lightdm/lightdm-gtk-greeter.conf

In addition, I usually add

## Lock down SSH (no root login && ssh key-only login)
sudo sed -i.bak -e 's/PermitRootLogin yes/PermitRootLogin no/' -e 's/#PasswordAuthentication yes/PasswordAuthentication no/' /etc/ssh/sshd_config
sudo systemctl restart sshd

## Install Git
sudo apt-get install -y git

## Install Armbian monitor
sudo armbianmonitor -r

BTW, I am fully expecting people to point out that directly sed'ing pkg files is wrong and I really should be doing it another way. :-)

Link to post
Share on other sites
Donate and support the project!

[Thanks Igor et al. for all the hard work]

 

For those who prefer LXDE, here are the steps to transform the Jessie server to LXDE desktop:

## Update distro
sudo apt-get update
sudo apt-get dist-upgrade -y

## Install LXDE Desktop
sudo apt-get install -y xorg lxde lightdm policykit-1
sudo sed -i.bak -e 's/^NotShowIn=GNOME;KDE;$/NotShowIn=LXDE;GNOME;KDE;/' /etc/xdg/autostart/lxpolkit.desktop

## Add Armbian wallpaper
umask 022
sudo mkdir -p /usr/local/wallpapers
(cd /usr/local/wallpapers; sudo wget https://raw.githubusercontent.com/igorpecovnik/lib/master/bin/armbian01.jpg)
sudo sed -i.bak -e 's/^wallpaper=.*$/wallpaper=\/usr\/local\/wallpapers\/armbian01.jpg/' /etc/xdg/pcmanfm/LXDE/pcmanfm.conf
sudo sed -i.bak -e 's/^background=.*$/background=\/usr\/local\/wallpapers\/armbian01.jpg/' /etc/lightdm/lightdm-gtk-greeter.conf

In addition, I usually add

## Lock down SSH (no root login && ssh key-only login)
sudo sed -i.bak -e 's/PermitRootLogin yes/PermitRootLogin no/' -e 's/#PasswordAuthentication yes/PasswordAuthentication no/' /etc/ssh/sshd_config
sudo systemctl restart sshd

## Install Git
sudo apt-get install -y git

## Install Armbian monitor
sudo armbianmonitor -r

BTW, I am fully expecting people to point out that directly sed'ing pkg files is wrong and I really should be doing it another way. :-)

 

Is possible to switch to a completely localized version (Spanish I mean in my case) of the LXDE Desktop?

Thanks.

Link to post
Share on other sites

Is possible to switch to a completely localized version (Spanish I mean in my case) of the LXDE Desktop?

Thanks.

 Yes : perform the following and you will get everything you need - works from the "server build" and or the "desktop build"

 

copy and paste the below line as root - this will give you a full LXDE deskop

 

apt-get update ; apt-get upgrade; apt-get install keyboard-configuration locales tzdata console-data task-lxde-desktop --install-recommends -f -y

 

then do the following to set system locales and keyboard settings specific to your region.

 

dpkg-reconfigure locales

dpkg-reconfigure tzdata

dpkg-reconfigure console-data

dpkg-reconfigure keyboard-configuration

Link to post
Share on other sites

Ubuntu-Xenial desktop 5.25

I followed your instructions, but got an error on the second line "file not found".

On logout and login, I am offered an LXDE option, but double-clicking it still brings me to an XFCE desktop.

Could you please explain what the commands are doing?

 

How can anyone tell what they are doing if the active title bar is the same colour as inactive title bars?

Link to post
Share on other sites
Guest
This topic is now closed to further replies.