Jump to content
  • 0

hdmi_force_hotplug=1 - to work against a blank screen


malaga
 Share

Question

 

 

hello dear all

 

on banana pi - i have connected all the wires

but:  no signal on screen

what  can i do now - plz advice

 

update:  found an very very interesting thread:

 

see https://www.raspberrypi.org/forums/viewtopic.php?t=34061 presume, you have installed your selected OS on SD card. Boot sector of the SD card is normally accessible from Windows, so you can edit file config.txt. What you maybe need? Add into config.txt this line:

Code: Select all

hdmi_force_hotplug=1

 

well - this can be a good hint..

 

what do you say - btw. How to edit this line!?

 

btw found some additonal texts:

 

https://raspberrypi.stackexchange.com/questions/2169/how-do-i-force-the-raspberry-pi-to-turn-on-hdmi

 

Add these two lines to /boot/config.txt and reboot Raspbmc:


 

hdmi_force_hotplug=1
hdmi_drive=2

 

hdmi_force_hotplug=1 sets the Raspbmc to use HDMI mode even if no HDMI monitor is detected. hdmi_drive=2 sets the Raspbmc to normal HDMI mode
(Sound will be sent if supported and enabled). Without this line, the Raspbmc would switch to DVI (with no audio) mode by default.

config.txt is read by the GPU so it will work on every distro.

There's two ways to do it. In older Pi installs, use the fb0 framebuffer when you want to display stuff on the HDMI/TV display, for example: FRAMEBUFFER=/dev/fb0 startx will use the HDMI/TV framebuffer for X windows instead of the PiTFT

On Jessie Pi installs, run sudo nano /usr/share/X11/xorg.conf.d/99-fbdev.conf to edit the configuration file and make sure it contains: Copy Code

 

Section "Device"
  Identifier "display"
  Driver "fbdev"
  Option "fbdev" "/dev/fb0"
EndSection

 

change the Option "fbdev" "/dev/fb0" line to Option "fbdev" "/dev/fb1" if you want the xdisplay on the PiTFT or fb1 to fb0 for HDMI output.
Update: If don't see the code above in the file, then simply copy and paste what is shown in this answer at the bottom of that file.
If you can't find 99-fbdev.conf file in that folder, then there is probably another file with different name like 10-evdev.conf in
the same folder which you will have to modify to make it work as described above.

 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
2 hours ago, malaga said:

what  can i do now - plz advice


No screen, means:
https://forum.armbian.com/topic/4591-mmc-no-card-present-error-on-allwinner-boards/

or something from here:
https://forum.armbian.com/forum/31-sd-card-and-power-supply/

 

Diagnostic tool costs <2 EUR http://amzn.to/2wbNkLp

 

2 hours ago, malaga said:

found an very very interesting thread:


You can skip this rubbish.

 

Link to comment
Share on other sites

Help Armbian team helping you!

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...