Jump to content
  • 0

Ramblings and progress with the RK3399


pbies
 Share

Question

Hello All,

 

I recently bought Orange Pi RK3399 and had some problems with it. At this moment I've solved most of them, but still no luck with such an old OS like Ubuntu Server 16.04 or Debian 9 which were provided by the manufacturer (images to flash).

 

What I am thinking now is to move this board to Armbian. Will it work?

 

How should I in this case organize the partitions on eMMC and where to load kernel and rootfs?

 

I don't see this board in supported ones.

Link to comment
Share on other sites

Recommended Posts

Help Armbian team helping you!

  • 0

So I tried this image found on this thread (Single Armbian image for RK + AML + AW), and it goes farther:

Spoiler

   21.071024] rockchip-dmc dmc: Cannot get the regulator "center"
[   21.075233] asoc-simple-card hdmi-sound: i2s-hifi <-> ff8a0000.i2s mapping ok
[   21.082156] dwmmc_rockchip fe310000.dwmmc: IDMAC supports 32-bit address mode.
[   21.085584] dwmmc_rockchip fe310000.dwmmc: Using internal DMA controller.
[   21.088899] dwmmc_rockchip fe310000.dwmmc: Version ID is 270a
[   21.092092] dwmmc_rockchip fe310000.dwmmc: DW MMC controller at irq 25,32 bit host data width,256 deep fifo
[   21.095717] dwmmc_rockchip fe310000.dwmmc: No vmmc regulator found
[   21.098905] dwmmc_rockchip fe310000.dwmmc: No vqmmc regulator found
[   21.103073] dwmmc_rockchip fe320000.dwmmc: IDMAC supports 32-bit address mode.
[   21.106413] dwmmc_rockchip fe320000.dwmmc: Using internal DMA controller.
[   21.109609] dwmmc_rockchip fe320000.dwmmc: Version ID is 270a
[   21.112675] dwmmc_rockchip fe320000.dwmmc: DW MMC controller at irq 26,32 bit host data width,256 deep fifo
[   21.116734] rockchip-dmc dmc: Cannot get the regulator "center"
[   21.120188] console [netcon0] enabled
[   21.123168] netconsole: network logging started
[   21.126934] input: gpio-keys as /devices/platform/gpio-keys/input/input1

 

And later today, I always have the infamous "mmc_init: -5, time 4" error when I try the run mmc_boot.
Go figure. I'm fed up with this card, nothing is stable. When it looks broken (EL3 errors, or kernel panic, or whatever) I can boot on the SDCard, but there isn't any image that boots until the end. When it gets back to life for whatever reason, I can't boot on the SDCard anymore.
I would just like to install Armbian, or push another version of the existing kernel so that I can at last use the camera.:wacko:

Link to comment
Share on other sites

  • 0

I rebuilt the image today, and I am still stuck at Starting kernel ...

Spoiler

Hit any key to stop autoboot:  0
=> setenv devnum 1
=> run mmc_boot
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1...
Found U-Boot script /boot/boot.scr
2940 bytes read in 43 ms (66.4 KiB/s)
## Executing script at 00500000
Boot script loaded from mmc 1
139 bytes read in 35 ms (2.9 KiB/s)
7106982 bytes read in 515 ms (13.2 MiB/s)
20654592 bytes read in 1378 ms (14.3 MiB/s)
73823 bytes read in 110 ms (655.3 KiB/s)
2698 bytes read in 63 ms (41 KiB/s)
Applying kernel provided DT fixup script (rockchip-fixup.scr)
## Executing script at 39000000
## Loading init Ramdisk from Legacy Image at 04000000 ...
   Image Name:   uInitrd
   Image Type:   AArch64 Linux RAMDisk Image (gzip compressed)
   Data Size:    7106918 Bytes = 6.8 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000
   Loading Ramdisk to 7d839000, end 7df00166 ... OK
   reserving fdt memory region: addr=1f00000 size=78000
   Loading Device Tree to 000000007d7be000, end 000000007d838fff ... OK

Starting kernel ...

 

I guess my board may be faulty.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...