1 1
rfog

SD Card not booting with Armbian

Recommended Posts

I'm trying to boot a Banana Pi M2U that I know is not supported, but I cannot make it even start booting with a SD Card. 

 

Let me explain. 

 

If I use the MFR Debian, image I flash the card and can boot. Another thing is the botched job the image is, that even no init is well done and at the end, the official Debian build ends failing and locking the board or entering in an eternal reboot with some kernel panics in between.

 

Then I tried Armbian. I downloaded an unsupported image for my board flash it (with balenaEtcher, as recommended) but the board does not boot. A normal boot means a red led, blue and green on. In this case only red one.

 

What I think is happening is I'm generating a wrong image, but I follow the steps in the documentation, that is un-zip2 the file, run Balena, flash the card and ready to go. As said, with original Banana Pi Debian image and same SD Card, (SanDisk Ultra 32GB) it boots. I've even installed a virtual Ubuunty and generated an image from sources, as described in documentation. Same problem with the generated image.

 

Once the card has been flashed, my iMAC says "unrecognized disk" for Armbian image, but original Banana image shows a mounted FAT partition called "boot_sd". That is why I think I'm mistaking something when flashing the Armbian image. 

 

I've tried a Centos image from an original PI and at least it starts booting. It does nothing but at least the blue and green led flashes for a time. But with a Armbian it is completely dead.

 

Any idea? 

 

Thanks.

Share this post


Link to post
Share on other sites

Hi rfog,

 

Armbian is until recently EXT4 filesystem only. Mac & Win cannot - cannot read that.

 

https://docs.armbian.com/User-Guide_Getting-Started/#how-to-prepare-a-sd-card  please read until "How to login", because the whole process takes some time and you learn what is important.

Once understood, above, did you download an image: https://dl.armbian.com/bananapim2ultra/ from here ?

 

Cheers

Tido

Share this post


Link to post
Share on other sites

Thanks for your help, but no luck.

 

I tried with all 4 images (nightly and dev). I have a 32 GB Sandisk Ultra and a 2GB KIngston. None of them boots the board. 

 

I think it is still a uboot problem. If I use a vendor image (Debian) it boots. Red led goes on, then start flashing blue and green, but with armbian images nothing happens. And any Centos for Raspberry PI at least flashes the blue and green leds.

 

Of course, I write the SD with BalenaEtcher tool. Now I'm doing in my Windows 10 instead of my iMac machine with same no luck...  This is very frustrating and at the end I will abandon the board.

 

Share this post


Link to post
Share on other sites
11 hours ago, martinayotte said:

Did you look at Serial Debug output with a USB-TTL Serial dongle ?

 

No because I don't have. But I'm in the way to get one. Will be here once I have it and see the result, but I suspect the uBoot of the board does not understand EXT4...

Share this post


Link to post
Share on other sites

It was booting!!!!!

 

I can login via serial port...

 

However it starts without screen support/led whatever. At this stage I don't mind because I want a headless system. Is fine this way. 

image.png

Share this post


Link to post
Share on other sites
13 minutes ago, martinayotte said:

Glad to see that you are now happy !

 

 

Thank you for the advice. I was giving up.

 

Now seems armbian needs installation and so.

 

A great community product.

Share this post


Link to post
Share on other sites
1 1