0
PlayingMuted

Mavell 88W8897 as Hotspot

Recommended Posts

Armbianmonitor:

Has anyone had success getting the Marvell 88W8897 setup as a hotspot?

 

It seems to work fine as a Supplicant, but I'm having challenges getting it to work as a hotspot. I've been trying to get the card to work as a hotspot via armbian-config without success.

 

Does anyone have any suggestions?

Share this post


Link to post
Share on other sites
33 minutes ago, PlayingMuted said:

I've been trying to get the card to work as a hotspot via armbian-config without success.


That method works if drivers for this chip are capable of running AP. Standard way.  No idea if this chip works at all.

Share this post


Link to post
Share on other sites
1 minute ago, Igor said:


That method works if drivers for this chip are capable of running AP. Standard way.  No idea if this chip works at all.

 

The Marvell 88W8897 works fine with OpenWrt as an access point. I'd use OpenWrt, but OpenWrt doesn't have support yet for the rtl8814au usb wifi cards.

 

I'm trying to set up a wireless repeater:

 

rtl8814au (edimax) as supplicant => 88W8897 (hostapd)

 

I'll try the other way around. I have had success switching the interfaces, but the rtl8814au seems to have some rate limiting as an access point.

Share this post


Link to post
Share on other sites
4 minutes ago, PlayingMuted said:

 

I'll try the other way around. I have had success switching the interfaces, but the rtl8814au seems to have some rate limiting as an access point.


Since you have 8814AU. Is that adaptor working within armbian-config? Can you set AP with it?

Share this post


Link to post
Share on other sites
2 hours ago, Igor said:


Since you have 8814AU. Is that adaptor working within armbian-config? Can you set AP with it?

 

Yes, I now have it setup this way .

 

88w8897 (supplicant) =>  8814AU (hostspot/ap)

Share this post


Link to post
Share on other sites

Hello PlayingMuted,

I had the same problem and found this thread.
Just wanted to let you know that i found a solution for that.

In my case i am using the app "create_ap" from:
https://github.com/oblique/create_ap
which is basically just a script setting up your hostapd,dnsmasq and interfaces.

With this command from the doc it was not working:
sudo create_ap wlp3s0 enp2s0 MyAccessPoint
I could open and start the AP but i couldn't really connect to it because no device ever got any IP from my AP.

The solution was to start in N mode instead of G mode, which is default in hostapd.
Following command worked for me:
sudo create_ap --ieee80211n wlp3s0 enp2s0 MyAccessPoint

 

But i think you can basically just change your hostapd.conf file and use this arguments:

hw_mode=g

ieee80211n=1

ht_capab=[SHORT-GI-40][HT40+][HT40-][DSSS_CCK-40]

[Copied from: https://unix.stackexchange.com/a/245402 ]

 

Regards,
Alex

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0