0
Grigory

OrangePI Prime continuiusly rebooting

Recommended Posts

Hello Folks,

Seems like it is very strange behaviour with last Armbian at the OrangePi Prime board.
It is continuiusly rebooting after power is on. Green led near the HDMI output is on, then after few seconds board is rebooting (led is off), and again.

Board:
    OrangePi Prime
SD Cards (the same results on both):

    SanDisk Extreme Pro microSDXC Class 10 UHS Class 3 V30 A1 64GB
    Kingston microSDHC Class 10 8GB
Compilation environment:
    VMware Workstation 14.1.3 with Ubuntu Bionic installed
    Linux ubuntu-bionic 4.15.0-44-generic #47-Ubuntu SMP Mon Jan 14 11:26:59 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    Distributor ID: Ubuntu
    Description:    Ubuntu 18.04.1 LTS
    Release:          18.04
    Codename:      bionic
    All steps are applied: https://docs.armbian.com/Developer-Guide_Build-Preparation/
For SD formatting tool is used:
    SD Card Formatter 5.0.1

For build image flashing tools are used (the same results on both):

    Win32 DiskImager 1.0
    balenaEtcher 1.4.9

Tested builds of the Armbian where problem is observed:

  1. Official server release for OrangePi Prime (yesterday was "Armbian_5.69_Orangepiprime_Debian_stretch_next_4.19.13.img"):
    https://www.armbian.com/orange-pi-prime/
    https://dl.armbian.com/orangepiprime/Debian_stretch_next.7z
  2. Manually compiled builds using compilation env described before (all builds are compiled with default build options):
    Armbian_5.73_Orangepiprime_Ubuntu_bionic_next_4.19.17.img
    Armbian_5.73_Orangepiprime_Ubuntu_xenial_next_4.19.17.img
    Armbian_5.74_Orangepiprime_Debian_stretch_next_4.19.17.img
    Armbian_5.74_Orangepiprime_Ubuntu_bionic_next_4.19.17.img
    Armbian_5.74_Orangepiprime_Ubuntu_xenial_next_4.19.17.img


This build was able to start successfully: "Armbian_5.72_Orangepiprime_Ubuntu_bionic_next_4.19.13.img"
But when I've started cpu load test it is freeze immedialetely.

Script on python that was used for cpu load testing:

# Produces load on all available CPU cores
from multiprocessing import Pool
from multiprocessing import cpu_count


def f(x):
    while True:
        x*x


if __name__ == '__main__':
    processes = cpu_count()
    print 'utilizing %d cores\n' % processes
    pool = Pool(processes)
    pool.map(f, range(processes))


Board is fully functional and working. Was tested with official "OranagePi Prime Ubuntu Desktop V2.1" build:
http://www.orangepi.org/downloadresources/orangepiprime/orangepiprime_90a173615c3d08cc1efb22.html
ubuntu_desktop_xfce_prime_V0_1.img
With this build board is successfully start and running cpu loading script without any problems.

Can you please lake a look into this problem?

Thanks,
Grigory.

Share this post


Link to post
Share on other sites
3 hours ago, Grigory said:

But when I've started cpu load test it is freeze immedialetely.

I've ran your cpuload.py script on mine without any issue, although top didn't reveal much stress !

My current kernel is 4.20.0 ...

Share this post


Link to post
Share on other sites

Another test with 4.19.y ended in:
kernel:[ 1403.832308] thermal thermal_zone0: critical temperature reached (90 C), shutting down

which is quite normal. Strange.

Share this post


Link to post
Share on other sites

Hello Folks,

Seems like problem was due to bad power supply...
But it is really strange because with official "OranagePi Prime Ubuntu Desktop V2.1" build anything is working fine... Maybe some slightly more gentle power settings?

Anyway, right now with 2.5 Amps power supply all previous tested builds are working fine.
Thanks a lot for your support!


Thanks,
Grigory.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0