lampra

Members
  • Content Count

    71
  • Joined

  • Last visited

About lampra

  • Rank
    Advanced Member

Recent Profile Visitors

634 profile views
  1. lampra

    Remote reboot with ssh unresponsive

    ok thank you. By the way, On a similar installation on cubietruck I see that kernel sysrq(-trigger) is not present. Do you know if this is the intended kernel build behaviour?
  2. lampra

    Remote reboot with ssh unresponsive

    No, i use telnet just to check that port 22 is open
  3. Hi, Updated to 5.70 next on Opi pc and after 2 days I cant login via ssh and i get: ssh_exchange_identification: Connection closed by remote host Some times ssh login just hangs. As I am not near the machine, is there any way to remotely reboot the Opi pc without ssh access? ps: I am sure that the machine is working as wireguard is working fine and I can ping the machine as well as telnet port 22!
  4. lampra

    Installation of Wireguard

    I don't know why, but I had similar issues with wireguard on cubietruck and on opi pc. It was mostly a matter of headers in my case. Even with armbian config I was not able to install the headers some times and on other occasions DKMS was not able to install wireguard. My workarounds are: 1. check manually apt (eg apt-cache search linux-headers-xxxx) for the correct header package (stable or next or whatever) for your board and kernel from armbian repo and manually install them. Then try to install wireguard with dkms. 2. If this does not work, install the headers, get the source of wireguard (check the wireguard webpage for manual installation) make & and make install and this should work even if you encounter erros during make. This is really trivial, just two commands as root!!
  5. Hi, I have a quectel ec 20 4g modem and I want to install it on espressobin. There seems to be some low cost solderless products like this or this. Is there any suggestion for SIM Card adapter?
  6. lampra

    EspressoBIN - static IP address

    I recently came across the same issue with systemd-resolved after upgrading an old laptop to bionic. I just disabled systemd-resolved and installed unbound. Maybe this is bionic specific (works fine on debian stretch for me).
  7. Well the module is compiled and installation finishes but when I am trying to use wireguard it fails and the output seems to point to wrong or missing kernel headers # wg-quick up wg0 [#] ip link add wg0 type wireguard RTNETLINK answers: Operation not supported Unable to access interface: Protocol not supported What i noticed is that after installation, a new folder is created in /lib/modules/ where wireguard.ko is placed $ ls /lib/modules/ 4.17.7 4.17.7-mvebu64 $ ls /lib/modules/4.17.7/extra/ wireguard.ko
  8. Compilation from source also not working:
  9. Am I missing something? I tried to install wireguard in the prebuild images but i failed using the linux-headers-next-mvebu64 package. Today I compiled a mainline image with headers installed but I still fail to install wireguard. Here is the log I have read in this that we need to call make scripts. Here is the output Edit: Diagnostics
  10. lampra

    EspressoBIN - static IP address

    Did you stop network-manager and checked the /etc/network/interfaces file contents? what is the output of these commands:
  11. lampra

    EspressoBIN - static IP address

    Well, rather than nano you can use vi witch works for me when connecting with minicom (ubuntu) from the usb.
  12. lampra

    EspressoBIN - static IP address

    networkctl is telling you that there is no br0 so this will not work. In the eth0 file is there something wrong? or this is because of copy & paste? lines 1-17/17 (END) lines 1-17/17 (END) * Make sure that the contents of the files and the files in /etc/systemd/network/ are exactly as in my previous post * Remove all the .txt files from /etc/systemd/network/ (You could also start from a fresh install and only change the contents of the 10-br0.network file) * Stop, disable and remove NetworkManager (systemctl stop NetworkManager && systemctl stop NetworkManager-wait-online && systemctl disable NetworkManager && systemctl disable NetworkManager-wait-online && apt remove --purge network-manager && apt autoremove) * use systemd-resolved for name resolution (systemctl enable systemd-resolved && ln -sf /run/systemd/resolve/resolv.conf /etc/resolv.conf) Ejoy!! Edit: make sure that the /etc/network/interfaces file contents are exactly these: auto lo iface lo inet loopback
  13. lampra

    EspressoBIN - static IP address

    By the way, for your tests you can have an 99-failover.network file with dhcp settings for the bridge in the /etc/systemd/network/ folder so if everything else fails, you will at least obtain an ip from the dhcp server (so no need to plug in the usb)
  14. lampra

    EspressoBIN - static IP address

    For me the following configuration works for either the lan ports or the wan port:
  15. lampra

    EspressoBIN - static IP address

    As i said, try to assign the static ip to the 10-br0.network file, not in the 10-wan.network file (something like this below):