0
jogger

Odroid HC1: can´t get up to speed after Buster update

Recommended Posts

Updated several HC1 to Buster. Reapplied the optimized board config, as done under stretch before.

 

Main issue: No matter what CPU governor I set, max. frequency jumps around automagically between 1.8 GHz and 2.0 GHz. I can set performance governor to the range from 1.9 to 2.0 GHz, armbian-config confirms, and when I back out of the menu it says "soc runs between 1800 and 1800 MHz using performance governor".  Even at > 90% CPU boards stay below 2.0 GHz.

 

Minor glitches only for boards, I already upgraded from jessie to stretch:

- boot.ini misses the hc1.dtb check - must manually edit

- systemd misses armbian* entries, as well as the utilities referenced in /usr/lib/

Share this post


Link to post
Share on other sites
4 hours ago, jogger said:

Updated several HC1 to Buster.


Please provide:

armbianmonitor -u

It can help diagnosing this issue.

Share this post


Link to post
Share on other sites

Getting nearer. Seems it is the current hc1.dtb that throttles down from about 60 degrees. Earlier releases or no dtb allowed 80, correct? Possible to configure?

Share this post


Link to post
Share on other sites

At least uninstall:

linux-stretch-root-next-odroidxu4

and install

linux-buster-root-next-odroidxu4

 

Jessie -> Stretch -> Buster ... booting the board is already a great success ;) We could waste a day/days (which is not possible to cover) and not fix all small issues that we were fixed in past few years and are not coming with update. You need to manually update u-boot, change boot script, adjust UUID in it, ... 

Rather start from a clean build and move your things there.

Share this post


Link to post
Share on other sites

Thanks for excellent support, the install made the systems nearly identical. Then I already had linux-u-boot-odroidxu4-next/buster,now 5.90 armhf installed, so everything looks fine. Autumn is coming, so it may take some time for the temp throttle to show up again, if it still exists.

Share this post


Link to post
Share on other sites
2 hours ago, jogger said:

With regard to CPU speed: problem is still there


With our official upgrade next mainline 4.19.y kernel is going back to stock 4.14.y. Which is the only option to fix this problem.

 

For CPU speed check/edit your /etc/default/cpufrequtil

Share this post


Link to post
Share on other sites

Finally solved this issue. The first thermal zone tripping point is at 70C with a hysteresis of 10. One would expect to kick a throttle in at 70C and lift the throttle at 60C. However throttling occurs at 60C. So I adapted a script found elsewhere and raised the first two tripping points.

echo 'setting cpu temperature limits ...'
i=0
while [ $i -lt 4 ]; do
	sudo bash -c "echo \"85000\">/sys/devices/virtual/thermal/thermal_zone""$i""/trip_point_0_temp"
	sudo bash -c "echo \"95000\">/sys/devices/virtual/thermal/thermal_zone""$i""/trip_point_1_temp"
	i=$[$i+1]
done

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0