Jump to content

Question: ssh/vnc from rockpi 4b to iPad over usbc

Recommended Posts

Hi there,


I have a RockPi 4b running Arabian with Ubuntu bionic. I mainly use the board to contact it online over ssh/vnc/rdp to work in spyder and texmaker. Quite often the connection is slow however. Therefore I am thinking of changing the system such that i can just bring it on the road and connect it using a local network with the usbc cable outlet of the iPad and a USB port on the rockpi. The reason i would like to connect over a cable is speed and not having to use the WiFi so that both devices can still easily connect to a WiFi network for internet access. I have found many solutions where iPads are connected to raspberry pi’s. These solutions all have various forms, could anyone here please suggest me what the ‘ best’ solution would be in terms of ease of configuration and stability?


What i’ ve found so far:

- avahi

- bonjour

- connection related to nmap


Are all these solutions even possible on a Arabian system ? And if the procedure is different, can anyone please help me het started ?


Furthermore, if anyone of you is willing to help me think out the steps to configure the system that would be awesome (like really awesome).


I’m only a Linux hobbyist so I’m still unable to find out the finesse between these programs.


Thank you very much in advance.



Link to comment
Share on other sites

When discussing a problem make sure to provide full logs!

I’ve tried the following link. this however didn’t work.

first of all the file /etc/modules is empty

whenever i reboot no usb0 interface will come online. 

Sudo ifconfig -a doesn’t show a usb0 interface

Sudo lshw -C network  only shows my wireless and ethernet connection.


sudo ifdown usb0 && sudo ifup usb0 yields:
ifdown: interface usb0 not configured
Unknown interface usb0




Link to comment
Share on other sites

This feature is not yet implemented and software board support is not matured yet. You can't just enable this feature and certainly not the way how its done with Raspberry Pi. This device is different. This means you or someone has to invest some time to get it working. Perhaps one hour, perhaps one week. We maintain build tools, which allows you to build latest image with changes you need: Do it https://docs.armbian.com/Developer-Guide_Build-Preparation/ and enable serial gadgets, test and report back. If things are working, send a PR with changes https://docs.armbian.com/Process_Contribute/ 


Radxa forums: "I’ve also posted my question on the armbian forum, that forum is however not as kind as this one"

You will not buy from us anymore? :P

Link to comment
Share on other sites

Hi there,


Thanx for the reply :)


In respond to my Radxa comment, I really love armbian, but on this forum i do sometimes get the feeling that i’m considered ‘dumb’ as a Linux hobbyist with no IT background. Hope you understand.

Link to comment
Share on other sites

1 minute ago, MEMEs said:

Hope you understand.

I do. Do you?

We invest a lot to make build tools on newbie level, while any other way is far more complicated and impossible to get along if you are not a developer. General IT/Linux hobby level knowledge does not help. Linux issues are specific and work of 1000+ people. One can support his own work, while for others its very difficult.


Sadly I don't have the luxury of time to write about problems from the very basics and explain wide aspects. Over and over again and be polite while wasting my own time in exchange for nothing.


Correct hints are what you have to work with. This is usually paid very well since it can easily save you hours/days/weeks and if you are unable to understand hints, you should find/hire someone who can. Since you are a hobbyist ... you must have time and wish to try on your own. I gave you hints where to start. I gave you something from "the best possible".


24 minutes ago, Igor said:

and enable serial gadgets

I made a mistake here. You need Ethernet functionality ... g_ether is the name of the gadget/google search keyword. But it looks like people already tried:
do some more googling, perhaps you will get better hit.

Link to comment
Share on other sites

Hey of course I understand! I saw your YouTube video lecture on armbian. I understand this is more of a High-Tier user forum. That's why I also post my question at raxda. I've never complained on this forum, I just experience the other one as 'more kind', that's all, it's my opinion of experience. It was maybe not the kindest thing to say, but hey im not cursing or anything.

I completely understand where you are coming from. I'm a teacher myself, I teach engineering at a uni (structural mainly, focused on offshore renewables and I also teach a bit of python programming (funny fact, I'm the python expert on my floor)), I have had my piece of 'dumb noob questions' :)


You asked for an explanation, you got one, that's all. No hard feelings whatsoever.


Now let's quit this 'feelings' nonsense and good luck on your crusade with armbian, I hope I can learn from you on the way, I already look forward being a more experienced linux person in a couple of years :)

Link to comment
Share on other sites

12 minutes ago, MEMEs said:

more kind

If you bought their hardware, you are their client. It would be unwise to treat you badly. They will surely handle this in more friendly manner even the outcome will be the same for you: "we will check, we will look into it ... " ... If you seek for a solution, like now, I did my best, but this problem can easily took up to three working days for an Linux expert (estimated) while you think "Linux expert" just enable something and it work. And sometimes this is actually true. I am also just learning things and there are way too many secrets/unknown things sorrowing Linux kernel that I will ever know.

25 minutes ago, MEMEs said:

I teach engineering at a uni

You are paid for the time with students? Do you work with 1.000's of them?

Link to comment
Share on other sites

1 hour ago, MEMEs said:

i've decided to buy a usbc to ethernet adapter

You don't need that since you already have an Ethernet port on the board. I assume you want to have a network connection over USB cable? That is possible with previously mentioned g_ether module.

Link to comment
Share on other sites

34 minutes ago, MEMEs said:

My ipad has an usbc port, if i plug in a female ethernet adapter i can connect that to a wifi cable from the rockpi thereby using eth0 rather than usb0

Ahaa. That should also work and be less troublesome to setup. 

Link to comment
Share on other sites

Okay I do apologize on forehand.

Ive tried the following:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get dist-upgrade

sudo reboot


sudo modprobe g_ether

modbprobe: FATAL: Module Gether not found in directory /lib/modules/4.4.192-rockchip65


Sudo cat /etc/modules is an empty file (it does exist)


sudo ifconfig usb0 up gives a no such device error


Sudo ifconfig -a doesnt have a usb0 output


Sudo lshw -C network only shows wireless and ethernet connection


cat /etc/os-release

version = 18.04.3 LTS Bionic Beaver


I think thats all i can do ?


Thanx for the help in advance, greatly appreciated!

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...