Jump to content
  • 0

USB3.0 connection problem



I have a serious problem as I mentioned in a title

Currently I'm using Armbian on my NanoPi M4 and very satisfied its functionality

But when I try to use usb3 device (especially camera from ZWO campany, ZWO ASI 178) with it,

it doesn't recognize it as USB3 device but USB2 by checking the data transfer speed with "lsusb -t"

Then, once I unplug the cable and plug it to the pi again, that device is recognized as USB3 and the data transfer speed becomes much higher.

I need to get USB3's fast data transfer as soon as the board gets booted, without unplugging cables since now it's not that easy to access to the board and cable.


I tried usb reset command like 

echo -n "1-2.1" > /sys/bus/usb/drivers/usb/unbind

but this doesn't change anything


I suppose somehow I can simulate this unplugging processing with some commands

and get USB3 connection.

Hope anyone knows about this issue 

Thank you




Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I have had usb3.0 problems with my NanoPC-T4,  close relative of your NanoPi-M4 but not really the same. 

When using my ZWO ASI294MC pro camera (USB3.0) the first image in any sequence is saved, but then the software goes into a cycle where the countdown continues for the next image, reaches zero  but the image is not saved, this continues over and over.  To reset, I need to shutdown the software and re-boot the NanoPC-T4. The camera works fine when plugged into one of the NanoPC-T4 usb2.0 ports, it just saves images at the usb2.0 speed. That isn't a big problem for me as I just do DSO imaging anyway. Still it would be nice to have it working as I need all three usb ports.

There are reports from NanoPi-M4 users on the indilib.org forum having the same problem as I have with the ASI294 camera and their usb3.0 ports.

A few weeks ago I burned the Armbian 5.98 image to an SD card, then upgraded the kernel to 5.3    from Armbian-Config and the usb3.0 problem with my camera was cured, however networking did not work so I am still using the 4.4.192 kernel for now. 

If you have an extra SD card you could give the 5.3 kernel a try.

Sorry I can't be more helpful



Link to comment
Share on other sites

Donate and support the project!

  • 0

Thank you for your prompt reply, I really appreciate it.

So I tried the same thing with Armbian 5.98 image and newest one(5.99) and checked the USB connections.

The camera was recognized as USB2 device, not USB3

I also tried sudo sh -c 'echo n > /sys/bus/usb/drivers/usb/unbind' operation but this didn't change anything

hope someone could give me additional advices to fix this problem


Thank you 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...