Jump to content

H2/H3: "old problem" Link (eth0) is Up/Down syndrom


Recommended Posts

14 minutes ago, Igor said:



Put few thousands on our account if you have such ideas or hire someone to get you that information. We have shared all we know - we always do that. To get a better information, to find a bug, additional time has to be lost. Perhaps a day is enough, perhaps a week wont. And we have other, much more important things to do. We would improve this service, but you don't care so ... 


@Igor - I have just put a few thousands on your account. Can I therefore kindly a request a withdrawal of the "you don't care" part of the above? Thank you.

Link to comment
Share on other sites

For those who end up here via search engines:


On a NanoPI M4V2 (RK3399) I activated the `tuned` profile "latency-performance" for my use case without the intention to address this issue. Thus, by coincidence, I recognized that the issue apparently disappeared (or got a lot less frequent, at least, since it hasn't appeared in the last 12 hours). I don't have the time/priority to track down which of the settings actually helped but it should be the governor or cstate settings.

Link to comment
Share on other sites

Thank you @lpirlfor your tip, unfortunately it did not work on my Orange Pi PC (H3 CPU), running Armbian 22.05.1 Bullseye with Linux 5.15.43-sunxi.

Here is what I tried (as root) :

apt install tuned tuned-utils tuned-utils-systemtap
tuned-adm profile latency-performance


It happens since I changed my ISP (and the router they provide). I tried all ethernet ports, but unfortunately nothing worked :(

@guidolwas right, I will try to put a switch between the router and the OPi to see if it gets better!

Link to comment
Share on other sites

Hi All.


I have nanopi-neo with exactly the same problem.

What I've found is that link may be established if i turn off autonegotiation on my PC and force 10Half mode.

However it is still not fully functional. I can seed Rx packets are growing as well as Tx packets. But there are no packets actually transmitted (checked with wireshark on PC).


I can experiment. Can anyone suggest what should I try to troubleshoot?

Link to comment
Share on other sites

On an orange pi one I notice the same regularly:


│Jan 21 15:50:25 a-m kernel: [ 1757.658898] dwmac-sun8i 1c30000.ethernet eth0: Link is Down                                                                                                         │
│Jan 21 15:50:27 a-m NetworkManager[1119]: <info>  [1674312627.1444] device (eth0): carrier: link connected


I can test with multiple samples.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines