OrangePi PC - TV Out


Recommended Posts

Hello;

 

My OrangePi PC HDMI port is dead, it throws no input signal, and I've read that this board has no ESD protection for HDMI, so I assume it died because of it. What I want to get is video working through analog TV out, but I can't seem to find the solution for this. I guess it should be simple task, but I never did it before.

 

Hopefuly somebody can give me the solution.

 

Thanks!

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Thank you for your help.

 

Unfortunatelly, I've made the changes and the video does not seem to work through analog. I checked the cable, and used a second one, and it does not work. I swapped red with yellow, as some people states in the forum you said and it isn't showing either. I don't know if the problem is related with the version of Armbian I'm using. since I have 5.04. The options I changed are:

 

[disp_init]

screen0_output_type = 2

screen0_output_type = 14 (for NTSC)

disp_mode = 0 (for 480i)

 

[hdmi_para]

hdmi_used = 0

hdcp_enable = 0

 

[tv_para]

tv_used = 1

tv_dac_used = 1

tv_dac_src0 = 0

 

Maybe I'm missing some other configuration?

 

Thanks!

Link to post
Share on other sites

I don't know if the problem is related with the version of Armbian I'm using. since I have 5.04.

 

In addition to jernej's suggestion I would strongly recommend to use a newer Armbian version (we're at 5.14 and currently preparing the 1st real H3 release: 5.15 -- maybe wait until then)

Link to post
Share on other sites

I updated to armbian 5.14, changed the settings as jernej says but still no image.

 

I don't understand the picture with the cable in the link. What does it mean 4 is red & yellow together?. My cables are 3 wires, and I plug them separetely to their colors. I try every connector with the yellow in the TV, but no image. It either is a problem about not being reading orangepipc.bin at boot (despite I have OrangePi PC board) or there are other options interfering in analog TV out.

 

To make sure the latter is not the problem I would ask the whole orangepipc.bin or fex to someone who made it working.

 

Thanks.

Link to post
Share on other sites

If you bought TV cable from Xunlong, I must disappoint you that you have wrong cable - ground and TV signal are inverted which means that you might get picture only if you try to gently pull out connector for few milimeteres, but definetly no sound, because instead of ground, you have TV signal there which completely scrambles the sound.

 

Image which I show you means that if you measure conductivity with a multimeter, all rings on RCA connector (don't know how to call it) should be connected to "4" on 3.5 mm jack. Xunlong cable has those rings connected to "3" on 3.5 mm jack. You should check that.

Link to post
Share on other sites

Mmm, so I should open the cable, and splice the ones which are marked as 4 (yellow and red) to the 4th ring of the minijack?, hilarious but if that's the only solution I will do. But I think I prefer to use old connectors with a broken minijack I have around the room, I will try to fix it the way you tell me.

 

Thank you!

Link to post
Share on other sites

Actually, white RCA connector has also wrong ground connection. It would be better to fix in on 3.5 mm side - somehow switch parts marked 3 and 4. If you have some soldering skills it would be easier just to buy 4 pole 3.5 mm connectors (male and female) and make an adapter cable... Or just buy a proper cable. It goes under name "Apple iBook AV cable" or some others mentioned here: http://anythingbutipod.com/2006/04/zen-vision-m-video-cable-other-4pole-35mm-pinouts/

Link to post
Share on other sites

I am using Armbian_5.14_Orangepipc_Debian_jessie_3.4.112_desktop and I am unable to get video output via the 3.5mm jack. The changes I made to script.fex are given below. The exact same changes worked with OpenELEC and I was able to get both video and audio with it. So its not a cable/tv issue. Can someone help me out?



[disp_init]
disp_mode = 1
screen1_output_type = 2
screen1_output_mode = 11

[tv_para]
tv_used = 1


Link to post
Share on other sites

Thanks. I added the following line to /etc/modules and got video output via the 3.5mm jack:

tv

I was trying to play video files and the default choice of vdpau output was giving a blank screen. There was no audio output either.

 

I had to use alsamixer and unmute 'Audio lineout' and feed the following options to mpv:

mpv --vo=x11 --audio-device='alsa/plughw:CARD=audiocodec,DEV=0' $FILE

No other video output was working. This of course means no hardware acceleration.

 

Am I missing something?

 

Another issue is with the overscan. Is there a way to compensate for this?

Link to post
Share on other sites
I was trying to play video files and the default choice of vdpau output was giving a blank screen. There was no audio output either.

 

AFAIK, libvdapu-sunxi don't currently have a capability to use second screen. If it is similar enough to Kodi in OpenELEC, code could be fixed quiet easily. I will take a look at code.

Link to post
Share on other sites
On 6/11/2016 at 6:03 AM, jernej said:

You changed disp_init section wrong. Test this:


[disp_init]
disp_mode = 1
screen1_output_type = 2
screen1_output_mode = 14

Note that TV works on screen1 only.

 

And another detailed picture how the cable must look like: http://www.orangepi.org/orangepibbsen/forum.php?mod=viewthread&tid=1349&page=3#pid12309Video signal in this case is labeled as "3"

Hey thanks. I saw this thread before and found it again. I was able to get signal to TV with that change.  I don't think 14 = ntsc. I noticed it said PAL. Now I have to find thee right code.  I know I saw that somewhere also. 

Link to post
Share on other sites
21 hours ago, jernej said:

 

TV out driver supports only PAL and NTSC - codes 11 and 14. I'm pretty sure that codes are correct. At least they are listed as such in fex files.

you are right. got it working. instead of plugging in the av cable, I just jumped it and woila!

Would you know how to enable the audio now?

Link to post
Share on other sites
5 hours ago, Armnlegs said:

Working NTSC but no audio yet.

You mean analog audio? From what I see, everything is set correctly. Maybe you have volume set too low or even muted?

 

5 hours ago, Armnlegs said:

Could we set the display size/resolution?

TV out driver supports only NTSC or PAL resolutions, maybe you can set TV to scale picture?

Link to post
Share on other sites

Audio is working now.  I had to follow another thread. Once I get everything working, I might rewrite a guide so others don't have to jump around like I did.

Now, the issue? lol 

 

Issue is now is that the game itself does not have sound. Not sure if it's configuration in the emulator or OPi.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.