Where has the Armbian splash screen gone?


Recommended Posts

It been a while since I have made custom images for the OrangePi PC Plus so things have changed a bit in the intervening period.

First I made the development environment change to Ubuntu Focal, then changes to a couple of patch files to bring them into line with the new u-boot and kernel versions however I have simply lost the ability to display an Armbian splash screen during boot.

In the past I had patched general-armbian-boot-logo-on-screen-center.patch and general-armbian-boot-logo-on-screen-center copy.patch to show the splash screen I required however now these patches are this patch is no longer even referenced during the build process.

Now, after the build, even with logo=enabled in armbianEnv.txt (this is also probably been superseded during the last year) I have no splash screen during kernel boot.

So just in case it was my build, I downloaded the latest Buster server build (Linux 5.4.20-sunxi) and edited armbvianEnv.txt to enable the logo. No joy, still no splash screen.

Is there something I've missed? Trawling through the forums has not found any information that I can find.

Has the splash screen been lost during the process of updating the kernel, or am I just being dense?

Link to post
Share on other sites

Donate and support the project!

13 minutes ago, jcheriton said:

Is there something I've missed?

 

"Disable DE2 in u-boot to improve EDID detection"

https://github.com/armbian/build/commit/5e8cbd8e6aaa87ee03d08c761d5e765e81c4c686#diff-380d179e59cc86f471a51c3aa7c21299

 

Waiting someone to implement plymouth

 

https://github.com/armbian/build/commit/b41834796294709644a4e503086bfbdd27b87785#diff-380d179e59cc86f471a51c3aa7c21299

Link to post
Share on other sites

Thanks Igor.

I already have u-boot working with a splash screen and no text. It's the kernel boot that is the problem.

I found the Plymouth forum topic and tried to implement it on my OrangPi PC Plus but it failed to boot once I had installed it, along with the themes, and had run init-ramfs.

Perhaps more investigation required to make Plymouth work. When I get some time I'll have a look at it.

 

 

Link to post
Share on other sites

@jcheriton

The patch Igor has mentioned is already included in the latest build as of today.

 

I was able to locate one of the patch files you have mentioned:

1. general-armbian-boot-logo-on-screen-center.patch  (https://github.com/FireflyTeam/armbian-build/blob/master/patch/kernel/odroidn2-default/general-armbian-boot-logo-on-screen-center.patch)

The other patch that has 'copy' in its name is not traceable general-armbian-boot-logo-on-screen-center copy.patch. 

Will it be possible for you to point me to this another file.

My device is orangepiplus2e so I hope this would work. I am unable to get the logo displayed with just '"Disable DE2 in u-boot to improve EDID detection""'

 

Any help is highly appreciated!

 

Thanks & Regards

-R

 

Link to post
Share on other sites

9 hours ago, jcheriton said:

Rajesh

 

Sorry that was my bad. The .copy file is simply that, a saved copy of the original general-armbian-boot-logo-on-screen-center.patch and should never have been mentioned above.

Please ignore any reference to it!

 

This patch fails on the latest 20.08 build. Looks like some of the newer patches supersedes this one. I think I am going to throw in the towel on the u-boot splash image. Tried everything I could.

 

If you want a bootspalsh as kernel loads, you may want to try https://www.tanzolab.it/CM3-Panel-boot-process

Nothing fancy.  Running fim as systemd service. The earlier it loads, the better the user experience.

 

Thank you for your response and help.

 

Regards

-Rajesh

 

Link to post
Share on other sites

The proper way to implement a bootsplash is to use the framework in the kernel as referenced here.

Quote

Bootsplash
==========

There is support in place now for writing internal DRM clients making it
possible to pick up the bootsplash work that was rejected because it was written
for fbdev.

- [v6,8/8] drm/client: Hack: Add bootsplash example
  https://patchwork.freedesktop.org/patch/306579/

- [RFC PATCH v2 00/13] Kernel based bootsplash
  https://lkml.org/lkml/2017/12/13/764

Contact: Sam Ravnborg

Level: Advanced

Max Staudt promised in one of his last posts to implement his work as soon as a framework will be available but he never showed up again.
The referenced example hack shows that the framework works, only someone needs to implement the bells and whistles.

Link to post
Share on other sites

I finally managed to get the plymouth working on Orange Pi Plus 2e.

 

1. Enabled the patch remove-boot-messages-from-hdmi.patch removed .disable. I get this warning during the build 'Cannot update. patch has changed. Options exit, ignore and continue. I chose ignore and continue)

2. Install plymouth as per instructions in 

 

 

I had to remove these two lines from armbianEnv.txt

 

console=custom

consoleargs="console=ttyS0,115200 console=tty7"

 

and replace with console=serial

 

The custom image I am building excluded Ethernet drivers and with these line above u-boot keeps on looking for ethernet device. Not sure if these two are related but removing these lines did help.

 

The plymouth theme comes into action when kernel loads however I still do not see boot logo. I am wondering if removing this patch 'xxx-disable-de2-to-improve-edid-detection.patch' would help. 

 

Thanks & Regards

Rajesh

 

Link to post
Share on other sites

Update:

I disabled patch xxx-disable-de2-to-improve-edid-detection.patch.disable so the boot logo now works.

 

But this breaks plymouth. It takes longer than usual to load the kernel and ends up booting in initramfs prompt. 

It appears the patch 'remove-boot-messages-from-hdmi.patch' does not go too well with plymouth.

 

-Rajesh

 

Link to post
Share on other sites

All issues resolved. 

I was copying a preset armbianEnv.txt (to save time to type in the details each time). Obviously the UUID of rootfs was different.

 

In Summary

To enable boot logo:

1. disable patch xxx-disable-de2-to-improve-edid-detection.patch

2. enable patch remove-boot-messages-from-hdmi.patch

 

Follow instructions in link below to install plymouth

 

-Rajesh

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0