Jump to content

WSL2 Build environment


 Share

Recommended Posts

I'm on Windows 10 using WSL2 (Ubuntu 20.04) to build (running with sudo).  I installed gpg & generated a public key (I chose DSA+RSA, 3072 Length, Never Expire), but get errors with verification:

Probably not a supported build environment but I figured I'd see if there was a simple fix rather than spinning up another VM... Came back here because I randomly looked and saw that UDOO was no longer obsolete :) (THANKS!)

 

CPU configuration:
392000 - 996000 with interactive
Displaying message: Preparing host info
Displaying message: Build host OS release focal info
Displaying message: Syncing clock host info
Displaying message: Checking for external GCC compilers  info
Displaying message: downloading using torrent network gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz
gpg: keybox '/mnt/e/_Code/armbian/build/cache/.gpg/pubring.kbx' created
gpg: /mnt/e/_Code/armbian/build/cache/.gpg/trustdb.gpg: trustdb created
gpg: error reading key: No public key
gpg: connecting dirmngr at '/mnt/e/_Code/armbian/build/cache/.gpg/S.dirmngr' failed: IPC connect call failed
gpg: keyserver receive failed: No dirmngr
gpg: error reading key: No public key
gpg: connecting dirmngr at '/mnt/e/_Code/armbian/build/cache/.gpg/S.dirmngr' failed: IPC connect call failed
gpg: keyserver receive failed: No dirmngr
gpg: assuming signed data in '/mnt/e/_Code/armbian/build/cache/toolchains/gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz'
gpg: Signature made Tue 19 Nov 2013 02:00:03 AM MST
gpg:                using RSA key D47877808F427EAF
gpg: Can't check signature: No public key
Displaying message: ERROR in function download_and_verify general.sh:1199 err
Displaying message: verification failed  err
Displaying message: Process terminated  info

 

output.log torrent.log

Link to comment
Share on other sites

Help Armbian team helping you!

So after googling a bit - apparently there are build issues using /mnt vs ~ folders with WSL2 (~ is case sensitive, /mnt follows windows case-insensitive)...  I was able to do a full compile out of ~ (not sure if you'd want to add WSL2 as a supported build environment)..  Took 134 min on a i7-3610 (I think that was about the same in a VM a few years ago).  Now to look at adding onewire again :unsure:

 

Only errors were on installing additional packages:

[ .... ] Installing additional packages [ EXTERNAL_NEW ]
Err:1 http://deb.debian.org/debian stable InRelease
  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
Err:2 http://ports.ubuntu.com focal InRelease
  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
Err:3 http://ports.ubuntu.com focal-security InRelease
  Unable to connect to localhost:3142:
Err:4 http://ports.ubuntu.com focal-updates InRelease
  Unable to connect to localhost:3142:
Err:5 http://ports.ubuntu.com focal-backports InRelease
  Unable to connect to localhost:3142:
Err:6 http://apt.armbian.com focal InRelease
  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
Err:7 http://deb.debian.org/debian stable-updates InRelease
  Unable to connect to localhost:3142:
Err:8 http://deb.debian.org/debian-security stable/updates InRelease
  Unable to connect to localhost:3142:
Reading package lists...
W: Failed to fetch http://ports.ubuntu.com/dists/focal/InRelease  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
W: Failed to fetch http://ports.ubuntu.com/dists/focal-security/InRelease  Unable to connect to localhost:3142:
W: Failed to fetch http://ports.ubuntu.com/dists/focal-updates/InRelease  Unable to connect to localhost:3142:
W: Failed to fetch http://ports.ubuntu.com/dists/focal-backports/InRelease  Unable to connect to localhost:3142:
W: Failed to fetch http://apt.armbian.com/dists/focal/InRelease  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
W: Failed to fetch http://deb.debian.org/debian/dists/stable/InRelease  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
W: Failed to fetch http://deb.debian.org/debian/dists/stable-updates/InRelease  Unable to connect to localhost:3142:
W: Failed to fetch http://deb.debian.org/debian-security/dists/stable/updates/InRelease  Unable to connect to localhost:3142:
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
mmc-utils is already the newest version (0+git20180327.b4fe0c8c-1).
sunxi-tools is already the newest version (1.4.2+git20181114.6d598a-3).
hostapd is already the newest version (3:2.9-102~armbian20.05.2+1).
htop is already the newest version (2.2.0-3~armbian19.11.9+1).
0 upgraded, 0 newly installed, 0 to remove and 31 not upgraded.
[ o.k. ] Calling image customization script [ customize-image.sh ]

 

Link to comment
Share on other sites

30 minutes ago, chiefwigms said:

 (not sure if you'd want to add WSL2 as a supported build environment)

Probably not. Too many uncertainties.

However if somebody takes on the challenge to make the build script ready for WSL and push a PR it might be accepted.

Link to comment
Share on other sites

On 6/15/2020 at 10:25 AM, chiefwigms said:

So after googling a bit - apparently there are build issues using /mnt vs ~ folders with WSL2 (~ is case sensitive, /mnt follows windows case-insensitive)...  I was able to do a full compile out of ~ (not sure if you'd want to add WSL2 as a supported build environment)..  Took 134 min on a i7-3610 (I think that was about the same in a VM a few years ago).  Now to look at adding onewire again :unsure:

 

Only errors were on installing additional packages:


[ .... ] Installing additional packages [ EXTERNAL_NEW ]
Err:1 http://deb.debian.org/debian stable InRelease
  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
Err:2 http://ports.ubuntu.com focal InRelease
  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
Err:3 http://ports.ubuntu.com focal-security InRelease
  Unable to connect to localhost:3142:
Err:4 http://ports.ubuntu.com focal-updates InRelease
  Unable to connect to localhost:3142:
Err:5 http://ports.ubuntu.com focal-backports InRelease
  Unable to connect to localhost:3142:
Err:6 http://apt.armbian.com focal InRelease
  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
Err:7 http://deb.debian.org/debian stable-updates InRelease
  Unable to connect to localhost:3142:
Err:8 http://deb.debian.org/debian-security stable/updates InRelease
  Unable to connect to localhost:3142:
Reading package lists...
W: Failed to fetch http://ports.ubuntu.com/dists/focal/InRelease  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
W: Failed to fetch http://ports.ubuntu.com/dists/focal-security/InRelease  Unable to connect to localhost:3142:
W: Failed to fetch http://ports.ubuntu.com/dists/focal-updates/InRelease  Unable to connect to localhost:3142:
W: Failed to fetch http://ports.ubuntu.com/dists/focal-backports/InRelease  Unable to connect to localhost:3142:
W: Failed to fetch http://apt.armbian.com/dists/focal/InRelease  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
W: Failed to fetch http://deb.debian.org/debian/dists/stable/InRelease  Could not connect to localhost:3142 (::1). - connect (111: Connection refused) Could not connect to localhost:3142 (127.0.0.1). - connect (111: Connection refused)
W: Failed to fetch http://deb.debian.org/debian/dists/stable-updates/InRelease  Unable to connect to localhost:3142:
W: Failed to fetch http://deb.debian.org/debian-security/dists/stable/updates/InRelease  Unable to connect to localhost:3142:
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
mmc-utils is already the newest version (0+git20180327.b4fe0c8c-1).
sunxi-tools is already the newest version (1.4.2+git20181114.6d598a-3).
hostapd is already the newest version (3:2.9-102~armbian20.05.2+1).
htop is already the newest version (2.2.0-3~armbian19.11.9+1).
0 upgraded, 0 newly installed, 0 to remove and 31 not upgraded.
[ o.k. ] Calling image customization script [ customize-image.sh ]

 

 

Would you by any change have set of instructions to do a build on Win 10 / WSL2? Microsoft has finally rolled out Wind 10 2004 with WSL2 enabled by default. I tried the build on Windows 10 after upgrade. The scripts exits with not supported build environment not supported. I also have docker running on Windows 10 but looks like WSL2 os more convenient and better option.

 

-R

Link to comment
Share on other sites

4 hours ago, Rajesh said:

Would you by any change have set of instructions to do a build on Win 10 / WSL2?

 

If you want support for WSL2, fork a project and develop support with your own resources.

Link to comment
Share on other sites

  • Igor locked and pinned this topic
  • Igor unpinned this topic
  • Igor unlocked this topic
  • Werner locked and unlocked this topic

Tested with Windows 10 version 1909 (Build 18363.1049) and Ubuntu 20.04 and default 4.9.109 kernel shipped directly from Microsoft.

Could run through my autobuild I usually do on remote machine flawless.

 

Needs NO_HOST_RELEASE_CHECK=yes

Link to comment
Share on other sites

 Share

×
×
  • Create New...