Jump to content
  • 0

Orange Pi PC: no sound over HDMI in terminal


ilyaigpetrov
 Share

Question

Armbianmonitor:

Device: Orange Pi PC.

Image: Armbian_20.08.1_Orangepipc_focal_current_5.8.5.img.

Issue:

No sound in the terminal when I run `sudo speaker-test` or `speaker-test` or if I launch kodi-gbm.

 

I have an old Armbian image with Linux 3.4.112-sun8i Ubuntu 16.04.7 Xenial, it has xfce desktop installed -- there if I set sndhdmi device as a fallback device then `speaker-test` plays fine.

I tried installing xfce and pulseaudio on this current Armbian Focal (not via arm-config, but via `apt install xorg xfce4 pulseaudio`) but in the audio settings there are only 2 devices both named "Built-in Audio Stereo" and setting any of them as a fallback doesn't produce sound over hdmi in the speaker-test.And I'm interested in sound in terminal and kodi-bgm, not xfce desktop.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Codec [H3 Audio Codec], device 0: CDC PCM Codec-0 [CDC PCM Codec-0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: sun8ih3hdmi [sun8i-h3-hdmi], device 0: 1c22800.i2s-i2s-hifi i2s-hifi-0 [1c22800.i2s-i2s-hifi i2s-hifi-0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

$ mpv --audio-device=help
List of detected audio devices:
  'auto' (Autoselect device)
  'pulse/alsa_output.platform-hdmi-sound.stereo-fallback' (Built-in Audio Stereo)
  'pulse/alsa_output.platform-1c22c00.codec.stereo-fallback' (Built-in Audio Stereo)
  'alsa' (Default (alsa))
  'alsa/samplerate' (Rate Converter Plugin Using Samplerate Library)
  'alsa/speexrate' (Rate Converter Plugin Using Speex Resampler)
  'alsa/jack' (JACK Audio Connection Kit)
  'alsa/oss' (Open Sound System)
  'alsa/upmix' (Plugin for channel upmix (4,6,8))
  'alsa/vdownmix' (Plugin for channel downmix (stereo) with a simple spacialization)
  'alsa/sysdefault:CARD=Codec' (H3 Audio Codec, CDC PCM Codec-0/Default Audio Device)
  'alsa/dmix:CARD=Codec,DEV=0' (H3 Audio Codec, CDC PCM Codec-0/Direct sample mixing device)
  'alsa/plughw:CARD=Codec,DEV=0' (H3 Audio Codec, CDC PCM Codec-0/Hardware device with all software conversions)
  'alsa/usbstream:CARD=Codec' (H3 Audio Codec/USB Stream Output)
  'alsa/sysdefault:CARD=sun8ih3hdmi' (sun8i-h3-hdmi, 1c22800.i2s-i2s-hifi i2s-hifi-0/Default Audio Device)
  'alsa/dmix:CARD=sun8ih3hdmi,DEV=0' (sun8i-h3-hdmi, 1c22800.i2s-i2s-hifi i2s-hifi-0/Direct sample mixing device)
  'alsa/plughw:CARD=sun8ih3hdmi,DEV=0' (sun8i-h3-hdmi, 1c22800.i2s-i2s-hifi i2s-hifi-0/Hardware device with all software conversions)
  'alsa/usbstream:CARD=sun8ih3hdmi' (sun8i-h3-hdmi/USB Stream Output)
  'jack' (Default (jack))
  'sdl' (Default (sdl))
  'sndio' (Default (sndio))

 

I tried different advice from different topics on this and other forums to no avail.

1) I tried adding my user to audio group (`sudo usermod -a -G audio <username>`).

2) I tried opening alsamixer and muting ("m" key) and unmuting line-in, line-out.

3) I tried adding and tweaking /etc/asound.conf.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

Donate and support the project!

  • 0

This produces no effect:

# cat << EOF > /etc/asound.conf
> defaults.pcm.card 1     
> defaults.ctl.card 1
> EOF                                   
# cat /etc/asound.conf 
defaults.pcm.card 1                                                             
defaults.ctl.card 1                                                             
# speaker-test

 

 

@xwiggen

# cat /etc/asound.conf 
pcm.!default {
        type hw
        card 1
}
ctl.!default {
        type hw
        card 1
}
# speaker-test 

speaker-test 1.2.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Channels count (1) not available for playbacks: Invalid argument
Setting of hwparams failed: Invalid argument

# Changing `card 1` to `card 0` produces no sound.
# Adding `device 0` or `device 1` doesn't help also.
# cat /etc/asound.conf 
pcm.!default {
        type hw
        card 0
        device 0
}
ctl.!default {
        type hw
        card 0
        device 0
}
# speaker-test
# No sound.

 

Link to comment
Share on other sites

  • 0
On 11/2/2020 at 4:04 AM, ning said:

the simple way:

install pulseaudio

 

mpv -ao pulse xxx.mp3

Thanks for you reply, @ning, but unfortunately it doesn't work:

ilyaigpetrov@orangepipc:~$ mpv --ao=pulse ./foobar.mp3 
 (+) Audio --aid=1 (mp3 2ch 48000Hz)
AO: [pulse] 48000Hz stereo 2ch float
A: 00:00:00 / 01:20:04 (0%)

No sound is heard. And it freezes at 00:00:00 and 0% not moving any further.

I used `sudo apt install pulseaudio` for installing pulseaudio.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...