[SOLVED] Amlogic S905 boxes


fossxplorer
 Share

1 1

Recommended Posts

I got couple of Amlogic S905 and S905x boxes.  And i think i've used at least a 7-8 hours to see if i can get these to work again. 

I tried to use the lastest images with S905 boxes, and it is has been a real hassle to get it working. Some times i had to hook up an USB disk in addition to get it to boot the rootfs.  And when i finally get into the OS, the network won't work. Both the built in Ethernet port and an USB Ethernet adapter. Both can detect a link, but unable to to receive IP from DHCP nor is it possible when manually assigned to get it to ping the GW.

 

Is support for such devices by @balbes150still something that he still does?

 

 

 

 

Link to post
Share on other sites

Donate and support the project!

5 hours ago, fossxplorer said:

I got couple of Amlogic S905 and S905x boxes

balbes150 not supporting Amlogic boxes going forward, but the current builds available should still work.  What dtb's have you tried?  What build are you using? And could you post the contents of your extlinux.conf file?  Also since there dozens of different s905/s905x boxes, each being different a little more information would be helpful.  You really have provided no information for anyone to be able to help you.

Link to post
Share on other sites

Thank a lot for your reply. And i apologize for not providing enough details.

I figured out by now that the issue was completely on my side. One of the switch port wasn't working hence not forwarding Ethernet packets to the gateway :(

Now i have one of the boxes, an MX Plus with S905, working with 1Gbit network.

 

@SteeMan thanks again!

 

 

 

Link to post
Share on other sites

  • fossxplorer changed the title to [SOLVED] Amlogic S905 boxes
On 11/12/2020 at 5:45 PM, SteeMan said:

balbes150 not supporting Amlogic boxes going forward, but the current builds available should still work. 

Ok, GREAT!.... Exactly what I was saying on the thread I started... There's no info. it's incomplete, stuff is not mentioned...

If you don't say this I would never find he is not enabling Amlogic even though he speaks about them on his latest instructions. (or what I can find and seems latest)

Link to post
Share on other sites

 Share

1 1