Hardware Encoding/Decoding for RK3399 on Helios64


Victor B.
 Share

10 10

Recommended Posts

Hello,


I am quite new to this topic, and I have found it to be quite complex. I primarily work with tiny MCUs and RTOSes, but I am enjoying the Linux space so far.

 

In essence I would like to use the Mali GPU that is embedded within the RK3399 of the Helios64 for hardware transcoding. This isn't a novel idea, as shown by these sources:

https://forum.armbian.com/topic/9272-development-rk3399-media-script/

https://emby.media/community/index.php?/topic/66675-36078-transcoding-rockpro64/

 

I am using Jellying, and in so FFMPEG to decode/encode the data streams. It seems that V4L2 is supported for hardware ecoding/decoding in the FFMPEG package, but in my experience doesn't appropriately work with the Mesa Panfrost drivers (https://wiki.debian.org/PanfrostLima) and the ARM drivers fail to compile with the kernel headers provided by the armbian-config script. I like the idea of having hardware accelerated transcoding, and I'm not even interested in 4K content, but my helios64 fails to transcode h265 (HEVC) to h264 at a playable rate. Secondly I like to have watch-togethers with my friends and I have to use my power-hungry PC for this. Of course I can introduce new hardware to do this like an arm64 laptop, but I like the all-in-one solution, and I simply can't be the only one that feels this way.


Has anyone had success with hardware acceleration? Any ROE or ongoing efforts?

Thanks,

Victor

Link to post
Share on other sites

Donate and support the project!

Hi,

I am also very interested in a solution. I use emby and would like to use the hardware encoding/decoding.

I'll do some research myself as soon as I have a little more time. 

If I find a good solution I'll post it here. At the moment I'm using the current 5.9 kernel and a downgrade is out of the question (at least for now).

Edited by realmiwi
Link to post
Share on other sites

Hi,

I too would very much like be interested by it! I bought a USB-C-to-HDMI cable, plugged a monitor, and everything worked well. I thought that using this + and USB DAC for audio, I could directly turn my Helios64 NAS into a media center.

 

Unfortunately I tried tried the RK3399 legacy multimedia framework (I just did  sudo apt install media-buster-legacy-rk3399 --install-recommends ; I thought no harm could happen by just installing a package) and now my NAS won't boot (U-boot stops after "starting kernel").

 

I  don't remember what kernel I installed, possibly this was not the legacy kernel. Thus, I would happily use some advice on how to unbrick my system -- and also upvote this vote, it would be terrific if the feature was installed in the default images or if there was an easy way to install them!

 

Bests

Link to post
Share on other sites

 Share

10 10