Buster image - unable to boot RockPi 4 B (1GB) board


hses
 Share

0
Go to solution Solved by NicoD,

Recommended Posts

It is my first RockPi 4 board and first Armbian install - board working OK with official Radxa image (Debian 9) and eMMC drive. Since my plan is to use just CLI I'm trying to install Armbian Buster images. Unforunately both "current" and "legacy" versions are not booting up. I have used SDFormatter (just in case) and Balena (as usual) on 16B Transcend Premim and 32GB SanDisk Ultra (A1) cards - same result: board is powered on but nothing happened at all. Only green diode is lighting but no signs from SD card (red diode is not showing up). eMMC card not connected in both cases.

I have checked other topics (i.e. ROCK64) but can not find a good solution how to proceed - your help is much appreciated.

Link to post
Share on other sites

Donate and support the project!

  • Solution

@hsesYou can try archived images. https://armbian.hosthatch.com/archive/rockpi-4b/archive/
5.8 should work. You can then update/upgrade.
@IgorAll rk3399 images seem troubled. I'm waiting to release a video about the Buster media script since no Buster Legacy image works on download page for RK3399. There are enough ways to make it work with either self build, archived or @balbes150 images.
I hope the beast will soon flex its muscles :) 

Link to post
Share on other sites

2 minutes ago, NicoD said:

You can then update/upgrade.


And don't update u-boot ... since u-boot in repository is still broken. Since this is manual procedure, this is not that problematic ...

 

3 minutes ago, NicoD said:

All rk3399 images seem troubled.


Maintaining legacy kernels is nightmare ... 

 

4 minutes ago, NicoD said:

either self build


You mean they work if you build them from sources, but not from the download section? Time for another round of bufix upgrade ... I am working on stabilising 5.10.y builds on all images and so far we are close to go.

Link to post
Share on other sites

2 minutes ago, Igor said:
7 minutes ago, NicoD said:

either self build


You mean they work if you build them from sources, but not from the download section?

Actually not. I build Buster Legacy for P1 with the desktop branche and there's no hdmi at boot. I used balbes image instead and this worked fine. 
I've not tried M4/M4V2 builds. There it was another problem with the rockpi4 BT driver. That should be fixed. I'll try building Buster Legacy for M4V2 and see this works. The P1 isn't as important as the M4/M4V2/RockPi4.

Link to post
Share on other sites

28 minutes ago, Igor said:

I am working on stabilising 5.10.y builds on all images and so far we are close to go.

Good. I am also working on some multimedia kernel-related stuff for legacy RK3399's, I am planning to push the changes very soon too. BTW, I understnad it is conveninet to make a Jira issue for it, because that way it is easier to incorporate it into the changelog, correct?

Link to post
Share on other sites

1 minute ago, Igor said:

That is expected. We don't support P1.

 

Indeed, that's why I find that less important. 
I'm now building legacy buster for M4V2. Too bad I don't have the RockPi4 anymore to test.
I had this thought yesterday, but it might be too much work, or not work at all. I only can share my thought. "It would be nice if after building an image, and confirm it working. That the user could upload this as "User uploaded". Certainly for the new desktops this could be handy."  
It would take up bandwidth and server space. Just an idea...

2 minutes ago, Igor said:

Very nice to see. 

Link to post
Share on other sites

36 minutes ago, JMCC said:

understnad it is conveninet to make a Jira issue for it, because that way it is easier to incorporate it into the changelog, correct?


Correct.

 

32 minutes ago, NicoD said:

I had this thought yesterday, but it might be too much work, or not work at all. I only can share my thought. "It would be nice if after building an image, and confirm it working.

 

We tried that https://github.com/armbian/testings but it was not very useful. 

 

We have better technology for this since it is at most important to have this information when we need it, but system needs more then one brain -> https://github.com/armbian/autotests to maintain it. I use it on a daily basis, but not on the level I would want. Changing kernel is buggy which is why legacy kernels on RK3399 are not tested at all.

Link to post
Share on other sites

@IgorI can confirm that freshly build Buster Legacy on the M4V2 is working. I love the native ARM build, so much faster than the RockPiX :) And that's RK3399, haven't gotten N2+ to work yet.

Spoiler

[ o.k. ] Done building [ /home/nicod/build-desktop/output/images/Armbian_21.02.0-trunk_Nanopim4v2_buster_legacy_4.4.213_xfce_desktop.img ]
umount: /home/nicod/build-desktop/.tmp/rootfs-8a1474672572673d347e66750ca71d0d: not mounted.
[ o.k. ] Runtime [ 80 min ]
[ o.k. ] Repeat Build Options [ ./compile.sh  BOARD=nanopim4v2 BRANCH=legacy RELEASE=buster BUILD_MINIMAL=no BUILD_DESKTOP=yes KERNEL_ONLY=no KERNEL_CONFIGURE=no DESKTOP_ENVIRONMENT=xfce DESKTOP_ENVIRONMENT_CONFIG_NAME=config_base DESKTOP_APPGROUPS_SELECTED="browsers chat desktop_tools editors email internet internet-tools multimedia office programming remote_desktop" COMPRESS_OUTPUTIMAGE=sha,gpg,img  ]

 


I do not know what the problem with the RockPi4 image is.
It can't have been the same issue as M4V2. The discription makes me think it's also hdmi not working as with P1.

Link to post
Share on other sites

13 minutes ago, NicoD said:

I do not know what the problem with the RockPi4 image is.


From master branch? 

 

15 minutes ago, NicoD said:

It can't have been the same issue as M4V2


If you build on desktop branch / natively ... it can be anything. Its known that at least 30% images can't be build since work is not done yet.

Link to post
Share on other sites

2 minutes ago, Igor said:

If you build on desktop branch / natively ... it can be anything. Its known that at least 30% images can't be build since work is not done yet.

I did build from desktop branch on RK3399 and the image works. No issues at all, except a new bug in the media script.
It would be good if RK3399 images are rebuild. If RockPi4 now doesn't work, we can't do anything wrong by uploading another non working image for it. We can only get a bit more feedback on the state of things.

Link to post
Share on other sites

20 minutes ago, NicoD said:

we can't do anything wrong by uploading

 

Rebuilding images with existing kernel? Or from sources? That is much more problematic and not something I will do by the way without eating shit. Which I already had enough today.

 

If froum sources - make a list - remove what doesn't need to be included https://github.com/armbian/build/blob/master/config/targets.conf 

Link to post
Share on other sites

On 12/28/2020 at 2:09 PM, NicoD said:

@hsesYou can try archived images. https://armbian.hosthatch.com/archive/rockpi-4b/archive/
5.8 should work. You can then update/upgrade.
@IgorAll rk3399 images seem troubled. I'm waiting to release a video about the Buster media script since no Buster Legacy image works on download page for RK3399. There are enough ways to make it work with either self build, archived or @balbes150 images.
I hope the beast will soon flex its muscles :) 

Dear ALL - thank you for all info provided! @NicoD link helped to run 5.8 Debian CLI version (on SD) first and easily update and upgrade. The only problem I have noticed is HDMI signal quality (?) - not as bad as in case of Diet version for RockPi4 - but still not usable. Screen "shakes" and it is not possible to work with (however it looks that system settings are OK for my Samsung screen). The good thing is that it is possile to set basic configuration (i.e. WiFi in my case) and go to SSH. My RockPi4 is planned for headless jobs anyway, thus I have to say - IT WORKS!! THANX!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0